LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-08-2005, 02:39 PM   #1
libriana
LQ Newbie
 
Registered: Jun 2005
Location: Nicaragua
Distribution: Ubuntu Edgy
Posts: 5

Rep: Reputation: 0
Problem with sound driver


Hello!

I'min trouble trying to install Fedora Core 3, with my sound driver.
It's not detected any sound card, and when I install another one (Genius PCI)
The entire system hang up, even if I try CTRL + ALT + BACKSPACE
I'm newbie, and I dont know how to fix it, any suggestion will be apreciated

My Hardware it's a clon
I have a VIA VT8235 mainboard
Intel Pentium 4 1,80 GHz
256 RAM
HDD MAXTOR 40 gb

Another specificatios
[root@Administracion ~]# /sbin/lspci
00:00.0 Host bridge: VIA Technologies, Inc. P4M266 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.2 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: S3 Inc. VT8375 [ProSavage8 KM266/KL266]

Kernel version
[root@Administracion ~]#uname -r
2.6.9-1.667 kernel for Fedora Core 3

Modeprobe
alias eth0 via-rhine
install snd-cmipci /sbin/modprobe --ignore-install snd-cmipci && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

Modprobe with the other snd card
alias eth0 via-rhine
alias snd-card-0 snd-cmipci
options snd-card-0 index=0
install snd-cmipci /sbin/modprobe --ignore-install snd-cmipci && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
remove snd-cmipci { /usr/sbin/alsactl store >/dev/null 2>&1 || : ; }; /sbin/modprobe -r --ignore-remove snd-cmipci
alias usb-controller ehci-hcd
alias usb-controller1 uhci-hcd

Thanks for your answers,
 
Old 09-09-2005, 06:50 PM   #2
comprookie2000
Gentoo Developer
 
Registered: Feb 2004
Location: Fort Lauderdale FL.
Distribution: Gentoo
Posts: 3,291
Blog Entries: 5

Rep: Reputation: 56
The onboard card is c-media;
http://www.alsa-project.org/alsa-doc...&module=cmipci
That Genius is here (I think);
http://www.alsa-project.org/alsa-doc...-Genius#matrix
If you want to use the pci soundcard I would disable the onboard sound in the bios.
Quote:
It's not detected any sound card
Looks like it found a C-Media
install snd-cmipci /sbin/modprobe --ignore-install snd-cmipci && /usr/sbin/alsactl restore >/dev/null 2>&1 || :
Did you run alsamixer and make sure to check if your PCM and Master volumes
are not muted. More on alsa;
http://www.linuxjournal.com/article/8234
Most times with fedora the sound will work out of the box.
Hope this helps
 
Old 09-13-2005, 11:55 AM   #3
libriana
LQ Newbie
 
Registered: Jun 2005
Location: Nicaragua
Distribution: Ubuntu Edgy
Posts: 5

Original Poster
Rep: Reputation: 0
Hello Comprokie2000,

Than's for your reply, you gave me the answer, it was a bios configuration problem.

If somebody have the same problem, I hope this can helps.

Regards
Libriana
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Sound driver problem Developer Beaud Linux - General 2 07-10-2005 05:16 PM
sound driver problem shdhnd Debian 1 07-28-2004 01:30 PM
Sound driver problem... SGFHK321 Linux - Newbie 4 07-09-2004 09:20 PM
sound driver problem Aksingh Linux - Software 1 05-29-2003 04:13 AM
Sound driver problem Stephanie Linux - General 5 05-18-2002 12:45 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 10:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration