LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-04-2007, 11:08 AM   #1
bramsey123
LQ Newbie
 
Registered: Aug 2007
Posts: 7

Rep: Reputation: 0
PCI Card not allowing the System to Boot


I am currently trying to develop a pci card/driver. Currently I have gotten the card and driver to work on an older machine with the following specs.

root@localhost TestCode]# cat /proc/cpuinfo

processor : 0
vendor_id : GenuineIntel
cpu family : 6
model : 11
model name : Intel(R) Celeron(TM) CPU 1200MHz
stepping : 1
cpu MHz : 1196.927
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 2
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 mmx fxsr sse
bogomips : 2394.96
clflush size : 32

However when I try to plug my board into a newer machine with the following specs....

[root@localhost bramsey]# cat /proc/cpuinfo
processor : 0
vendor_id : GenuineIntel
cpu family : 15
model : 4
model name : Intel(R) Celeron(R) CPU 2.93GHz
stepping : 9
cpu MHz : 2933.536
cache size : 256 KB
fdiv_bug : no
hlt_bug : no
f00f_bug : no
coma_bug : no
fpu : yes
fpu_exception : yes
cpuid level : 5
wp : yes
flags : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge
mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe nx
lm constant_tsc up pni monitor ds_cpl tm2 cid cx16 xtpr lahf_lm
bogomips : 5870.73
clflush size : 64

The system will not boot. It freezes at the splash screen for the BIOS. Any ideas on how to trouble shoot this issue would be great. Thanks.
 
Old 10-04-2007, 11:39 AM   #2
farslayer
LQ Guru
 
Registered: Oct 2005
Location: Northeast Ohio
Distribution: linuxdebian
Posts: 7,243
Blog Entries: 5

Rep: Reputation: 190Reputation: 190
well if it's freezing at POST that's prior to the driver loading.

I would recommend getting a POST card to find out where in the boot sequence the system is halting. Might provide you some insight to the problem with the hardware.

http://www.uxd.com/hardware-diagnostics.shtml

http://shopv2.elstonsystems.com/inde...643aa6738719d4

http://www.pc-diagnostics.com/pc_dia..._pci_bus.shtml

http://www.elstonsystems.com/products.html
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Failed to load ISDN-PCI-card during boot UncleBenz Linux - Hardware 0 06-07-2006 01:14 PM
xilinx system ace driver for compact flash on a fpga based pci card doesnt work urwithsudheer Programming 0 03-22-2006 03:28 AM
Boot from disk on IDE IT8212 raid PCI card zenithpbarm Slackware 2 03-08-2006 02:33 PM
Embeded linux PCI card backup system Nigel_Tufnel Linux - Hardware 2 05-05-2004 06:36 AM
Nvidia FX 5200 PCI Card (System bus / DDR Ram Question) sergeantroach Linux - Hardware 6 02-08-2004 01:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 11:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration