LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-14-2006, 03:31 AM   #1
idahoakl
LQ Newbie
 
Registered: Feb 2005
Location: Idaho
Distribution: Fedora Core 5
Posts: 7

Rep: Reputation: 0
lirc_atiusb 0.8.1 being ignored by udev


I have a remote for a mythtv system that uses the lirc_atiusb module to run. I upgraded everything tonight and upon rebooting the system it hung at the udev stage. I looked into and found that it would get past the udev stage if I unplugged the remote reciever. I tried plugging the reciever in again once I was logged in and then checked the messages to see what was going on. This is what I was seeing:

Sep 14 01:16:50 localhost udevd[339]: udev_event_run: seq 601 forked, pid [2426], 'add' 'module', 0 seconds old
Sep 14 01:16:50 localhost kernel: lirc_dev: IR Remote Control driver registered, at major 61
Sep 14 01:16:50 localhost udevd-event[2426]: udev_rules_get_run: rule applied, 'lirc_dev' is ignored
Sep 14 01:16:50 localhost udevd-event[2426]: udev_device_event: device event will be ignored
Sep 14 01:16:50 localhost udevd-event[2426]: udev_event_run: seq 601 finished
Sep 14 01:16:50 localhost udevd[339]: udev_event_run: seq 602 forked, pid [2427], 'add' 'module', 0 seconds old
Sep 14 01:16:50 localhost kernel:
Sep 14 01:16:50 localhost udevd[339]: udev_done: seq 601, pid [2426] exit with 0, 0 seconds old
Sep 14 01:16:50 localhost kernel: lirc_atiusb: USB remote driver for LIRC v0.5
Sep 14 01:16:50 localhost udevd-event[2427]: udev_rules_get_run: rule applied, 'lirc_atiusb' is ignored
Sep 14 01:16:50 localhost kernel: lirc_atiusb: Paul Miller <pmiller9@users.sourceforge.net>
Sep 14 01:16:50 localhost udevd-event[2427]: udev_device_event: device event will be ignored
Sep 14 01:16:50 localhost udevd-event[2427]: udev_event_run: seq 602 finished
Sep 14 01:16:50 localhost udevd[339]: udev_done: seq 602, pid [2427] exit with 0, 0 seconds old

I went through and was trying to play with the lirc.rules file. I did find on other boards that udev under went some changes on how it read rules. It required == instead of = for matching, I tried this to no avail. My current lirc.rules file is:

KERNEL=="lirc[0-9]*", NAME="lirc/%n"

Any help on any of this would be greatly appreciated.

System information:
FC5
2.6.17-1.2174_FC5 kernel
lirc-0.8.1-61_cvs20060628 installed from atrpms
udev-084-13 also installed from atrpms

Thank you again

Matt
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
udev hosler Slackware 10 08-12-2006 02:02 PM
slackware-current, udev 0.96, and custom udev rules not working rignes Slackware 6 08-10-2006 03:43 AM
Udev LinxNew Mandriva 1 05-01-2005 02:47 PM
Udev anyone? yanik Debian 5 01-05-2005 09:02 AM
udev ... I think element Debian 4 05-27-2004 03:32 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 01:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration