LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 07-18-2006, 02:51 PM   #1
Tommi Viitanen
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Rep: Reputation: 0
Joystick,dmesg


I have connected a Joystick, which has been working earlier in an other Linux-machine. In the new machine it's not working. Both Linux have Kernel 2.6

~$ lspci | grep -i audio
0000:01:02.0 Multimedia audio controller: Creative Labs SB Live! EMU10k1 (rev 08)

But:

dmesg | grep -i Joystick

gives nothing.

I have also tried:

modprobe analog
modprobe joydev
modprobe ns558

but they don't change anything.

Tommi
 
Old 07-19-2006, 12:39 PM   #2
ugenn
Member
 
Registered: Apr 2002
Posts: 549

Rep: Reputation: 30
Check your /dev/js* devices. Do they exist? Permissions right?
 
Old 07-19-2006, 07:33 PM   #3
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,201

Rep: Reputation: 51
I've been having the same problem. Although I hadn't tried using one before with earlier versions of Slack and kernels. I did the same dmesg check, tried the kernel components both as modules and as built-in, checked the /dev/js* and even tried creating the nodes - all with no success. Some searching led me to posts that suggest recent kernels, later 2.6.x series, have broken joystick support.
 
Old 07-21-2006, 01:44 PM   #4
Tommi Viitanen
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by ugenn
Check your /dev/js* devices. Do they exist? Permissions right?
Yes, I have made this by:
mknod /dev/input/ js0 c 13 0

and permissions are:
crw-r--r

I changed them by chmod 755 to:
crwxr-xr-r

but it's not working.
 
Old 07-21-2006, 08:04 PM   #5
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,617

Rep: Reputation: 103Reputation: 103
If you are using that SB Live to connect too then you need the emu10k1-gp module loaded. This is what I have for permission on my js devices.

Code:
ls -l /dev/input/js*
crw-rw---- 1 root root 13, 0 2005-08-13 21:30 /dev/input/js0
crw-rw---- 1 root root 13, 1 2005-08-13 21:30 /dev/input/js1
crw-rw---- 1 root root 13, 2 2005-08-13 21:30 /dev/input/js2
crw-rw---- 1 root root 13, 3 2005-08-13 21:30 /dev/input/js3
 
Old 07-21-2006, 08:31 PM   #6
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,248
Blog Entries: 8

Rep: Reputation: 235Reputation: 235Reputation: 235
where does your joystick connect? usb or parport? if usb, maybe you're having problems with your usb drivers.

you can try adding Joystick_port=1 in your modules config (e.g. in gentoo /etc/modules.d/alsa)
Code:
options snd-[modname] Joystick_port=1
after you set this if you're using gentoo, do etc-update and sometimes modules-update

you can also try testing your joystick simply by doing 'cat /dev/input/js#' then play around with your joystick. see if there are messages appearing. you can also use a program named jtest here.

if all device drivers are working maybe you have a problem detecting your joystick. check your joystick to other system or other machines. that's the only way i know.

regards

Edit: if 'Joystick_port=1' is not working for you try 'joystick=1' instead.

Last edited by konsolebox; 07-21-2006 at 09:14 PM.
 
Old 07-22-2006, 03:14 AM   #7
Tommi Viitanen
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Original Poster
Rep: Reputation: 0
alsa

Quote:
Originally Posted by konsolebox
where does your joystick connect? usb or parport? if usb, maybe you're having problems with your usb drivers.

It's connected in soundcard. Earlier I have succeeded with SB, so I have that connected at the moment.

you can try adding Joystick_port=1 in your modules config (e.g. in gentoo /etc/modules.d/alsa)
Code:
options snd-[modname] Joystick_port=1
after you set this if you're using gentoo, do etc-update and sometimes modules-update

I have
1) etc/modutils/alsa-base
2) etc/modprobe.d/
3) etc/modules
4) etc/modprobe.conf

Which one of these 4 is the right ?

if all device drivers are working maybe you have a problem detecting your joystick. check your joystick to other system or other machines. that's the only way i know.

Ok, thank you

regards

Edit: if 'Joystick_port=1' is not working for you try 'joystick=1' instead.
123456789011243
 
Old 07-22-2006, 04:20 AM   #8
konsolebox
Senior Member
 
Registered: Oct 2005
Distribution: Gentoo, Slackware, LFS
Posts: 2,248
Blog Entries: 8

Rep: Reputation: 235Reputation: 235Reputation: 235
this depends on distros. but try doing
Code:
grep -r "options snd-" -rl
it will show you the default file you're using.

i also recommend reading this HOWTO from Gentoo. this is where i get the idea on how i installed my joystick.
http://gentoo-wiki.com/HOWTO_Joystick_Setup
 
Old 07-25-2006, 05:37 AM   #9
Tommi Viitanen
LQ Newbie
 
Registered: Jul 2006
Posts: 4

Original Poster
Rep: Reputation: 0
[QUOTE=konsolebox]this depends on distros. but try doing
Code:
grep -r "options snd-" -rl
it will show you the default file you're using.

That code does not give any answer, but now I get:

dmesg | grep -i gameport
gameport: EMU10K1 is pci0000:01:02.1/gameport0, io 0x20a0, speed 1147kHz

But: cat /dev/input/js0
tells that: No such device

I'v loaded modules: analog joydev ns558 and emu10k1-gp
(this doesn't work by: snd-emu.... or snd_emu... but only by: modprobe emu10k1-gp (which give no answer))

I'v set the permissions (is the other than js0 really deeded):
crw-rw---- 1 root root 13, 0 2006-07-13 13:21 /dev/input/js0
crw-rw---- 1 root root 13, 0 2006-07-25 00:34 /dev/input/js1
crw-rw---- 1 root root 13, 0 2006-07-25 11:49 /dev/input/js2
crw-rw---- 1 root root 13, 0 2006-07-25 11:49 /dev/input/js3
crw-rw---- 1 root root 13, 0 2006-07-25 11:49 /dev/input/js4

Thanks for everyone anyway !
 
Old 08-12-2006, 09:15 PM   #10
dracolich
Senior Member
 
Registered: Jul 2005
Distribution: Slackware
Posts: 1,201

Rep: Reputation: 51
I finally solved mine. I have to load the sound driver module with the option "joystick_port=1", which is case-sensitive. These are the steps (for mine) in order.

1. stop alsa - /etc/rc.d/rc.alsa stop
2. unload the sound module - modprobe -r ens1371
3. reload with option - modprobe ens1371 joystick_port=1
4. reload joystick - modprobe analog
5. restart alsa - /etc/rc.d/rc.alsa restart

After which the /dev/input/js0 device appears. I then create the symlink /dev/js0 -> /dev/input/js0 and everything is fine.

My card is a SB16PCI, not a SB Live, but maybe this will help.

Good luck.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dmesg (command) and /var/log/dmesg are different? Oxagast Linux - Software 2 07-10-2006 05:50 AM
Joystick Driver and API under kernel 2.6.12.3 using an USB joystick dispatcher Linux - Newbie 1 08-06-2005 09:43 AM
dmesg HELP oldi Slackware 7 07-17-2004 09:14 AM
/bin/dmesg > /dmesg-boot not Working in Knoppix 3.4 suguru Debian 2 07-04-2004 05:21 PM
dmesg XPediTioN Slackware 22 07-17-2003 08:21 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 03:04 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration