LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 09-04-2008, 12:06 AM   #16
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 131Reputation: 131

Now that you mention ATI... I had exactly the same problem with an ATI 1600 after adding 2GB of RAM. But that was 32 bit Ubuntu 7.04 or 7.10 so I thought that the real problem was the 32 bit server kernel not knowing how to handle 4GB. When I installed the 64 bit version, the problem was gone. But you already have a 64 bit kernel... Does it actually see all of your RAM? What is the output of free -m?
 
Old 09-04-2008, 01:54 AM   #17
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I assume you explaining about DDR2. The memory speed 1066 MHz is overclocked, so some memory modules may need their timings changed and/or their voltage increase to provide a stable 1066 MHz. I suggest stepping down to 800 MHz which will be the normal speed. Increasing the voltage of the memory to 1.9 volts is OK. Other causes of memory instability is heat, so I suggest buy some RAM heatsinks.

Try changing fglrx in /etc/X11/xorg.conf to radeon. If that helps, then complain to ATI about the problem using a 64-bit Linux and with more than 2 GB of RAM.
 
Old 09-04-2008, 09:00 AM   #18
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 282

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by Electro View Post
I assume you explaining about DDR2. The memory speed 1066 MHz is overclocked, so some memory modules may need their timings changed and/or their voltage increase to provide a stable 1066 MHz. I suggest stepping down to 800 MHz which will be the normal speed. Increasing the voltage of the memory to 1.9 volts is OK. Other causes of memory instability is heat, so I suggest buy some RAM heatsinks.

Try changing fglrx in /etc/X11/xorg.conf to radeon. If that helps, then complain to ATI about the problem using a 64-bit Linux and with more than 2 GB of RAM.
the speed of the ram is at stock settings of 800 the timings are identicle and they do have heat sinks already, I am not sure why I would have to change my xorg.config if it worked before I put the extra 2 gbs of ram in if I have all 4 gbs of ram it ( for some reason) won't boot to desk top it just freezes just before I get to desktop, I have to reboot in recovery mode and select the "fix x server" setting then reboot and I can get to my desktop but for some reason it only gives me a desktop resolution of 640x480 now if I go into the system/admin hardware driver settings and turn back on the ATI accelerated graphics driver then reboot I end up back to the same problem.
I am wondering if it is a bug in Ubuntu and I might have to do a fresh install which I really want to avoid since I pretty much have everything set up the way I want except ofcourse the ram part.
 
Old 09-04-2008, 09:06 AM   #19
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 131Reputation: 131
Electro's suggestion makes sense even if your RAM is 800Mhz. Some motherboards and brands of RAM simply do not work together all that well. ASUS and OCZ come to mind. Nine times out of time, the problem is that the RAM requires different voltages from what the motherboard default to, in which case you have to correct them manually.
 
Old 09-04-2008, 09:22 AM   #20
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 282

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by jay73 View Post
Electro's suggestion makes sense even if your RAM is 800Mhz. Some motherboards and brands of RAM simply do not work together all that well. ASUS and OCZ come to mind. Nine times out of time, the problem is that the RAM requires different voltages from what the motherboard default to, in which case you have to correct them manually.
so I should try and increase the voltages up to 1.9 volts well this is a new thing for me but I will try.

I posted the same problem on the Ubuntu forums yesterday( morning) I did wait for a response before posting here but didn't get one after a few hours I then posted here . I just checked my Post on the Ububuntui forums and someone did reply saying
Quote:
Originally Posted by IntuitiveNipple View Post
When you use the LiveCD it probably uses different video drivers than you've got installed.

What most likely causes this is the video card needing to allocate a large range of PCI IOMEM but, because you've got 4GB of RAM installed, there is not enough free IOMEM address space below the 4GB boundary for the PCI IOMEM window - video devices usually need 256MB or 512MB.

When the PC only has 2GB of RAM, there's a window of 1.25GB available for PCI IOMEM. With 4GB of RAM, 1GB is mapped above the 4GB boundary, leaving just 256MB of PCI IOMEM space between the 3GB and 4GB boundaries.

As all PCI devices in the system have to share this space, and the video device isn't the first to request an IOMEM allocation, the system doesn't have enough IOMEM space and the video device doesn't get any.

That means it will only operate in text and low-resolution graphics modes. When a high-resolution mode is attempted it can't do it, and fails the way you describe.

There isn't a solution at present. I'm currently putting the finishing touches to new Linux kernel PCI IOMEM allocation system that works as well as, if not better than, Windows. That won't appear in mainline for a few months though, and I doubt it'll get backported to existing releases.
now in one way this does make a little sense but in another way it doesn't because I am very sure that there are other people out there that have 4 gbs or even more Gigs of ram on there Ubuntu os just wondering if it makes sense to anyone here
 
Old 09-04-2008, 11:03 AM   #21
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 282

Original Poster
Rep: Reputation: 29
Quote:
Increasing the voltage of the memory to 1.9 volts is OK.
how do I find out what the voltage of my mem is because when I go into my Bios it only shows that I can increase volatge by 0,1 incriments it doesn't show the total voltage of my Ram ( what the voltage is of my ram)

Quote:
Originally Posted by jay73 View Post
... Does it actually see all of your RAM? What is the output of free -m?
this is the out put of free -m
total used free shared buffers cached
Mem: 3958 936 3022 0 32 398
-/+ buffers/cache: 505 3453
Swap: 1027 0 1027

so I am thinking that it is seeing all of the ram

Last edited by Shadowmeph; 09-04-2008 at 11:13 AM.
 
Old 09-04-2008, 11:11 AM   #22
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 131Reputation: 131
Have you checked whether your motherboard has an option to enable memory mapping? Memory mapping leaves only 2GB of RAM within the 4GB space so there is plenty of room for other devices; the remaining RAM gets mapped over the 4GB limit. That is why I first suggested to try mem=6144MB (which amounts to 6GB), i.e. 4GB memory space and 2GB outside it. Some motherboards haven't (my latest MSi for example) while other ones have (my older ASUS).

Last edited by jay73; 09-04-2008 at 11:12 AM.
 
Old 09-04-2008, 11:57 AM   #23
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 282

Original Poster
Rep: Reputation: 29
I read my Motherboard manual and I could find anything on Memory mapping in there. Hmm this looks like I am stuck and have to remove 2Gb of ram man just as I was really starting to Like Linux lol
 
Old 09-04-2008, 12:03 PM   #24
jay73
LQ Guru
 
Registered: Nov 2006
Location: Belgium
Distribution: Ubuntu 11.04, Debian testing
Posts: 5,019

Rep: Reputation: 131Reputation: 131
If it is a hardware issue, then it would very likely affect Windows, too. Just try google and you'll find plenty of windows users reporting the same problem.
 
Old 09-04-2008, 12:25 PM   #25
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 282

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by jay73 View Post
If it is a hardware issue, then it would very likely affect Windows, too. Just try google and you'll find plenty of windows users reporting the same problem.
I think I am going to try and install Ubuntu with the 4gigs ram on a small blank 10 gig partition I have just to see if it works on there what else do I have to lose I refuse to go back to the Microsoft conglomerate

Edit

ok so I tryed my idea it came to the same result.so I will just remove the other 2gigs ram and use just 2 gigs of ram

Last edited by Shadowmeph; 09-04-2008 at 01:09 PM.
 
Old 09-05-2008, 12:34 AM   #26
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
I said two things. One increase the voltage of the memory for more stability, but make sure you are within limits of the memory. The second is change the driver from fglrx (proprietary ATI driver) to radeon (open source driver). The reason why to use a different driver is because the open source driver is mostly to have less problems.

I suggest try a 64-bit version of Knoppix. If it works than Ubuntu developers patched the wrong lines of code or their additions are screwing up some driver and probably the fglrx driver is not compatible with 4 GB of RAM.

Probably listing your motherboard and kernel config will gives us a better idea of your setup.
 
Old 09-05-2008, 09:51 AM   #27
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 282

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by Electro View Post
I said two things. One increase the voltage of the memory for more stability, but make sure you are within limits of the memory. The second is change the driver from fglrx (proprietary ATI driver) to radeon (open source driver). The reason why to use a different driver is because the open source driver is mostly to have less problems.

I suggest try a 64-bit version of Knoppix. If it works than Ubuntu developers patched the wrong lines of code or their additions are screwing up some driver and probably the fglrx driver is not compatible with 4 GB of RAM.

Probably listing your motherboard and kernel config will gives us a better idea of your setup.
ok first thing is how do I find out what the voltage of my mem is because when I go into my Bios it only shows that I can increase volatge by 0,1 incriments it doesn't show the total voltage of my Ram ( what the voltage is of my ram)
And I am guessing that I can just go into my xorg.conf and just exchange the "driver "fglrx" to driver "radeon" if I do this will I lose the accerated driver what I mean is will I still be able to play an online game and get my average of 144fps?
 
Old 09-05-2008, 10:48 AM   #28
amani
Senior Member
 
Registered: Jul 2006
Location: Kolkata, India
Distribution: Debian 64-bit GNU/Linux, Kubuntu64, Fedora QA, Slackware,
Posts: 2,766

Rep: Reputation: Disabled
You need to uninstall all fglrx completely and then change the driver line to radeon. 'radeon' is ok with 3D, hardware acceleration, compiz, etc and is often better than fglrx

You can use memtest to get more details of your RAM
or try hwinfo
 
Old 09-05-2008, 11:19 AM   #29
Shadowmeph
Member
 
Registered: May 2008
Location: West Coast Canada
Posts: 282

Original Poster
Rep: Reputation: 29
Quote:
Originally Posted by amani View Post
You need to uninstall all fglrx completely and then change the driver line to radeon. 'radeon' is ok with 3D, hardware acceleration, compiz, etc and is often better than fglrx

You can use memtest to get more details of your RAM
or try hwinfo
I did the hwinfo ( had to install it first) but it didn't show anything about my ram this is what it showed
Code:
 Driver Modules: "usbcore"
  Speed: 12 Mbps
  Module Alias: "usb:v0000p0000d0206dc09dsc00dp00ic09isc00ip00"
  Driver Info #0:
    Driver Status: usbcore is active
    Driver Activation Cmd: "modprobe usbcore"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #40 (USB Controller)

60: ADB 00.0: 10502 Bus Mouse
  [Created at input.159]
  UDI: /org/freedesktop/Hal/devices/computer_logicaldev_input
  Unique ID: kZYT.9XB1QYZ8Aa7
  Hardware Class: mouse
  Model: "Apple Macintosh mouse button emulation"
  Vendor: int 0x0100 "Apple"
  Device: int 0x0300 "Macintosh mouse button emulation"
  Compatible to: int 0x0210 0x0003
  Device File: /dev/input/mice (/dev/input/mouse0)
  Device Files: /dev/input/mice, /dev/input/mouse0, /dev/input/event0
  Device Number: char 13:63 (char 13:32)
  Driver Info #0:
    Buttons: 3
    Wheels: 0
    XFree86 Protocol: explorerps/2
    GPM Protocol: exps2
  Config Status: cfg=new, avail=yes, need=no, active=unknown

61: None 00.0: 10103 CPU
  [Created at cpu.304]
  Unique ID: rdCR.j8NaKXDZtZ6
  Hardware Class: cpu
  Arch: X86-64
  Vendor: "GenuineIntel"
  Model: 6.23.6 "Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz"
  Features: fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,ht,tm,pbe,syscall,nx,lm,constant_tsc,arch_perfmon,pebs,bts,rep_good,pni,monitor,ds_cpl,vmx,smx,est,tm2,ssse3,cx16,xtpr,sse4_1,lahf_lm
  Clock: 3000 MHz
  BogoMips: 6004.21
  Cache: 6144 kb
  Units/Processor: 2
  Config Status: cfg=new, avail=yes, need=no, active=unknown

62: None 01.0: 10103 CPU
  [Created at cpu.304]
  Unique ID: wkFv.j8NaKXDZtZ6
  Hardware Class: cpu
  Arch: X86-64
  Vendor: "GenuineIntel"
  Model: 6.23.6 "Intel(R) Core(TM)2 Duo CPU     E8400  @ 3.00GHz"
  Features: fpu,vme,de,pse,tsc,msr,pae,mce,cx8,apic,sep,mtrr,pge,mca,cmov,pat,pse36,clflush,dts,acpi,mmx,fxsr,sse,sse2,ss,ht,tm,pbe,syscall,nx,lm,constant_tsc,arch_perfmon,pebs,bts,rep_good,pni,monitor,ds_cpl,vmx,smx,est,tm2,ssse3,cx16,xtpr,sse4_1,lahf_lm
  Clock: 3000 MHz
  BogoMips: 5999.94
  Cache: 6144 kb
  Units/Processor: 2
  Config Status: cfg=new, avail=yes, need=no, active=unknown

63: None 01.0: 10701 Ethernet
  [Created at net.125]
  Unique ID: L2Ua.ndpeucax6V1
  Parent ID: JNkJ.49XPc+GN1h3
  SysFS ID: /class/net/eth1
  SysFS Device Link: /devices/pci0000:00/0000:00:1e.0/0000:07:02.0
  Hardware Class: network interface
  Model: "Ethernet network interface"
  Driver: "e1000"
  Driver Modules: "e1000"
  Device File: eth1
  HW Address: 00:1b:21:17:06:e9
  Link detected: yes
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #15 (Ethernet controller)

64: None 00.0: 10701 Ethernet
  [Created at net.125]
  Unique ID: usDW.ndpeucax6V1
  Parent ID: rBUF.WkkGS5m8Th0
  SysFS ID: /class/net/eth0
  SysFS Device Link: /devices/pci0000:00/0000:00:1c.4/0000:06:00.0
  Hardware Class: network interface
  Model: "Ethernet network interface"
  Driver: "r8169"
  Driver Modules: "r8169"
  Device File: eth0
  HW Address: 00:1a:4d:4f:27:68
  Link detected: no
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #17 (Ethernet controller)

65: None 00.0: 10700 Loopback
  [Created at net.125]
  Unique ID: ZsBS.GQNx7L4uPNA
  SysFS ID: /class/net/lo
  Hardware Class: network interface
  Model: "Loopback network interface"
  Device File: lo
  Link detected: yes
  Config Status: cfg=new, avail=yes, need=no, active=unknown
 
Old 09-05-2008, 02:08 PM   #30
Electro
LQ Guru
 
Registered: Jan 2002
Posts: 6,042

Rep: Reputation: Disabled
The utility hwinfo sucks and by Gentoo developers it is unstable. I suggest lshw because it is more informative. You will have to use root or sudo to use lshw.

Do not need to remove fglrx. Just need to edit /etc/X11/xorg.conf to change that reads fglrx to radeon. Yes, you will get 3D accerlation, but performance depends what options you include to speed it up and what optimization that the maintainer used for the X11 module. Though may have to edit /etc/modules.conf so that fglrx module is not loaded, but this file is different for each distribution.

I do not think you will ever get the chance of getting information about what voltage your memory is set at because hwinfo gave a clue that it is an Apple computer. Usually with end-user motherboards the voltages are in the diagnostics section of the BIOS. Sure software like lm_sensors can be used to look up the data of the diagnostic chip, but it is not always accurate.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: Installing VMWare Server 2 Beta in Ubuntu Hardy 64bit LXer Syndicated Linux News 0 07-01-2008 12:50 AM
Adding LVM to menu in Hardy Heron desktop version Linux31 Ubuntu 3 05-11-2008 05:09 AM
All RAM not being recognized on Linux RHEL after adding RAM manouche Linux - Enterprise 4 04-18-2008 10:31 AM
Suse 10.3 hangs on Pentium-D 64bit 1GB Ram jtm_tango Linux - Newbie 3 11-17-2007 01:46 PM
How do I enable 64GB RAM support on Suse 10.1 64bit ajitup Linux - Kernel 5 11-23-2006 10:18 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:10 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration