LinuxQuestions.org
Go Job Hunting at the LQ Job Marketplace
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 10-06-2013, 01:06 PM   #1
Mother_Brain
LQ Newbie
 
Registered: Oct 2013
Posts: 3

Rep: Reputation: Disabled
Hybrid graphics Intel/ATI with vga_switcheroo


Hi! I bought recently a new laptop, a Samsung Series 5 model. I realized that the battery discharges in a very short time using Debian, while using Windows 7 I can work about 4 or 5 hours (with Debian only one and a half, two if I'm lucky). After doing a lspci, I discovered that it has two graphic cards, an Intel integrated card and an ATI Radeon. It looks like a wrong management of this Intel/ATI hybrid graphic system.

I searched on the web, and I found a lot of webpages talking about vga_switcheroo as an option to manage this hybrid systems. I followed the steps that were described on those websites, but I think they didn't work. First of all I'm going to show you the output of the lspci:

Code:
    00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
    00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
    00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
    00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
    00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 04)
    00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 04)
    00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b4)
    00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b4)
    00:1c.4 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 (rev b4)
    00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 04)
    00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 04)
    00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 04)
    00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 04)
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon 7550M/7570M/7650M]
    02:00.0 Network controller: Intel Corporation Centrino Advanced-N 6230 [Rainbow Peak] (rev 34)
    03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller (rev 06)
    04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
The steps that I followed were this:

Code:
    root@rafael-laptop:/home/rafael# mountpoint -q /sys/kernel/debug
    root@rafael-laptop:/home/rafael# mount -t debugfs none /sys/kernel/debug
    root@rafael-laptop:/home/rafael# echo "none /sys/kernel/debug debugfs defaults 0 0" > /etc/fstab
    root@rafael-laptop:/home/rafael# cat /sys/kernel/debug/vgaswitcheroo/switch
    0:IGD:+:Pwr:0000:00:02.0
    1:DIS: :Pwr:0000:01:00.0
    root@rafael-laptop:/home/rafael# ls -l /sys/kernel/debug/vgaswitcheroo/switch
    -rw-r--r-- 1 root root 0 sep 28 11:36 /sys/kernel/debug/vgaswitcheroo/switch
    root@rafael-laptop:/home/rafael# cat /sys/kernel/debug/vgaswitcheroo/switch
    0:IGD:+:Pwr:0000:00:02.0
    1:DIS: :Pwr:0000:01:00.0
    root@rafael-laptop:/home/rafael#
    root@rafael-laptop:/home/rafael# cat /sys/kernel/debug/vgaswitcheroo/switch
    0:IGD:+:Pwr:0000:00:02.0
    1:DIS: :Pwr:0000:01:00.0
    root@rafael-laptop:/home/rafael# echo OFF > /sys/kernel/debug/vgaswitcheroo/switch
    root@rafael-laptop:/home/rafael# cat /sys/kernel/debug/vgaswitcheroo/switch
    0:IGD:+:Pwr:0000:00:02.0
    1:DIS: :Off:0000:01:00.0
It looks like if the ATI isn't working now, but if we do a lspci -v:

Code:
    01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon 7550M/7570M/7650M] (prog-if 00 [VGA controller])
    Subsystem: Samsung Electronics Co Ltd Radeon HD 7550M
    Flags: fast devsel, IRQ 52
    Memory at c0000000 (64-bit, prefetchable) [size=256M]
    Memory at e0700000 (64-bit, non-prefetchable) [size=128K]
    I/O ports at 3000 [size=256]
    Expansion ROM at e0720000 [disabled] [size=128K]
    Capabilities: [50] Power Management version 3
    Capabilities: [58] Express Legacy Endpoint, MSI 00
    Capabilities: [a0] MSI: Enable+ Count=1/1 Maskable- 64bit+
    Capabilities: [100] Vendor Specific Information: ID=0001 Rev=1 Len=010 <?>
    Capabilities: [150] Advanced Error Reporting
    Kernel driver in use: radeon
We can see that there's a "Kernel driver in use". It means that the ATI card is still in use, I think. And the battery level is still discharging at an enormous speed. Has anyone an idea of what's going on? How can I improve the use of the baterry?

Regards from Spain!

P.S.: I tried also the fglrx driver as a way to manage the hybrid graphics, but I couldn't. There's more information about how it didn't work in this spanish post: http://www.esdebian.org/foro/49605/g...ridos-intelati
 
Old 10-06-2013, 01:18 PM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo, Slackware
Posts: 14,903
Blog Entries: 2

Rep: Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812
The HD7000 series is not well supported at this time, especially not by the quite dated kernel of Debian. In order to get proper powermanagement with the radeon driver you will have to use a 3.11 kernel and add the kernel option radeon.dpm=1 to your bootloader. The option to turn on/off a complete videochip on the fly will come with kernel 3.12. So for now I would recommend to go with the latest Catalyst driver (aka fglrx). Since I can't speak Spanish I can't help with that until you provide an Ebglish version of the problem.
 
1 members found this post helpful.
Old 10-11-2013, 09:42 AM   #3
Mother_Brain
LQ Newbie
 
Registered: Oct 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
The HD7000 series is not well supported at this time, especially not by the quite dated kernel of Debian. In order to get proper powermanagement with the radeon driver you will have to use a 3.11 kernel and add the kernel option radeon.dpm=1 to your bootloader. The option to turn on/off a complete videochip on the fly will come with kernel 3.12. So for now I would recommend to go with the latest Catalyst driver (aka fglrx). Since I can't speak Spanish I can't help with that until you provide an Ebglish version of the problem.
Hi! Thank you very much for your answer. I was very busy (university) and I couldn't read it before. The kernel I'm using in my Debian Testing is the 3.10. Should I try for a time a different distribution in order to get a proper powermanagement? I always wanted to try ArchLinux, and it seems to be a distribution with very new versions of the software. Perhaps, installing Arch I would be able to use the 3.11 kernel and add that kernel option that you mention. The problem is that I haven't the time right now to learn how to use a new distribution, but it shouldn't be too hard to use Arch.

Anyway, I'll translate my problem with the fglrx driver. There's an option in the Catalyst Control Center to turn off the card that you are not using. But it doesn't work properly.

http://www.esdebian.org/files/esdebi...ti-control.png (Snapshot of the option)

I searched a bit on the web, and I discovered that the cards can be turned off with the tty by using this:
Code:
aticonfig --px-igpu
After doing that, I did the folowing to see what card was active:
Code:
aticonfig --pxl
And the output was:
Code:
rafael@rafael-laptop:~$ aticonfig --pxl
PowerXpress: Integrated GPU is active (Power-Saving mode).
rafael@rafael-laptop:~$ fglrxinfo
display: :0  screen: 0
OpenGL vendor string: Intel Open Source Technology Center
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Mobile
OpenGL version string: 3.0 Mesa 9.1.6
It looks like if the ATI card isn't in use at all, but when I use the battery I have the same issue as before, and doing a lspci -v:
Code:
01:00.0 VGA compatible controller: Advanced Micro Devices, Inc. [AMD/ATI] Thames [Radeon 7550M/7570M/7650M] (prog-if 00 [VGA controller])
Subsystem: Samsung Electronics Co Ltd Radeon HD 7550M
Flags: bus master, fast devsel, latency 0, IRQ 52
Memory at c0000000 (64-bit, prefetchable) [size=256M]
Memory at e0700000 (64-bit, non-prefetchable) [size=128K]
I/O ports at 3000 [size=256]
Expansion ROM at e0720000 [disabled] [size=128K]
Capabilities: <access denied>
Kernel driver in use: radeon
The line "Kernel dirver in use" says "radeon". Not only the battery is a problem, the computer gets very hot while using it on Debian.

Thank you very much for your time! Grüße aus Spanien und vielen dank für deine Hilfe!
 
Old 10-11-2013, 10:46 AM   #4
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Hanover, Germany
Distribution: Gentoo, Slackware
Posts: 14,903
Blog Entries: 2

Rep: Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812Reputation: 3812
How did you install the fglrx driver? Have you tried blacklisting the radeon module?
 
1 members found this post helpful.
Old 10-23-2013, 11:12 AM   #5
Mother_Brain
LQ Newbie
 
Registered: Oct 2013
Posts: 3

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by TobiSGD View Post
How did you install the fglrx driver? Have you tried blacklisting the radeon module?
Hi! To install the fglrx drivers I simply did this:

Code:
# aptitude install fglrx-driver fglrx-control
# aticonfig --initial
I don't know how to blacklisting the radeon module. Should that work? I can't try it right now because I'm not writing from the computer in which I have Debian.

Thanks again for your help!

Edit: I searched on Google how to blacklist the radeon module. I will try it as soon as possible. https://ask.fedoraproject.org/questi...radeon-module/

Last edited by Mother_Brain; 10-23-2013 at 11:15 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Help Dual monitor setup -------[ATI pci-e and onboard Intel graphics HD2000/3000] venandane Red Hat 2 06-27-2012 10:43 AM
[HP Pavilion] ATI Radeon HD 5650 and vga_switcheroo Insomnium Linux - Laptop and Netbook 2 06-21-2011 10:39 AM
How to disable onboard intel graphic card on Toshiba M640 (Hybrid Intel/Nvidia) Marcelo Ruiz Linux - Laptop and Netbook 6 08-14-2010 09:59 AM
Sound and Graphics not working in Intel D101GGC with ATI graphics and Realtek audio sanu1 Linux - Hardware 2 12-28-2008 07:29 PM
Soundcard and Graphics not detected in Intel D101Ggc motherboard with ATI chipset devansh Linux - Hardware 1 12-31-2005 01:33 PM


All times are GMT -5. The time now is 12:14 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration