LinuxQuestions.org
Support LQ: Use code LQ3 and save $3 on Domain Registration
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
LinkBack Search this Thread
Old 08-03-2010, 10:37 AM   #1
K_REY_C
LQ Newbie
 
Registered: May 2010
Distribution: Fedora, Debian
Posts: 14

Rep: Reputation: 0
Command Line Resolution Issues


My command line (and my bootsplash) in Ubuntu 10.04 64 bit is illegible. I'm on a Dell XPS m1530 (1440x900) and the command line (in non-GUI mode) is compressed, doubled (side by side on my widescreen monitor), and practically unusable. I'd really like to get this fixed if possible, but I don't know what's wrong.

I do use two proprietary drivers (one a broadcom for wireless... and the other an nvidia). Perhaps the nvidia is the issue?

The problems I experienced before this (as well as my attempted fixes and pictures) can be found here: http://ubuntuforums.org/showthread.php?t=1540361

I figured it might be worth it to broaden the question the the entirety of the GNU/Linux community. Thanks for any assistance you can provide!

KYLE
 
Old 08-03-2010, 02:55 PM   #2
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
I followed your link and bounced around some verbose ubuntu forums without seeing a picture.
It's a screen resolution problem, and/or perhaps a lack of a synch signal. The usual way this happens is diagonal lines. The fact that they're not diagonal suggests a lack of horizontal synchronization. I's suggest check video plugs and change the cable - borrow one from a mate if needed. Next change out the monitor. Then power off and reseat the video card.
 
Old 08-03-2010, 03:16 PM   #3
K_REY_C
LQ Newbie
 
Registered: May 2010
Distribution: Fedora, Debian
Posts: 14

Original Poster
Rep: Reputation: 0
Sorry about the picture thing. I think you've maybe got to be signed in to see them. I'll post them below:

Here is the bootsplash:
bootsplash.jpg

Here is the command line:
commandline.jpg

The problem doesn't happen at all in the GUI ... only the bootsplash and the command line (non-GUI). This openoffice strangeness is the only thing I have seen in the GUI:
ooweird.png

Sorry if I didn't mention before... I'm on a laptop and this only happens in the instances mentioned above.

Thanks!
 
Old 08-04-2010, 02:53 AM   #4
business_kid
Guru
 
Registered: Jan 2006
Location: Ireland
Distribution: Slackware & Android
Posts: 5,953

Rep: Reputation: 496Reputation: 496Reputation: 496Reputation: 496Reputation: 496
Okay, that's a bit unusual. It's actually locked in at twice the frequency. The usual thing there is to have a black line down the middle.

The answer is to specify vga=nnn on the boot line, where nnn is a video mode. There's a few here
http://www.linuxquestions.org/questi...a-mode-425695/

It's trying to come up on 640x480 normally, although framebuffer may alter this. try 800x600
 
Old 08-04-2010, 07:48 AM   #5
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,353

Rep: Reputation: 205Reputation: 205Reputation: 205
Some distros kernels might only accept vga=0x####, so what used to just be vga=317 is now something like vga=0x0317. It's the same hex number, you just have to fully qualify it now. Or at least that's one change to my debian lenny system running a system kernel that I noticed. Which differs from debian etch, woody, and other versions I've run in the past. And there's other parameters to mod depending on your configuration if you use the newer grub2 bootloader.

in /boot/grub/grub.cfg:
set gfxmode=640x480

And other related means to an end.
 
Old 08-04-2010, 12:58 PM   #6
K_REY_C
LQ Newbie
 
Registered: May 2010
Distribution: Fedora, Debian
Posts: 14

Original Poster
Rep: Reputation: 0
Should I be worried when the file starts like this:

Quote:
#
# DO NOT EDIT THIS FILE
#
# It is automatically generated by /usr/sbin/grub-mkconfig using templates
# from /etc/grub.d and settings from /etc/default/grub
#
Also... do I just change this to my actual resolution (1440x900) or leave it as it is (or something else):

Quote:
insmod ext2
set root='(hd0,1)'
search --no-floppy --fs-uuid --set dee77000-2dfd-4281-ae0f-707456c22f9e
if loadfont /usr/share/grub/unicode.pf2 ; then
set gfxmode=640x480
insmod gfxterm
insmod vbe
if terminal_output gfxterm ; then true ; else
# For backward compatibility with versions of terminal.mod that don't
# understand terminal_output
terminal gfxterm
fi
I'm pretty sure I'm using GRUB2. This sounds kinda crazy. I might just leave it be if it's going to be a lot of tinkering --- i've messed things up quite a few times before and I could probably live with it... but it would be great to get it fixed.

Also- The "ooPresenter" is a "compiz" thing ... since when it is not enabled it displays properly.

Thanks so much, everyone, for helping.

Last edited by K_REY_C; 08-04-2010 at 01:04 PM.
 
Old 08-04-2010, 01:21 PM   #7
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,353

Rep: Reputation: 205Reputation: 205Reputation: 205
Have a rescue disk handy to revert your changes if they don't work. The warning basically means that when you update / upgrade, your changes will be over written. Double check what resolutions are supported in either the grub2 framebuffer or the driver your kernel is using when you boot. Be prepared to redo your changes, or research your distro for the administratively proper way that they have setup for such changes to remain in effect / semi-permanent. Or just stand at the ready to redo your changes every time you update / upgrade. And/Or reconfigure your bootloader. At a minimum 1024x768 should be a safe bet, and noticeably better than 640x480.
 
Old 08-04-2010, 03:08 PM   #8
K_REY_C
LQ Newbie
 
Registered: May 2010
Distribution: Fedora, Debian
Posts: 14

Original Poster
Rep: Reputation: 0
Changed the line to read 1024x768 - everything still boots fine but the resolution issues remain exactly the same. Perhaps I'm just out of luck on this one? Thanks!
 
Old 08-04-2010, 07:22 PM   #9
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,353

Rep: Reputation: 205Reputation: 205Reputation: 205
Perhaps if you install svgatextmode, it might change something. The ubuntu forums has some good info on changing your resolutions. Even though it's probably a different distro, the configuration elements remain the same. The grub.cfg only affects grub. Once you're booting your linux kernel it's a different game. Although it looks like grub2 changes how the parameters are passed to the kernel.

http://forums.debian.net/viewtopic.php?f=5&t=41881

http://harrison3001.blogspot.com/200...ps-to-set.html
https://wiki.ubuntu.com/Grub2
 
Old 08-05-2010, 11:55 PM   #10
K_REY_C
LQ Newbie
 
Registered: May 2010
Distribution: Fedora, Debian
Posts: 14

Original Poster
Rep: Reputation: 0
Here's what I tried:

Basically following instructions here: http://harrison3001.blogspot.com/200...ps-to-set.html

***PART ONE***
Changed /etc/default/grub
Line 18: from 640x480 to 1440x900
Ran sudo update-grub

***PART TWO***
/boot/grub/grub.cfg
Line 36: from 640x480 to 1440x900
Line 37: added set gfxpayload=keep
Ran sudo update-grub
#This undid the work I had jsut done above in the /boot/grub/grub.cfg file

***PART THREE***
/etc/grub.d/00_header
Line 104: added gfxpayload=keep #much like after the same line in the above
Line 103: from 640x480 to 1440x900

***PART FOUR***
#Since I might be screwing my system anyway...
/etc/grub.d/00_header
Line 10: from /usr/share/images/desktop-base/moreblue-orbit-grub.png *to* /home/kyconway/Pictures/1440_Keep Calm and Cary on.jpg

***PART FIVE***
Re-do "PART TWO"
This time your changes to /boot/grub/grub.cfg should keep. (and mine did)
Restart

And then I restarted and nothing had changed. Bootsplash and the Command Line were exactly the same. Lost cause?

Thanks so much for all of your help!
 
Old 08-05-2010, 11:55 PM   #11
K_REY_C
LQ Newbie
 
Registered: May 2010
Distribution: Fedora, Debian
Posts: 14

Original Poster
Rep: Reputation: 0
Double Post --- sorry.

Last edited by K_REY_C; 08-05-2010 at 11:56 PM. Reason: Double Post
 
Old 08-06-2010, 05:37 AM   #12
Shadow_7
Senior Member
 
Registered: Feb 2003
Distribution: debian
Posts: 1,353

Rep: Reputation: 205Reputation: 205Reputation: 205
Every time that you run update-grub it overwrites whatever changes you made to /boot/grub/grub.cfg. Hence the # DO NOT EDIT .... comment. Make the changes, DON'T run update-grub, and reboot. See if that works. See if /boot/grub/grub.cfg is as you LEFT it after edits after a reboot. Just bear in mind that if it does work, you might need to REDO those edits at any point that grub is updated or update-grub is run. This normally happens when you do upgrades, especially if you get a new system kernel and other things. There is probably a more official distro specific way to make your changes permanent. You'll have to read the documentation for your distro to find out what that is, if it's even documented yet.

Bear in mind that grub2 is still very experimental and may not work on your system, or at all. So keep a liveCD handy and other things. So you can revert your changes or just install grub 1 if you need to. Not that you will, but you might. You USED TO just pass vga=0xFFFF and some sort of video_mode=XxY type parameters directly to the kernel. Some of the newer framebuffer stuff allows for more customized looks. But you're now dealing with a video driver that is card specific and there might not be one that works for your card or your desired resolution.
 
  


Reply

Tags
command, line, resolution


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off
Trackbacks are Off
Pingbacks are On
Refbacks are Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Can the command line terminal resolution be changed? lazyFoot_theMighty Linux - General 2 08-03-2006 09:44 PM
change monitor resolution from command line gschrade Linux - Newbie 2 04-23-2004 03:57 PM
Setting Resolution from command line Teoryn Mandriva 5 01-23-2004 03:55 PM
Setting resolution from command line Teoryn Linux - General 1 01-23-2004 02:56 PM
How do i set my command line resolution greendusk Linux - General 1 09-26-2003 05:14 PM


All times are GMT -5. The time now is 10:28 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration