LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 02-02-2008, 11:14 PM   #1
creature124
Member
 
Registered: May 2007
Distribution: Kubuntu
Posts: 40

Rep: Reputation: 15
CD drive mounting error


Hi,

I am having issues with mounting CDs in my CD drive correctly.

I was (attempting) to install Call of Duty 2 over Wine (in vain as it would appear) and when I went to remove the CD, it would not unmount the CD or release it from the tray because the crashed installer was still registered as using it. I killed the process mention in the dialog box, and the CD ejected normally.

The next time I put in a CD and attepting at access it, I get the following error:

could not enter folder /media/cdrom0

This problem persited through a reboot. I am almost certain that this has been caused by the botched CD removal, but I am unsure how to fix it.

I am running the newest stable version of Kubuntu.

Thanks,
Greg
 
Old 02-03-2008, 12:11 AM   #2
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Quote:
Originally Posted by creature124 View Post
This problem persited through a reboot.
Did you try a power cycle (power off, then on) instead of just a reboot? while I would be very surprised if the OS would remember anything about this across a reboot, the CD drive might.
 
Old 02-03-2008, 10:51 AM   #3
creature124
Member
 
Registered: May 2007
Distribution: Kubuntu
Posts: 40

Original Poster
Rep: Reputation: 15
It seems the problem persists through a power cycle too.
 
Old 02-04-2008, 01:31 AM   #4
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
Run the command

Code:
tail -f /var/log/syslog
prior to inserting a CD, and see what messages get printed out when you insert a CD.
 
Old 02-04-2008, 08:12 AM   #5
creature124
Member
 
Registered: May 2007
Distribution: Kubuntu
Posts: 40

Original Poster
Rep: Reputation: 15
....Okay, this is starting to annoy me.

The problem appears to have resolved itself.

I'm not even kidding. This isn't the first time this has happened to me either. No less than two other times since the beginning of my foray into the wilderness of Linux, problems have inexplicably disappeared.

Well, my CD drive is working correctly again. For reference, here is the pertinent part of the output you requested:

Code:
Feb  4 09:08:09 creature-lappy NetworkManager: <debug> [1202134089.207476] nm_hal_device_added(): New device added (hal udi is '/org/freedesktop/Hal/devices/volume_label_COD2CD1').
Feb  4 09:08:13 creature-lappy kernel: [ 1482.472000] UDF-fs: No VRS found
Feb  4 09:08:13 creature-lappy kernel: [ 1482.536000] ISO 9660 Extensions: Microsoft Joliet Level 3
Feb  4 09:08:13 creature-lappy kernel: [ 1482.584000] ISOFS: changing to secondary root
 
Old 02-04-2008, 08:33 AM   #6
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680Reputation: 680
One think to check are the two hidden files in /media/. ".hal-mtab" and ".hal-mtab-lock".
 
Old 02-05-2008, 12:17 AM   #7
blackhole54
Senior Member
 
Registered: Mar 2006
Posts: 1,896

Rep: Reputation: 61
I was intending for that command to be used when you were having the problem, and hopefully shedding some light on what was going on. So if you are unfortunate enough for this to happen again, you might try that command again. jschiwal's comment sounds interesting too, but this is the first time I've heard of those files.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
error mounting usb drive dsids Linux - General 3 06-14-2006 06:15 AM
error mounting hard drive tsitras Debian 4 12-27-2005 05:21 AM
yet another hard drive mounting error Abomb Linux - Hardware 6 12-21-2005 04:37 PM
hard drive mounting error?? wwwc21 Linux - Hardware 3 03-16-2004 07:01 PM
windows xp hard drive mounting error threedguy Linux - Hardware 14 10-09-2003 10:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 06:58 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration