Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Hardware
User Name
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?


  Search this Thread
Old 05-08-2005, 09:17 AM   #1
Registered: Feb 2002
Posts: 393

Rep: Reputation: 30
Cannot Access my Real Time Clock?

Hi can anyone tell me how to allow devices and applications to gain access to my /dev/rtc (real time clock)? A bunch of applications like VMware and Mplayer and so on perform very poorly because they cannot access it.

Mplayer says:

Linux RTC init error in ioctl (rtc_irqp_set 1024): Invalid argument
Try adding "echo 1024 > /proc/sys/dev/rtc/max-user-freq" to your system startup scripts.
VMware says:

The host high-resolution timer device (/dev/rtc) cannot be set up to deliver interrupts (Invalid argument).  Certain versions of the Linux kernel do not support this feature. Without the device, the guest operating system can fail to keep time correctly. To avoid this problem, see
Also several of my games are performing very poorly and I can only assume that they are having similar issues.

I am not certain how to make a start up script that will work. (I'm using Debian Sid and kernel 2.6.11-7 BTW). I was going to ask how to do this. But before I did I decided to try entering the suggested command on the command line.

This is what happend:

echo 1024 > /proc/sys/dev/rtc/max-user-freq
bash: /proc/sys/dev/rtc/max-user-freq: No such file or directory
I looked and indeed I have no such file in my RTC directory.

I would simply try adding it. But a) I'm not sure what effect this would have and b/ AFAIK /proc contains a virtual file system that is wiped after every reboot anyway.

Can anyone offer any input?

Best regards,

Old 05-08-2005, 05:09 PM   #2
Senior Member
Registered: Jul 2004
Distribution: Ubuntu 7.04
Posts: 1,991

Rep: Reputation: 76
You can't create files in /proc (not without adding a kernel module anyway).

Are you using an ix86 type processor? The RTC interrupt controller is very Intel/IBM architecture-specific, so you won't have it on a Mac or SPARC machine, for example.

You could get around the problem by running the programs as root, although this isn't a very good solution.

If you don't have the /proc/sys/dev/rtc/ directory, then try
modprobe rtc
Try adding
dev.rtc.max-user-freq = 1024
to your /etc/sysctl.conf file (

Just for completion: If you syncronise your system's clock using NTP, then your RTC mileage may vary, because it will be briefly turned off every 11 minutes.

Hope that helps,

Robert J. Lee


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Various clock issues: Clock shows wrong time only in Knoppmyth, & CMOS time change ? davidbix General 1 04-05-2006 09:58 PM
Freeze while loading Real Time Clock Driver [10.1] playroll Slackware - Installation 0 04-28-2005 03:22 PM
Real Time Clock(RTC) problem gongcon Linux - Software 6 01-06-2005 09:36 PM
System hanging at "Real Time Clock Driver" raccoon Linux - General 3 07-15-2004 02:57 PM
System freezing at "Real Time Clock Driver" raccoon Linux - Newbie 0 12-02-2003 02:51 AM > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 04:10 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration