LinuxQuestions.org
LinuxAnswers - the LQ Linux tutorial section.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices

Reply
 
Search this Thread
Old 07-03-2013, 11:39 AM   #1
pdg1986
LQ Newbie
 
Registered: Jul 2013
Posts: 3

Rep: Reputation: Disabled
Smile Bluetooth not working


Hi! I am using Debian 7 with KDE. I have bluedevil installed but it shows No Adapter Found.
http://i.imgur.com/4NnlKKdl.jpg

Here is my lspci:

Code:
lspci
00:00.0 Host bridge: Intel Corporation 2nd Generation Core Processor Family DRAM Controller (rev 09)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port (rev 09)
00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
00:16.0 Communication controller: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 (rev 05)
00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller (rev 05)
00:1c.0 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 (rev b5)
00:1c.1 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 2 (rev b5)
00:1c.3 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 (rev b5)
00:1c.5 PCI bridge: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 6 (rev b5)
00:1d.0 USB controller: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 (rev 05)
00:1f.0 ISA bridge: Intel Corporation HM65 Express Chipset Family LPC Controller (rev 05)
00:1f.2 SATA controller: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller (rev 05)
00:1f.3 SMBus: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller (rev 05)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 630M] (rev a1)
03:00.0 Network controller: Atheros Communications Inc. AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
04:00.0 USB controller: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
05:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller (rev 06)
rfkill list

Code:
# rfkill list
0: asus-wlan: Wireless LAN
        Soft blocked: yes
        Hard blocked: no
1: asus-bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes
lsusb:

Code:
# lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
Bus 001 Device 003: ID 13d3:3304 IMC Networks 
Bus 001 Device 004: ID 13d3:5710 IMC Networks 
Bus 001 Device 005: ID 0bda:0139 Realtek Semiconductor Corp. Card reader
Bus 002 Device 003: ID 1c4f:0003 SiGma Micro HID controller
Bus 003 Device 003: ID 19d2:0117 ZTE WCDMA Technologies MSM
Code:
# lsmod | grep blue
bluetooth             119455  12 btusb,ath3k,rfcomm,bnep
rfkill                 19012  5 cfg80211,bluetooth,asus_wmi
crc16                  12343  2 ext4,bluetooth
 
Old 07-04-2013, 09:35 AM   #2
dominik232
LQ Newbie
 
Registered: Dec 2012
Posts: 9

Rep: Reputation: Disabled
Code:
Bus 001 Device 003: ID 13d3:3304 IMC Networks 
Bus 001 Device 004: ID 13d3:5710 IMC Networks
One of them is probably your bluetooth device.
Take a look this: https://bugs.launchpad.net/ubuntu/+s...ez/+bug/736788
 
Old 07-04-2013, 10:27 AM   #3
alfredo10
Member
 
Registered: Sep 2010
Location: Algarve
Distribution: Linux Multiboot
Posts: 264

Rep: Reputation: 14
Hi!
At the moment I'm not on a KDE Desktop, on MATE you need to install the package bluez to find the adapter.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Bluetooth not working HRS1064 Linux - Newbie 5 10-22-2012 01:56 PM
[SOLVED] Bluetooth is not working shariefbe Linux - Newbie 1 01-29-2010 12:23 AM
Bluetooth not working on FC6 with Targus USB bluetooth adapter mikevicious Linux - Software 1 12-11-2009 09:03 AM
Bluetooth not working Aviynw Linux - Hardware 1 09-22-2007 05:57 AM
Bluetooth not working at all yumingtian Linux - Wireless Networking 2 08-30-2005 11:30 PM


All times are GMT -5. The time now is 08:22 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration