LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware
User Name
Password
Linux - Hardware This forum is for Hardware issues.
Having trouble installing a piece of hardware? Want to know if that peripheral is compatible with Linux?

Notices


Reply
  Search this Thread
Old 10-13-2004, 05:37 PM   #1
rgbrock1
Member
 
Registered: Sep 2004
Location: Connecticut
Distribution: SUSE 10, Mandriva
Posts: 70

Rep: Reputation: 15
ALSA drivers for my Dell Sound Card


HI all,

I am one of those Linux users - using FC 2 - who was bestowed with the fake Creative Labs SB Live! sound cards. Thus, the emu10k1 drivers don't work with this fraudulent card.
Anyway, I downloaded all the pertinent files from ALSA's web site which include the
emu10k1X driver which is supposed to, well, drive the fake sound card.
I have faithfully followed the installation steps in the documentation area of ALSA's web site.
Everything works fine until I enter the command:

/sbin/modprobe snd-emu10k1x;modprobe snd-pcm-oss;modprobe snd-mixer-oss;modprobe snd-seq-oss

I then receive the following FATAL error message:

FATAL: Error inserting snd_emu10k1x (/lib/modules/2.6.5-1.358/kernel/sound/pci/emu10k1/snd-emu10k1x.ko): Unknown symbol in module, or unknown parameter (see dmesg)

When I look at dmesg I see this:

snd_emu10k1x: Unknown symbol snd_compat_kcalloc
snd_emu10k1x: Unknown symbol snd_verbose_printk
snd_emu10k1x: Unknown symbol snd_compat_kcalloc
snd_emu10k1x: Unknown symbol snd_verbose_printk
snd_emu10k1x: Unknown symbol snd_compat_kcalloc
snd_emu10k1x: Unknown symbol snd_verbose_printk

When I try to run alsamixer I get this:

alsamixer: function snd_ctl_open failed for default: No such device

Which I kind of figured due to the FATAL error above.

All make and config. commands completed successfully so I"m stumped by the failed attempt at inserting the sound module.

Any ideas?

Thanks much in advance.

Last edited by rgbrock1; 10-13-2004 at 05:39 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Dell SB Live! [value] sound card, Mandrake 10.1, ALSA 1.0.7, playback problems Grasshopper Linux - Hardware 1 07-11-2005 02:28 PM
Dell CPiR 400, NM 256ZX no sound via ALSA cbr4119 Linux - Laptop and Netbook 0 09-17-2004 03:33 PM
Alsa 1.01 drivers compiling fine, but amixer can't find sound card CestusGW Linux - Hardware 1 02-09-2004 08:36 AM
neebie ? about Dell sound drivers slapshot52 Linux - Newbie 2 08-31-2003 11:27 AM
Can I load both oss (kernel sound drivers) and alsa in 2 sound cared system? cmisip Linux - General 0 04-12-2003 01:27 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Hardware

All times are GMT -5. The time now is 08:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration