LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 05-24-2005, 03:09 AM   #1
jupiter3437
Member
 
Registered: May 2005
Distribution: fc3
Posts: 64

Rep: Reputation: 15
update glibc-2.3.5-6.i386.rpm


hi...I installed glibc-2.3.3-74.i386 in fedora core 3.0 ,but when i want to update glibc-2.3.5-6.i386.rpm this error:
rpm -Uvh glibc-2.3.5-i386.rpm
failed dependencies:
glibc:glibc-common=2.3.5-6 is neaded by glibc-2.3.5-6.i386
glibc > 2.3.3 conflicts with glibc-common-2.3.3.74.i386
and when i want to install glibc-common-2.3.5-6.i386.rpm this error:
failed dependencies:
glibc-common:
glibc < 2.3.5 conflicts with glibc-common-2.3.5-6.i386
appears
what should i do??????
please help me...thanks
 
Old 05-24-2005, 06:03 AM   #2
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
are you upgrading for a particular reason ( like a new feature) or to just have the latest glibc? really, you should leave the one you have alone, since to do it the correct way you cannot just plug a new glibc in and be done.
 
Old 05-24-2005, 03:00 PM   #3
jupiter3437
Member
 
Registered: May 2005
Distribution: fc3
Posts: 64

Original Poster
Rep: Reputation: 15
I want to install a software that require the glibc-2.3.5 .I try so mutch to install it ,but it wasn't installed. please explane more..thanks
 
Old 05-25-2005, 04:11 AM   #4
__J
Senior Member
 
Registered: Dec 2004
Distribution: Slackware, ROCK
Posts: 1,973

Rep: Reputation: 46
****NOTE: messing around with glibc can break your system, there is no guarantee your system will work or even boot after installing this. if you have valuable info, make sure you back it up*****

you can force the upgrade by passing --force to the rpm command you were using. are these glibc rpm's for your distro? if you compile software you may experience some problems compiling if you don't have the matching kernel-headers that this glibc was compiled against.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
problem installing glibc-2.3.2-4.80.i686, glibc-common-2.3.2-4.80.8.i386.rpm martianpackets Red Hat 8 05-01-2009 03:22 PM
does anybody know where I can get glibc-devel-2.3.2-5.i386.rpm. kelly_kong03 Linux - General 1 06-02-2004 11:59 AM
Fedora first update hangs on "Fetching rpm header: glibc-2.3.2-101.4" Darthomir Fedora 24 04-10-2004 11:53 AM
Fedora first update (with RH NetW) hangs on "Fetching rpm header: glibc-2.3.2-101.4" Darthomir Red Hat 5 03-15-2004 05:04 PM
glibc-2.2.4.i386.rpm (Red Hat 7.1) genoa Linux - Newbie 2 07-09-2003 03:05 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration