LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 06-29-2006, 10:08 AM   #1
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Rep: Reputation: 30
Unable to access certain files on NTFS share


I am unable to access certain files on my NTFS drive thru dapper. These are some of the files:
Code:
 ls -la
total 128
dr-xr-xr-x 1 root tom 65536 2006-04-20 13:53 .
dr-xr-xr-x 1 root tom 65536 2006-05-01 15:00 ..
?--------- ? ?    ?       ?                ? Star.Trek.TNG.s04e17.Night.Terrors.avi
?--------- ? ?    ?       ?                ? Star.Trek.TNG.s04e18.Identity.Crisis.avi
?--------- ? ?    ?       ?                ? Star.Trek.TNG.s04e19.The.Nth.Degree.avi
?--------- ? ?    ?       ?                ? Star.Trek.TNG.s04e20.Qpid.avi
?--------- ? ?    ?       ?                ? Star.Trek.TNG.s04e21.The.Drumhead.avi
?--------- ? ?    ?          ?                ? Star Trek Enterprise - Season 1 to 4 - english subtitles ( srt).ace
--------- ? ?    ?        ?                ? NMK S4E03 Bolniku prijazna bolnisnica.avi
?--------- ? ?    ?       ?                ? test.txt
and when trying to copy them to an XFS share I get this:
Code:
cp: cannot stat `Star Trek - TNG4/Star.Trek.TNG.s04e26.Redemption.Part.I.avi': Input/output error
The line in FSTAB responsible for mounting the drive:
Code:
/dev/hda6       /media/d        ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
Needless to say that if I boot back into Win2k3 than these files are accesible.

Last edited by Ashrack; 06-30-2006 at 06:50 AM.
 
Old 06-29-2006, 10:26 AM   #2
mikieboy
Member
 
Registered: Apr 2004
Location: Warrington, Cheshire, UK
Distribution: Linux Mint 19.1 Xfce
Posts: 555

Rep: Reputation: 33
I think the problem may be that the umask value in your etc/fstab entry is set to deny all permissions to users (umask=007). Try editing to give umask=000 and see if that works.
 
Old 06-29-2006, 10:31 AM   #3
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by mikieboy
I think the problem may be that the umask value in your etc/fstab entry is set to deny all permissions to users (umask=007). Try editing to give umask=000 and see if that works.
Tried it, but it didnt help
 
Old 06-29-2006, 02:22 PM   #4
mikieboy
Member
 
Registered: Apr 2004
Location: Warrington, Cheshire, UK
Distribution: Linux Mint 19.1 Xfce
Posts: 555

Rep: Reputation: 33
Quote:
Posted by Ashrack
Tried it, but it didnt help
OK! Looking at your original post again it's the Star.Treck files that are the problem. The first five fields in each file are not identified (and one of those is the file permissions).

From a google I have found out that a .TNG file is a compressed file:

TNG = Audio Utility Tuningwrench compressed file

Also: AVI = Video for Windows Audio Video Interleave movie

Perhaps someone knows if 'nix has a problem identifying and/or opening files of these types? If I find out more I'll post back.
 
Old 06-29-2006, 02:36 PM   #5
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,283

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Quote:
Originally Posted by mikieboy
TNG = Audio Utility Tuningwrench compressed file
I think these are all avi files. "TNG" stands for "The Next Generation".

e.g.,

Star.Trek.TNG.s04e17.Night.Terrors.avi

means

Series name: "Star Trek The Next Generation"
When aired: "Season Four, Episode 17"
Episode name: "Night Terrors"
File type: "avi"

And no, I do not know why the OP cannot access these files on NTFS. Although if I remember correctly, "Night Terrors" is not an episode I'd want to access. Most episodes were very good, but if I remember, this one was not one of them! I could be remembering wrong though.
 
Old 06-29-2006, 02:46 PM   #6
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,283

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Quote:
The line in FSTAB responsible for mounting the drive:
Code:
/dev/hda6       /media/d        ntfs    defaults,nls=utf8,umask=007,gid=46 0       1
Below is an fstab example of how I mount a readonly NTFS partition. You might try getting rid of your nls and gid settings to see if that makes any difference. Also, try a umask of four digits with the leading zero (specifically indicating the assumed default octal format) as I illustrate below. You three digit umask of 007 might be confusing things.
Code:
/dev/sda2       /mnt/windows/d     ntfs    ro,umask=0222              0       0
 
Old 06-29-2006, 02:53 PM   #7
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,283

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
One more thought - that doesn't affect your current problem but should probably be mentioned anyway.

The last field of your fstab line is "1". That means that fsck should check this filesystem at boot time. You don't want that with NTFS (is there even an fsck variant for NTFS?) I imagine this setting would probably be ignored in the absense of fsck.ntfs, but it's probably better to be safe than sorry and set it to a "0" explicitly.
 
Old 06-29-2006, 03:21 PM   #8
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by haertig
I think these are all avi files. "TNG" stands for "The Next Generation".
correct
Quote:
And no, I do not know why the OP cannot access these files on NTFS. Although if I remember correctly, "Night Terrors" is not an episode I'd want to access. Most episodes were very good, but if I remember, this one was not one of them! I could be remembering wrong though.
Ive added to the OP some other files so U wont think that only Star Trek is affected. Almost a quarter of hard drive has this problems
 
Old 06-29-2006, 03:28 PM   #9
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Original Poster
Rep: Reputation: 30
@HAERTIG
I changed the line to this and its even worse now.Since now it will freeze NAUTILUS for 15sec when accesing data on that drive.
Code:
/dev/hda6 /media/d ntfs ro,umask=0222	0       0
ps. That NTFS drive is using 64k CLUSTER SIZE! But as I read on NTFS KERNEL 64k CLUSTER SIZE is well supported.
 
Old 06-29-2006, 03:51 PM   #10
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,283

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
Quote:
Originally Posted by Ashrack
I changed the line to this and its even worse now.Since now it will freeze NAUTILUS for 15sec when accesing data on that drive.
Is your syslog file showing any errors when you try to access? Since your cp attempt generated in I/O error warning, maybe syslog will give you some more clues. (It'll probably just say "I/O Error" in some different wording however.)

Not sure how I would procede in your case. I'd probably try booting the system with a Knoppix LiveCD and see if I could access NTFS from there. This might help narrow down the problem to one in NTFS vs. one in your Linux installation.
 
Old 06-29-2006, 04:00 PM   #11
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Original Poster
Rep: Reputation: 30
dmesg report:
Code:
[17182415.808000] NTFS-fs error (device hda6): ntfs_ucstonls(): Unicode name con tains characters that cannot be converted to character set cp437.  You might wan t to try to use the mount option nls=utf8.
[17182415.808000] NTFS-fs warning (device hda6): ntfs_filldir(): Skipping unrepr esentable inode 0xa50f.
[17182415.808000] NTFS-fs error (device hda6): ntfs_ucstonls(): Unicode name con tains characters that cannot be converted to character set cp437.  You might wan t to try to use the mount option nls=utf8.
[17182415.808000] NTFS-fs warning (device hda6): ntfs_filldir(): Skipping unrepr esentable inode 0x3bb1.
[17182415.808000] NTFS-fs error (device hda6): ntfs_ucstonls(): Unicode name con tains characters that cannot be converted to character set cp437.  You might wan t to try to use the mount option nls=utf8.
[17182415.808000] NTFS-fs warning (device hda6): ntfs_filldir(): Skipping unrepr esentable inode 0x9634.
[17182447.748000] printk: 6 messages suppressed.
[17182447.748000] NTFS-fs error (device hda6): ntfs_ucstonls(): Unicode name con tains characters that cannot be converted to character set cp437.  You might wan t to try to use the mount option nls=utf8.
[17182447.748000] NTFS-fs warning (device hda6): ntfs_filldir(): Skipping unrepr esentable inode 0x2ca6.
[17183794.068000] NTFS volume version 3.1.
[17183809.136000] NTFS-fs error (device hda6): ntfs_read_locked_inode(): Found n onstandard compression unit (0 instead of 4).  Cannot handle this.
[17183809.136000] NTFS-fs error (device hda6): ntfs_read_locked_inode(): Failed with error code -95.  Marking corrupt inode 0x2c02 as bad.  Run chkdsk.
but I had run chkdsk already in Windows and it found zero errors!
 
Old 06-29-2006, 04:41 PM   #12
haertig
Senior Member
 
Registered: Nov 2004
Distribution: Debian, Ubuntu, LinuxMint, Slackware, SysrescueCD, Raspbian, Arch
Posts: 2,283

Rep: Reputation: 354Reputation: 354Reputation: 354Reputation: 354
It looks like it doesn't like your filenames for some reason. I'd try temporarily renaming one of these files (from within Windows) to something plain-Jane simple ... like "test.avi". See if you can access it then. This obviously doesn't fix your problem, but it may move you a step closer towards debugging the root cause.

You could also try using "Captive NTFS" to mount the partition. This uses NTFS drivers Linux finds in the Windows installation for file access, rather than the NTFS drivers installed into Linux itself. Captive NTFS should be installable on your distro.
 
Old 06-30-2006, 02:43 AM   #13
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Original Poster
Rep: Reputation: 30
Quote:
Originally Posted by haertig
It looks like it doesn't like your filenames for some reason. I'd try temporarily renaming one of these files (from within Windows) to something plain-Jane simple ... like "test.avi". See if you can access it then. This obviously doesn't fix your problem, but it may move you a step closer towards debugging the root cause.
Renaming the file doesnt help. But if I copy and paste the file than it is readable in UBUNTU DAPPER.

Quote:
You could also try using "Captive NTFS" to mount the partition. This uses NTFS drivers Linux finds in the Windows installation for file access, rather than the NTFS drivers installed into Linux itself. Captive NTFS should be installable on your distro.
trying it now...
EDIT:
with captive it works. but thats no sollution 4M since its so slooow. And to beta

Last edited by Ashrack; 06-30-2006 at 07:10 AM.
 
Old 06-30-2006, 03:22 AM   #14
spooon
Senior Member
 
Registered: Aug 2005
Posts: 1,755

Rep: Reputation: 51
Quote:
Originally Posted by Ashrack
dmesg report:
Code:
...  You might wan t to try to use the mount option nls=utf8.
maybe you should follow its suggestion
 
Old 06-30-2006, 03:35 AM   #15
Ashrack
Member
 
Registered: Oct 2005
Distribution: Ubuntu - Edgy Eft
Posts: 173

Original Poster
Rep: Reputation: 30
With this line in fstab where 'nls=utf8':
Code:
/dev/hda6       /media/d        ntfs    defaults,nls=utf8,umask=000,gid=46 0       0
I get the following errors in 'dmesg':
Code:
42952208.050000] NTFS-fs error (device hda6): ntfs_read_locked_inode(): Found nonstandard compression unit (0 instead of 4).  Cannot handle this.
[42952208.050000] NTFS-fs error (device hda6): ntfs_read_locked_inode(): Failed with error code -95.  Marking corrupt inode 0x2c02 as bad.  Run chkdsk.
[42952216.470000] NTFS-fs error (device hda6): ntfs_read_locked_inode(): Found nonstandard compression unit (0 instead of 4).  Cannot handle this.
[42952216.470000] NTFS-fs error (device hda6): ntfs_read_locked_inode(): Failed with error code -95.  Marking corrupt inode 0x7120 as bad.  Run chkdsk.
[42952216.520000] NTFS-fs error (device hda6): ntfs_read_locked_inode(): Found nonstandard compression unit (0 instead of 4).  Cannot handle this.
Found something on google about 'Found nonstandard compression unit (0 instead of 4). Cannot handle this.'
http://groups.google.com/groups?q=Fo...roups&ct=title
If any GURU out there can understand this///

Last edited by Ashrack; 06-30-2006 at 03:45 AM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Strange...can't share usb printer connected to xp pc vatman Linux - Software 2 11-02-2005 06:50 PM
NTFS network share zchoyt Linux - Newbie 4 08-29-2004 07:17 AM
Preserve file permissions when copying from NTFS to a Samba share? somedude Linux - Software 4 06-11-2004 09:20 AM
samba share permissions? psychomaniac Linux - Software 4 04-29-2004 02:22 PM
Samba Share Permissions stever Linux - Newbie 4 05-17-2003 02:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 04:53 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration