LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - General
User Name
Password
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.

Notices


Reply
  Search this Thread
Old 08-26-2003, 03:47 AM   #1
pcdebb
Member
 
Registered: Aug 2003
Location: Brandon, FL
Distribution: Mageia 2
Posts: 81

Rep: Reputation: 15
screensaver problem


right now I dont have a screensaver present, so the default is to power off the monitor (which freaks me out). When I open Screensaver preferences, it asks if i want to start it, I say yes, then i receive an error saying "the xscreensaver daemon didnt start properly". I enter a command but then it tells me to select "`File / Restart Daemon'.". I'm at a loss, where am I doing this? In the screensaver preferences there isnt a file menu to chose from to do this?



 
Old 08-26-2003, 07:17 PM   #2
questionasker
Member
 
Registered: Aug 2003
Location: North Carolina, USA
Distribution: Onebase 2004-r2 | Updated through 6-10-04
Posts: 359

Rep: Reputation: 30
sounds like an error in x. you may need to reinstall...
 
Old 08-26-2003, 07:26 PM   #3
exodist
Senior Member
 
Registered: Aug 2003
Location: Portland, Oregon
Distribution: Gentoo
Posts: 1,372

Rep: Reputation: 47
doubt it is an error in x, probably a dependancy not met, or an error int he xscreensaver package or surce depending on what you used.
 
Old 08-26-2003, 11:33 PM   #4
megaspaz
Senior Member
 
Registered: Nov 2002
Location: Silly Con Valley
Distribution: Red Hat 7.3, Red Hat 9.0
Posts: 2,054

Rep: Reputation: 46
a real easy fix. i assume you're using gnome. you have to add the xscreensaver daemon to the start up programs list. i'm using redhat 7.3 so the exact location maybe different than 9.0

click the foot button > settings > sessions > session properties and start up programs

click the start up tab and then the add button. put in this command:

xscreensaver -nosplash

click apply and then ok. logout and save the current session. log in and the xscreensaver daemon should be up and running. if it isn't, make sure and check that the xscreensaver command is in the start up programs list and log out (saving the current session) and log back in.

also what version of xscreensaver are you running? the newest version is 4.12 and you can make rpms from the source tarballs.
 
Old 08-27-2003, 12:23 AM   #5
pcdebb
Member
 
Registered: Aug 2003
Location: Brandon, FL
Distribution: Mageia 2
Posts: 81

Original Poster
Rep: Reputation: 15
I think I'm using knome as everything is Knome-ish, I dont have the little foot as the "start" button, but rather a hat. i'm in windoze right now so I'll switch over and try to do as you suggested
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
a problem about screensaver ? naihe2010 Programming 2 12-02-2005 09:53 PM
problem with kde screensaver? kahn Linux - Software 4 08-10-2005 02:24 PM
problem with screensaver jasmeet93 Linux - Software 2 06-19-2005 12:11 AM
RH9 Screensaver Problem Sherpa Linux - General 5 03-31-2004 02:36 PM
Problem installing screensaver... 3dmike Linux - Software 5 03-12-2004 07:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration