Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - General
User Name
Linux - General This Linux forum is for general Linux questions and discussion.
If it is Linux Related and doesn't seem to fit in any other forum then this is the place.


  Search this Thread
Old 11-26-2008, 03:02 AM   #1
Registered: Nov 2002
Posts: 207

Rep: Reputation: 32
fail to start xterm: "could not exec /usr/OSE/bash: No such file or directory"


I am running Ubuntu 8.10 and logged in a user via NIS.

I am having problems starting xterm from Run program window (ALT-F2). When the terminal opens, I get the failing message:
Could not exec /usr/OSE/bash: No such file or directory".

I have located the failure in my export setting:

declare -x SHELL="/usr/OSE/bash"

Where is this set? I can change it from my gnome-terminal but then have to run xterm from gnome-terminal which I have no intention to do.

Any ideas?

Old 11-26-2008, 10:27 PM   #2
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Hey there,

if you don't need all the opensource virtual box OSE stuff, you can get rid of it by doing:

apt-get remove virtualbox --purge

then check with dkpg --list|grep -i virtualb

to make sure no other ose packages exist.

Otherwise, you can find the config file like this (sorry, I don't have Ubuntu running in my Vmware right now):

dpkg --list|grep -i virtualb

and run

dpkg --list-files for each package.

Alternately, just string it all together:

dpkg --list|grep -i virtualb|while read x;do dpkg --list-files $x;done

or however you prefer to do it.

Hope that helps. Sorry I couldn't be more specific.

Happy Thanksgiving

, Mike
Old 11-27-2008, 02:04 AM   #3
Registered: Nov 2002
Posts: 207

Original Poster
Rep: Reputation: 32
Thanks for the info but I don't have Virutalbox installed or any vmware etc.

I think it's set due the NIS log in and some login script in my home folder. I have tried to grep the whole system but can't seem to find it...

Old 11-28-2008, 12:22 AM   #4
Registered: Apr 2008
Posts: 310

Rep: Reputation: 30
Hey There,

If you're logging on with NIS is possible that the setting isn't even on your machine.

If you they give you the latitude to modify your own home directory init files, create a .bashrc (or add to whatever's already there) and export the SHELL variable in there. You may want to just exec the right bash in there instead (assuming it's in /usr/bin) - that would get around problems you might have if they set the SHELL variable to read only. That variable is useful in some instances, but actually can be set to anything without changing the shell you're in.

exec /usr/bin/bash

Best wishes

, Mike


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
"No such file or directory" when trying to start up wlan0 with ifconfig Jonasfrax Linux - Wireless Networking 1 08-26-2008 07:12 AM
Strangely, bash tells me "no such file or directory", but it's there!? ramchip Linux - Software 13 02-26-2008 05:09 AM
LFS 6.2 Ch. 6.14 - 2nd Coreutils test returns "/bin.bash: No such file or directory" 0graham0 Linux From Scratch 2 08-23-2007 06:32 PM
What does "Directory "/usr/src/linux" doesn't appear to contain kernel source." mean? jtp51 Linux - General 4 06-11-2007 12:22 AM
Error in man command "sh: line 1: /usr/bin/gtbl: No such file or directory" MinA Slackware 1 09-06-2004 06:36 PM > Forums > Linux Forums > Linux - General

All times are GMT -5. The time now is 08:27 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration