LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux From Scratch
User Name
Password
Linux From Scratch This Forum is for the discussion of LFS.
LFS is a project that provides you with the steps necessary to build your own custom Linux system.

Notices

Reply
 
Search this Thread
Old 12-06-2012, 10:58 AM   #1
erkant
Member
 
Registered: Oct 2012
Posts: 51

Rep: Reputation: Disabled
BLFS: Udev Extras (from systemd) error


I finished with LFS 7.2, and started with BLFS. All I do in BLFS is install X Windows System and KDE, along with all the required and recommended packages and software. I need to install Udev Extras (from systemd), but I alread installed Udev in LFS, and my Udev version is 188. Here is the output of what I get while installing Udev Extras (from systemd).

root [ /sources ]# tar -Jxf systemd-188.tar.xz
root [ /sources ]# cd systemd-188
root [ /sources/systemd-188 ]# tar -xf ../udev-lfs-188-3.tar.bz2
root [ /sources/systemd-188 ]# make -f udev-lfs-188/Makefile.lfs keymap
CC src/shared/log.c
Assembler messages:
Fatal error: can't create build/log.o: No such file or directory
cc1: fatal error: cfg.h: No such file or directory
compilation terminated.
make: *** [build/log.o] Error 2

If I try to check the output of my udevadm I get the following:
root [ /sources/systemd-188 ]# /sbin/udevadm --version
188

What can be the problem, and how can I solve it?
 
Old 12-06-2012, 11:30 AM   #2
Keith Hedger
Member
 
Registered: Jun 2010
Location: Devon,UK
Distribution: Linux From Scratch, Slackware64,
Posts: 830

Rep: Reputation: 167Reputation: 167
I had to do this first:
Code:
make -f udev-lfs-188/Makefile.lfs
 
Old 12-06-2012, 12:47 PM   #3
erkant
Member
 
Registered: Oct 2012
Posts: 51

Original Poster
Rep: Reputation: Disabled
Thanks that solved the problem!
 
  


Reply

Tags
blfs, error, systemd, udev


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] systemd/udev-196 problem (devices not discovered) re_nelson Linux From Scratch 2 11-29-2012 03:13 PM
Boot Delay 30min: systemd-analyze blame systemd-tmpfiles-setup.service BGHolmes Fedora 0 07-27-2011 09:02 AM
[SOLVED] tango-icon-theme-extras PACKAGE DESCRIPTION error opt9 Slackware 1 05-29-2010 09:01 AM
udev extras engkozhe Linux - Newbie 1 03-07-2010 11:42 AM
Yum Error: Cannot find a valid baseurl for repo: extras ivanleblanc Linux - Newbie 3 03-05-2009 02:03 PM


All times are GMT -5. The time now is 08:39 AM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration