LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 10-20-2017, 02:22 PM   #1
vicky219
LQ Newbie
 
Registered: Jul 2017
Posts: 3

Rep: Reputation: Disabled
Proxy protocol error in apache logs of my virtual host


We have two virtual hosts on three linux servers behind an ELB. We have enabled proxy protocol for prod ELB so that the requests for ssl are terminated on instance rather than on ELB. We are seeing following errors flowing in error logs of our virtual host starting from 11th Oct. At the instance level there were no changes in the past.

Error log:

Quote:
[Thu Oct 19 14:57:07.126415 2017] [proxy_protocol:error] [pid 2992] [client 127.0.0.1:47348] ProxyProtocol: no valid header found
[Thu Oct 19 14:57:07.471596 2017] [proxy_protocol:error] [pid 3076] [client 127.0.0.1:47388] ProxyProtocol: no valid header found
[Thu Oct 19 14:57:07.785776 2017] [proxy_protocol:error] [pid 3076] [client 127.0.0.1:47428] ProxyProtocol: no valid header found
[Thu Oct 19 14:57:07.909984 2017] [proxy_protocol:error] [pid 2528] [client 127.0.0.1:47450] ProxyProtocol: no valid header found
[Thu Oct 19 14:57:08.384383 2017] [proxy_protocol:error] [pid 2612] [client 127.0.0.1:47496]
Access logs:

Quote:
127.0.0.1 - - [19/Oct/2017:14:57:45 +0000] "GET /admin/index.php HTTP/1.1" 302 - "-" "-"
127.0.0.1 - - [19/Oct/2017:14:57:45 +0000] "GET /? HTTP/1.1" 302 - "-" "-"
127.0.0.1 - - [19/Oct/2017:14:57:45 +0000] "GET /admin/index.php HTTP/1.1" 302 - "-" "-"
127.0.0.1 - - [19/Oct/2017:14:57:45 +0000] "GET /? HTTP/1.1" 302 - "-" "-"
127.0.0.1 - - [19/Oct/2017:14:57:45 +0000] "GET /admin/index.php HTTP/1.1" 302 - "-" "-"
127.0.0.1 - - [19/Oct/2017:14:57:46 +0000] "GET /? HTTP/1.1" 302 - "-" "-"
127.0.0.1 - - [19/Oct/2017:14:57:46 +0000] "GET /admin/index.php HTTP/1.1" 302 - "-" "-"
127.0.0.1 - - [19/Oct/2017:14:57:46 +0000] "GET /? HTTP/1.1" 302 - "-" "-"
127.0.0.1 - - [19/Oct/2017:14:57:46 +0000] "GET /admin/index.php HTTP/1.1" 302 - "-" "-"
These errors started to appear from 11th october and still we are yet to figure the root cause. Could you please suggest on how to eliminate these errors and also the source of these errors.
 
  


Reply

Tags
apache 2.4.2, apache php subdomain, linux, proxy, virtual host


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LXer: How to split the logs of Varnish for Virtual host LXer Syndicated Linux News 0 05-16-2012 07:51 PM
Any way to tunnel apache virtual host to an internal apache? ciuly Linux - Server 5 01-31-2010 12:53 PM
Virtual Host Configuration - Issue (Utilization of Proxy Pass Method) sanjay.s Linux - Newbie 1 08-11-2009 03:55 AM
squid proxy+ virtual host question frieza Linux - Networking 11 03-03-2009 04:01 PM
Apache virtual host, rewrite & proxy question NickDeGraeve Linux - Server 8 02-02-2009 07:09 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 03:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration