LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 10-21-2009, 12:00 PM   #1
instinct46
LQ Newbie
 
Registered: Dec 2005
Location: Liverpool
Distribution: Slackware
Posts: 18

Rep: Reputation: 0
Unhappy Grub Help!


I once had ubuntu installed which installed grub.

I then installed slackware13 onto a different hdd, yet lilo never installed properly so I just booted to slackware through grub which was left intact for some reason.

Then 2months later I installed WinXP over ubuntu thinking I would reinstall lilo using slackware disc, I soon discovered that I can't find my slackware disc, and have just moved so am currently running internet of a mobile broadband pen so can't really download isos.

I then found Grub Windows Installer, so I installed and it worked fine boots to grub and everything, now I tried the following

//This was how I boot while using grub with ubuntu

> root (hd1,0)
> kernel /boot/vmlinuz root=/dev/hdb1 ro vga=standard
> boot

Except on the kernel line it comes up and says invalid filename, I've looked using an old ubuntu live disc I still have and it all correct.

I then tried

> root (hd1,0)
> setup (hd1,0)

And it says something along the lines of hell no! their no stage1 file on this partion, Is their anyway I can boot to lilo from grub is my question as the lilo files are on the partion.
 
Old 10-21-2009, 12:15 PM   #2
camorri
LQ Guru
 
Registered: Nov 2002
Location: Somewhere inside 9.9 million sq. km. Canada
Distribution: Slackware 14.1, 14.2
Posts: 5,163

Rep: Reputation: 522Reputation: 522Reputation: 522Reputation: 522Reputation: 522Reputation: 522
Is this the second hard drive on your system? Grub counts from 0 not 1 like lilo.
 
Old 10-21-2009, 12:22 PM   #3
cola
Senior Member
 
Registered: Sep 2007
Location: Dhaka,Bangladesh
Distribution: Debian
Posts: 1,031

Rep: Reputation: 63
Quote:
Originally Posted by instinct46 View Post
I once had ubuntu installed which installed grub.

I then installed slackware13 onto a different hdd, yet lilo never installed properly so I just booted to slackware through grub which was left intact for some reason.

Then 2months later I installed WinXP over ubuntu thinking I would reinstall lilo using slackware disc, I soon discovered that I can't find my slackware disc, and have just moved so am currently running internet of a mobile broadband pen so can't really download isos.

I then found Grub Windows Installer, so I installed and it worked fine boots to grub and everything, now I tried the following

//This was how I boot while using grub with ubuntu

> root (hd1,0)
> kernel /boot/vmlinuz root=/dev/hdb1 ro vga=standard
> boot

Except on the kernel line it comes up and says invalid filename, I've looked using an old ubuntu live disc I still have and it all correct.

I then tried

> root (hd1,0)
> setup (hd1,0)

And it says something along the lines of hell no! their no stage1 file on this partion, Is their anyway I can boot to lilo from grub is my question as the lilo files are on the partion.
Grub counting starts from 0 . (hda0-->hda1-->hda2-->hda3-->hda4-->)
Can you post fdisk -l using ubuntu livecd?

Last edited by cola; 10-21-2009 at 12:23 PM.
 
  


Reply

Tags
grub


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
grub drops to grub prompt on boot, but can use commands to find menu... fix? greenmuzz Linux - Software 7 06-07-2009 03:07 AM
Why /boot/grub/grub.conf is symlinked to /boot/grub/menu.lst raj_hcl1986@rediffma Linux - Newbie 2 10-19-2008 02:19 AM
Changing GRUB-GRUB, GRUB-LILO and vice versa andreas_skw Linux - Newbie 1 06-05-2008 06:40 AM
Booting my new ubuntu install = "GRUB GRUB GRUB GRUB GRUB" etc. dissolved soul Ubuntu 2 01-13-2007 12:55 PM
can some fc4 user mail his grub.conf and tell me how can i make this grub read this amolgupta Linux - Software 1 03-15-2006 04:04 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 06:18 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration