LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions
User Name
Password
Linux - Distributions This forum is for Distribution specific questions.
Red Hat, Slackware, Debian, Novell, LFS, Mandriva, Ubuntu, Fedora - the list goes on and on... Note: An (*) indicates there is no official participation from that distribution here at LQ.

Notices


Reply
  Search this Thread
Old 10-20-2009, 06:29 AM   #1
dheerajg6
LQ Newbie
 
Registered: Oct 2009
Posts: 1

Rep: Reputation: 0
Evolution-2.28 build failure on Fedora 10


Hi,

I was trying to build evolution 2.28 on fedora 10. The errors I'm getting are

checking for GNOME_PLATFORM... configure: error: Package requirements (glib-2.0 >= 2.20.0
gtk+-2.0 >= 2.16.0
gconf-2.0 >= 2.0.0
libbonobo-2.0 >= 2.20.3
libbonoboui-2.0 >= 2.4.2
libglade-2.0 >= 2.0.0
libgnomecanvas-2.0 >= 2.0.0
libgnomeui-2.0 >= 2.0.0
libxml-2.0 >= 2.7.3
shared-mime-info >= 0.22
gnome-desktop-2.0 >= 2.26.0) were not met:

Requested 'glib-2.0 >= 2.20.0' but version of GLib is 2.18.2
Requested 'gtk+-2.0 >= 2.16.0' but version of GTK+ is 2.14.4
Requested 'libxml-2.0 >= 2.7.3' but version of libXML is 2.7.2
Requested 'gnome-desktop-2.0 >= 2.26.0' but version of gnome-desktop-2.0 is 2.24.3

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables GNOME_PLATFORM_CFLAGS
and GNOME_PLATFORM_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

error: Bad exit status from /var/tmp/rpm-tmp.l7VLcj (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.l7VLcj (%build)

To resolve the above errors, I changed the versions of the dependencies for the packages in configure file in the tar ball of evolution-2.28 (which I realised as not a correct step after I got the same build errors).

I'm unable to find GNOME_PLATFORM_CFLAGS & GNOME_PLATFORM_LIBS, from where I believe the configure script is taking the dependency package versions . Would someone please guide me, on how to resolve these dependencies and build the evolution package?.

Regards

Dheeraj G
 
Old 10-21-2009, 02:54 PM   #2
John VV
LQ Muse
 
Registered: Aug 2005
Location: A2 area Mi.
Posts: 17,218

Rep: Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517Reputation: 2517
why not just install it from " yum " ?
it is in the repos .

from your post it looks like you are missing the -devel.rpm's for those programs
like the whole of the " GNOME Software Development "
Code:
su -
yum install evolution
--------
Code:
su -
yum groupinstall "GNOME Software Development"
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
evolution 2.21 build problem lrt Linux - Software 3 12-07-2007 04:08 AM
failure trying to build bioapi hedpe Linux - Software 2 09-10-2006 07:24 PM
Build failure for mkfontscale.c kira Linux - Software 1 04-06-2005 07:26 AM
Would someone like to build Evolution 2.2 for Slack? dhave Slackware 11 03-13-2005 06:36 PM
Evolution update failure moger Slackware 4 04-06-2004 03:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions

All times are GMT -5. The time now is 11:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration