LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Deepin
User Name
Password
Linux Deepin This forum is for the discussion of Linux Deepin.

Notices


Reply
  Search this Thread
Old 03-08-2018, 06:05 AM   #1
Sawsmith
LQ Newbie
 
Registered: Mar 2018
Posts: 18

Rep: Reputation: Disabled
Question I have tried to get Deepin to recognise my HP3630 wifi printer but keep getting the following error message: CUPS server error - 'server-err


Hi folks - I have just installed Deepin 15.5 and I am currently trying to get it to see my HP3634 printer.

I have the printer connected through both the USB and wifi and I get the same error message regardless.

I could attach a screenshot, but can't see how?

Thanks

p.s. The error message should read: CUPS server error. 'server-error-internal-error'.

Last edited by Sawsmith; 03-08-2018 at 06:07 AM. Reason: Detail left out
 
Old 03-08-2018, 08:22 AM   #2
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 958
Blog Entries: 2

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
Can you post the output of lpinfo -v ? with your printer connected of course.
 
Old 03-08-2018, 08:36 AM   #3
Sawsmith
LQ Newbie
 
Registered: Mar 2018
Posts: 18

Original Poster
Rep: Reputation: Disabled
Thanks Mill J. Here it is:

john@john-PC:~$ lpinfo -v
network beh
network socket
network https
network http
network ipps
network ipp
network lpd
serial serial:/dev/ttyS0?baud=115200
direct usb://HP/DeskJet%203630%20series?serial=CN59T1H0HN0658&interface=1
direct hp:/usb/DeskJet_3630_series?serial=CN59T1H0HN0658
file dcp:/
network dnssd://HP%20DeskJet%203630%20series%20%5B754463%5D._ipp._tcp.local/?uuid=1c852a4d-b800-1f08-abcd-b05ada754463
network smb
direct hpfax
network socket://192.168.0.25
network ipp://192.168.0.25
network socket://[fe80::b25a:daff:fe75:4463%wlx20e11706a36e]
network ipp://HPB05ADA754463.local:631/ipp/print
 
Old 03-08-2018, 09:33 AM   #4
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 958
Blog Entries: 2

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
Ok great your printer is being seen. Now how are you trying to add this printer? probably the deepin system printer config app?

Try opening your web browser and navigating to localhost:631 click on admin in the top menu bar, then try to add your printer from there.

Let us know if this works/doesn't work.
 
Old 03-08-2018, 10:07 AM   #5
Sawsmith
LQ Newbie
 
Registered: Mar 2018
Posts: 18

Original Poster
Rep: Reputation: Disabled
If by 'navigate to' you mean type localhost:631 into the search area of my web browser, that doesn't work. It states that 'this site cannot be reached'. Then tells me to check my firewall etc. I am using Opera, by the way.
 
Old 03-08-2018, 10:27 AM   #6
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 958
Blog Entries: 2

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
Do you have a proxy set? In Firefox i can turn the proxy off in the settings without affecting system proxy.

Also most browsers have a url text ctrl and a smaller search text ctrl. make sure you use the url crtl.
 
Old 03-08-2018, 10:38 AM   #7
Sawsmith
LQ Newbie
 
Registered: Mar 2018
Posts: 18

Original Poster
Rep: Reputation: Disabled
This is the message I get when searching proxy:

Under a supported Desktop Environment, Opera will use the proxy settings from your system. If you see this page, Opera was not able to automatically determine your proxy settings from the environment. If you want Opera to use a proxy server, you can configure it either by a command line switch or by setting appropriate environment variables.

I did search in the main URL search box. I also tried in Chrome and got a similar response i.e. site couldn't be found or similar.
 
Old 03-08-2018, 10:55 AM   #8
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 958
Blog Entries: 2

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
That strange, Ok open /etc/cups/cupsd.conf in your text editor(it will likely be read only) Look for:

#Only listen for connections from local machine.

post the two lines that come after that line. And also post the line that comes after

#Web Interface settings...


I've seen very few distros that didn't just work with printing.
 
Old 03-08-2018, 11:08 AM   #9
Sawsmith
LQ Newbie
 
Registered: Mar 2018
Posts: 18

Original Poster
Rep: Reputation: Disabled
I'm not having a lot of luck here:

john@john-PC:~$ /etc/cups/cupsd.conf
bash: /etc/cups/cupsd.conf: Permission denied

john@john-PC:~$ sudo /etc/cups/cupsd.conf
[sudo] password for john:
sudo: /etc/cups/cupsd.conf: command not found

john@john-PC:~$ sudo su /etc/cups/cupsd.conf
No passwd entry for user '/etc/cups/cupsd.conf'

I've been using Linux for over 5 years and I've never had this issue before. I've even used earlier versions of Deepin?

I was running Ubuntu 17.10 until about a week ago and the printer just loaded and ran.

For what it's worth I am getting exactly the same issue when trying to get the same printer to work on my laptop.
 
Old 03-08-2018, 11:20 AM   #10
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 958
Blog Entries: 2

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
youll have to run sudo gedit /etc/cups/cupsd.conf

I'm not sure what the default text editor is for Deepin, substitute gedit accordingly.

What distro are you running on you laptop?
 
Old 03-08-2018, 11:30 AM   #11
Sawsmith
LQ Newbie
 
Registered: Mar 2018
Posts: 18

Original Poster
Rep: Reputation: Disabled
Happy reading. Gedit kind of works in Deepin. My laptop is running Deepin as well, so this appears to be an inherent problem, maybe with this particular printer. I know that HP printers are usually well catered for.

LogLevel warn
PageLogFormat
MaxLogSize 0
Listen /run/cups/cups.sock
Listen /run/cups/cups.sock
Browsing On
BrowseLocalProtocols dnssd
DefaultAuthType Basic
WebInterface Yes
<Location />
Order allow,deny
</Location>
<Location /admin>
Order allow,deny
</Location>
<Location /admin/conf>
AuthType Default
Require user @SYSTEM
Order allow,deny
</Location>
<Location /admin/log>
AuthType Default
Require user @SYSTEM
Order allow,deny
</Location>
<Policy default>
JobPrivateAccess default
JobPrivateValues default
SubscriptionPrivateAccess default
SubscriptionPrivateValues default
<Limit Create-Job Print-Job Print-URI Validate-Job>
Order deny,allow
</Limit>
<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>
<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default CUPS-Get-Devices>
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>
<Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs CUPS-Reject-Jobs>
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>
<Limit CUPS-Authenticate-Job>
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>
<Limit All>
Order deny,allow
</Limit>
</Policy>
<Policy authenticated>
JobPrivateAccess default
JobPrivateValues default
SubscriptionPrivateAccess default
SubscriptionPrivateValues default
<Limit Create-Job Print-Job Print-URI Validate-Job>
AuthType Default
Order deny,allow
</Limit>
<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
AuthType Default
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>
<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>
<Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs CUPS-Reject-Jobs>
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>
<Limit Cancel-Job CUPS-Authenticate-Job>
AuthType Default
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>
<Limit All>
Order deny,allow
</Limit>
</Policy>
<Policy kerberos>
JobPrivateAccess default
JobPrivateValues default
SubscriptionPrivateAccess default
SubscriptionPrivateValues default
<Limit Create-Job Print-Job Print-URI Validate-Job>
AuthType Negotiate
Order deny,allow
</Limit>
<Limit Send-Document Send-URI Hold-Job Release-Job Restart-Job Purge-Jobs Set-Job-Attributes Create-Job-Subscription Renew-Subscription Cancel-Subscription Get-Notifications Reprocess-Job Cancel-Current-Job Suspend-Current-Job Resume-Job Cancel-My-Jobs Close-Job CUPS-Move-Job CUPS-Get-Document>
AuthType Negotiate
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>
<Limit CUPS-Add-Modify-Printer CUPS-Delete-Printer CUPS-Add-Modify-Class CUPS-Delete-Class CUPS-Set-Default>
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>
<Limit Pause-Printer Resume-Printer Enable-Printer Disable-Printer Pause-Printer-After-Current-Job Hold-New-Jobs Release-Held-New-Jobs Deactivate-Printer Activate-Printer Restart-Printer Shutdown-Printer Startup-Printer Promote-Job Schedule-Job-After Cancel-Jobs CUPS-Accept-Jobs CUPS-Reject-Jobs>
AuthType Default
Require user @SYSTEM
Order deny,allow
</Limit>
<Limit Cancel-Job CUPS-Authenticate-Job>
AuthType Negotiate
Require user @OWNER @SYSTEM
Order deny,allow
</Limit>
<Limit All>
Order deny,allow
</Limit>
</Policy>
JobPrivateAccess default
JobPrivateValues default
SubscriptionPrivateAccess default
SubscriptionPrivateValues default
 
Old 03-08-2018, 11:44 AM   #12
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 958
Blog Entries: 2

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
Quote:
Listen /run/cups/cups.sock
Listen /run/cups/cups.sock
mine is:
Code:
Listen localhost:631
Listen /run/cups/cups.sock
So if yours doesn't have the localhost line you need to add it, save it and restart cups via sudo /etc/init.d/cups restart or maybe sudo systemctl restart cups.service depending on your system.
 
Old 03-08-2018, 11:53 AM   #13
Sawsmith
LQ Newbie
 
Registered: Mar 2018
Posts: 18

Original Poster
Rep: Reputation: Disabled
Deepin terminal won't accept 'Listen' as a command.

john@john-PC:~$ Listen /run/cups/cups.sock
bash: Listen: command not found

john@john-PC:~$ sudo Listen /run/cups/cups.sock
[sudo] password for john:

sudo: Listen: command not found

john@john-PC:~$ Listen localhost:631
bash: Listen: command not found

john@john-PC:~$ sudo Listen localhost:631
sudo: Listen: command not found
 
Old 03-08-2018, 11:57 AM   #14
Sawsmith
LQ Newbie
 
Registered: Mar 2018
Posts: 18

Original Poster
Rep: Reputation: Disabled
Just by the by, how do you attach a file (such as a screenshot .png file), to a post?
 
Old 03-08-2018, 12:05 PM   #15
Mill J
Member
 
Registered: Feb 2017
Location: 127.0.0.1 Sweet 127.0.0.1
Distribution: Void, MX, Haiku, Icaros, Puppy and many others
Posts: 958
Blog Entries: 2

Rep: Reputation: 403Reputation: 403Reputation: 403Reputation: 403Reputation: 403
No listen is not a command. it is a setting in your cupsd.conf file you opened earlier, you need to edit a section in that file from:

#Only listen for connections from local machine.
Listen /run/cups/cups.sock
Listen /run/cups/cups.sock

to

#Only listen for connections from local machine.
Listen localhost:631
Listen /run/cups/cups.sock

I think you need a certain amount of posts before you can add a attach a picture to your post.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Server Hung with error message: ERROR: Message hist queue is filling up iprince Linux - Enterprise 7 02-10-2014 10:40 AM
server-error-internal-error with CUPS "Configure Printer" fskmh Slackware 6 06-05-2013 02:51 PM
Installed printer won't print - CUPS error message refers to temp file fotofill1969 Linux - Hardware 1 03-10-2013 01:39 AM
[SOLVED] Cups server error 'client-error-not-possible'. jlfkeefe Linux - Newbie 1 05-13-2010 07:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Linux Deepin

All times are GMT -5. The time now is 10:09 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration