LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo
User Name
Password
Gentoo This forum is for the discussion of Gentoo Linux.

Notices


Reply
  Search this Thread
Old 08-28-2019, 12:23 PM   #1
jrredho
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Rep: Reputation: 0
[Solved] Recent Update to Base System release 2.6 and Weird mutt Behavior


Hey All,

I have a terminal-only account and my ISP has recently updated the hardware that I use for this and, coincidentally, updated the OS from a years old version of Gentoo to what I believe is a fairly recent update. The file /etc/gentoo-release contains the line: Gentoo Base System release 2.6.

Everything I do on this machine is via a terminal interface only. Access to it is via ssh, and I use GNU screen to create some virtual terminal windows. To my knowledge, there is not even a desktop environment installed on the platform.

As part of all of this the terminal-based email program, mutt, was updated to version Mutt 1.10.1 (2018-07-13, gentoo-1.10.1/r0). I'm a long-time user of this application, but I'm encountering a weird effect that I've never come across before: In email replies, the quoted text from the email that I'm replying to appears to contain terminal control escape sequences. Here's an example message from myself to my gmail account that I've gotten into a reply window,

-----------------begin included email message-------------
From: john r red-horse <jrredho@swcp.com>
To: john red-horse <jrredho@gmail.com>
Cc:
Bcc:
Subject: Re: OpenSSL 1.1.1 Is Released
Reply-To:
In-Reply-To: <A32BA8F9-99F4-4D8C-BB5D-E9BF8E31AA20@swcp.com>

This is a test.

john r red-horse wrote:
> ^[[38;5;0m^[[48;5;0m^[[38;5;15m ^[[38;5;21mhttp://www.openssl.org/blog/blog/2018/09/11/release111/

-----------------end included email message-------------

Am I the only user that's come across this? I've been using an older version of the gentoo/mutt via ssh/screen in the same TERM=xterm-color combination for several years; this is a new one.

Many thanks,
john

Last edited by jrredho; 08-30-2019 at 10:43 AM. Reason: Indicate issue is solved in title
 
Old 08-29-2019, 03:51 AM   #2
evo2
LQ Guru
 
Registered: Jan 2009
Location: Japan
Distribution: Mostly Debian and CentOS
Posts: 6,015

Rep: Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394Reputation: 1394
Hi,

those look like colour escape codes. If you are doing all of this under screen they you should probably set TERM=screen-256color or similar.

Evo2.

P.S.
If its installed, I highly recommend trying out tmux as a replacement for screen.
 
Old 08-30-2019, 10:42 AM   #3
jrredho
LQ Newbie
 
Registered: Jan 2006
Posts: 2

Original Poster
Rep: Reputation: 0
Quote:
Originally Posted by evo2 View Post
Hi,

those look like colour escape codes. If you are doing all of this under screen they you should probably set TERM=screen-256color or similar.

Evo2.

P.S.
If its installed, I highly recommend trying out tmux as a replacement for screen.
Hey Evo2,

Thanks for responding to this. Your guess was exactly what I thought too. Moving along that line, I tried to do a limited bit of sleuthing and have determined that this effect only occurred when I was replying to messages that were html formatted. I *think* that what I'm seeing has to do with the fact that mutt first uses autoview to translate such messages. In my case, I use 'elinks -dump' via my ~/.mailcap. This is a totally new effect since the system OS update as I've used this mailcap setup for quite some time now.

I switched to using 'lynx -dump' for the autoview scenario and restricted my use of elinks to the 'copiousoutput' case only and things are being quoted correctly. I'll mark this thread as solved asap.

Thanks again!

cheers,
john
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] [Mutt] Can I process a current mail in a shell command from Mutt? Michael Uplawski Linux - Software 5 06-21-2016 03:56 AM
[SOLVED] Mutt does not change the "unread" flag on the IMAP server and other Mutt questions TobiSGD Linux - Software 1 10-09-2012 09:44 AM
mutt does not honour mutt.rc 'use_from' entry when accepting piped input davidchall Linux - Software 0 05-28-2012 03:13 AM
Mutt experts - Mutt won't use the Maildir I specify in .muttrc moistTowelette Debian 2 08-24-2009 09:04 AM
Mutt question: "How can I configure mutt for not automarking as read??" xowl Linux - Software 0 09-25-2007 10:09 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Gentoo

All times are GMT -5. The time now is 09:55 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration