LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Non-*NIX Forums > General
User Name
Password
General This forum is for non-technical general discussion which can include both Linux and non-Linux topics. Have fun!

Notices


Reply
  Search this Thread
Old 06-17-2012, 02:53 AM   #1
Navjot Arora
LQ Newbie
 
Registered: Apr 2012
Location: Bangalore
Distribution: J ARORA
Posts: 22

Rep: Reputation: Disabled
Internet Connection using wvdial


Hi All,
I tried connecting internet using GPRS Connection(Samsung Mobile)using wvdial command. The output of the command "sudo wvdial DATA" (without quotes) on the console was like below in b/w --- line
----------------------------------------------------------------------------
--> WvDial: Internet dialer version 1.61
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,ΓǥIPΓǥ,Γǥairtelgprs.comΓǥ
AT+CGDCONT=1,b [1d]IPb [1d],b [1d]airtelgprs.comb [1d]
+CME ERROR: 3
--> Bad init string.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,ΓǥIPΓǥ,Γǥairtelgprs.comΓǥ
AT+CGDCONT=1,b [1d]IPb [1d],b [1d]airtelgprs.comb [1d]
+CME ERROR: 3
--> Bad init string.
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
ATZ
OK
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
OK
--> Sending: AT+CGDCONT=1,ΓǥIPΓǥ,Γǥairtelgprs.comΓǥ
AT+CGDCONT=1,b [1d]IPb [1d],b [1d]airtelgprs.comb [1d]
+CME ERROR: 3
--> Bad init string.
--------------------------------------------------------------------------

and the wvdial.conf was like below in bw --- line
--------------------------------------------------------------------------
[Modem0]
Modem = /dev/rfcomm0
Baud = 230400
SetVolume = 0
DialCommand = ATDT
FlowControl = Hardware(CRTSCTS)
[Modem1]
Modem = /dev/ttyACM0
Baud = 230400
SetVolume = 0
DialCommand = ATDT
FlowControl = Hardware(CRTSCTS)
[Dialer GPRS]
Username = 1
Password = 1
Phone = *99***1#
Mode = 1
Inherits = Modem0
[Dialer DATA]
Username =
Password =
Phone = *99***1#
Mode = 1
Inherits = Modem1
[Dialer Defaults]
Modem = /dev/rfcomm0
Baud = 230400
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init3 = AT+CGDCONT=1,IP,airtelgprs.com
ISDN = 0
Modem Type = Analog Modem
Area Code =
Phone = *99***1#
Username =
Password =
Ask Password = 0
Dial Command = ATDT
Stupid Mode = 1
Compuserve = 0
Force Address =
Idle Seconds = 3600
DialMessage1 =
DialMessage2 =
ISDN = 0
Auto DNS = 1
-------------------------------------------------------------------------

As a result of some error i am not able to connect to internet.
Can anyone help me in this problem.
 
Old 07-03-2012, 03:25 AM   #2
durgesh.ddn
LQ Newbie
 
Registered: Feb 2008
Posts: 4

Rep: Reputation: 0
Hi Navjot, Please give this file a try. If it does not work try changing the Init3 "internet" by airtelgprs.com, be sure about the modem path.
This file is working for me for almost all carriers, you just need to change few minor things. Good luck.

Modem = /dev/ttyACM0
Baud = 460800
Init1 = ATZ
Init2 = ATQ0 V1 E1 S0=0 &C1 &D2
Init3 = AT+CGDCONT=1,"IP","internet"
Modem Type = Analog Modem
Phone = *99#
Username = www
Password = www
New PPPD = yes
Stupid Mode = on
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Tried to connect to internet through Wvdial in Ubuntu 10.04 unable to get connection dalfish Ubuntu 6 06-20-2010 07:29 PM
[SOLVED] Finding connection speed when using wvdial jim_d Linux - Newbie 2 06-07-2010 11:59 PM
GSM mobile internet connection using wvdial basheer Ubuntu 1 05-07-2010 05:59 AM
wvdial connection problems Fredmukjimjim Mandriva 5 03-19-2005 12:52 PM
Permanent Dialup Connection Using Wvdial sombra_tommy LinuxQuestions.org Member Success Stories 0 08-25-2003 10:10 AM


All times are GMT -5. The time now is 08:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration