LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 10-08-2007, 05:39 PM   #16
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911

And at this stage in the game I'd like to move your post
to the Fedora forum because I have no explanation for this
behaviour ... would you mind? Sorry that I can't be of
further assistance.



Cheers,
Tink
 
Old 10-08-2007, 05:44 PM   #17
ipfreely28
LQ Newbie
 
Registered: Oct 2007
Posts: 23

Original Poster
Rep: Reputation: 15
Its ok thanks for your help anyways also i would like to point out that
while using [root@localhost libpgtcl]# ./configure --with-tcl --prefix=/usr/local/pgsql --exec-prefix=/usr/local/pgsql --with-postgres-lib=/usr/local/pgsql/lib --with-tcl=/usr/local/lib/tclConfig.sh
I'am still getting this error. configure: error: Cannot locate program pg_config to determine PostgreSQL paths. Make sure pg_config is in PATH or set PG_CONFIG env var to path to pg_config.
 
Old 10-08-2007, 05:47 PM   #18
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
Moved: This thread is more suitable in <Fedora> and has been moved accordingly to help your thread/question get the exposure it deserves.
 
Old 10-08-2007, 06:17 PM   #19
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
Quote:
Originally Posted by ipfreely28 View Post
I'am still getting this error. configure: error: Cannot locate program pg_config to determine PostgreSQL paths. Make sure pg_config is in PATH or set PG_CONFIG env var to path to pg_config.
Did you try adding /usr/local/pgsql/bin to the PATH, or
setting PG_CONFIG?


Cheers,
Tink
 
Old 10-08-2007, 06:32 PM   #20
ipfreely28
LQ Newbie
 
Registered: Oct 2007
Posts: 23

Original Poster
Rep: Reputation: 15
I had tried using --with-postgres-bin=/usr/local/pgsql/bin/pg_config
that didnt work prolly do that wrong,and as setting PG_CONFIG i dont know how i went into the directory executed ./pg_config but it just give me stats.


[root@localhost bin]# ./pg_config
BINDIR = /usr/local/pgsql/bin
DOCDIR = /usr/local/pgsql/doc
INCLUDEDIR = /usr/local/pgsql/include
PKGINCLUDEDIR = /usr/local/pgsql/include
INCLUDEDIR-SERVER = /usr/local/pgsql/include/server
LIBDIR = /usr/local/pgsql/lib
PKGLIBDIR = /usr/local/pgsql/lib
LOCALEDIR =
MANDIR = /usr/local/pgsql/man
SHAREDIR = /usr/local/pgsql/share
SYSCONFDIR = /usr/local/pgsql/etc
PGXS = /usr/local/pgsql/lib/pgxs/src/makefiles/pgxs.mk
CONFIGURE = '--enable-multibyte' '--with-CXX' '--with-tcl' '--without-tk'
CC = gcc
CPPFLAGS = -D_GNU_SOURCE
CFLAGS = -O2 -Wall -Wmissing-prototypes -Wpointer-arith -Winline -Wdeclaration-after-statement -Wendif-labels -fno-strict-aliasing
CFLAGS_SL = -fpic
LDFLAGS = -Wl,-rpath,/usr/local/pgsql/lib
LDFLAGS_SL =
LIBS = -lpgport -lz -lreadline -lcrypt -lresolv -lnsl -ldl -lm -lbsd
VERSION = PostgreSQL 8.1.8
 
Old 10-08-2007, 06:45 PM   #21
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
Try
Code:
export PG_CONFIG=/usr/local/pgsql/bin/pg_config
on the shell before running your ./config
 
Old 10-08-2007, 06:53 PM   #22
ipfreely28
LQ Newbie
 
Registered: Oct 2007
Posts: 23

Original Poster
Rep: Reputation: 15
there that fixed everything thank you very much for your help
 
Old 10-08-2007, 06:57 PM   #23
Tinkster
Moderator
 
Registered: Apr 2002
Location: in a fallen world
Distribution: slackware by choice, others too :} ... android.
Posts: 23,067
Blog Entries: 11

Rep: Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911Reputation: 911
Not quite "fixed everything" ... you SHOULD be able to use
the postgres libraries with ldconfig. There's definitely
something seriously weird there.
 
Old 10-08-2007, 06:59 PM   #24
ipfreely28
LQ Newbie
 
Registered: Oct 2007
Posts: 23

Original Poster
Rep: Reputation: 15
yea your right its still doing that
 
Old 11-21-2007, 04:15 PM   #25
LinuxManMikeC
Member
 
Registered: Nov 2007
Location: Provo, Utah
Distribution: Debian and Ubuntu
Posts: 74

Rep: Reputation: 15
I just came across this thread while trying to figure out how to get the native library part of JOGL (Java OpenGL) recognized by ldconfig. Using Fedora 7 here as well. The problem is with SELinux blocking ldconfig from accessing your .so files because they don't have the proper SELinux context type. Simply run the following command in the directory containing your .so files:

chcon -t lib_t *.so

Don't do this in a directory such as /usr/lib because some of the libraries in there have special context types, this could probably break those. Specify the full filename(s) of the libraries you need to change in that case.

Last edited by LinuxManMikeC; 11-21-2007 at 04:18 PM.
 
Old 11-22-2007, 02:41 AM   #26
ipfreely28
LQ Newbie
 
Registered: Oct 2007
Posts: 23

Original Poster
Rep: Reputation: 15
thanks i will try this later on today see if it solves this
 
Old 11-22-2007, 03:05 AM   #27
ipfreely28
LQ Newbie
 
Registered: Oct 2007
Posts: 23

Original Poster
Rep: Reputation: 15
i just tried it i ran it under /usr/prostgres/lib it didnt seem to work maybe iam doing something wrong iam a bit of a noob when it comes to linux.
 
Old 11-23-2007, 01:57 AM   #28
LinuxManMikeC
Member
 
Registered: Nov 2007
Location: Provo, Utah
Distribution: Debian and Ubuntu
Posts: 74

Rep: Reputation: 15
There may be further SELinux contexts to set on the files and directories you are using. You should be getting a little star notification icon for the SELinux Troubleshooter. You can click on it to get a listing of what SELinux has blocked and why. Thats how I discovered what was wrong in my situation. You can also start the SELinux Troubleshooter from the menu at System->Administration->SELinux Troubleshooter. Look through there for any security alerts relating to /sbin/ldconfig and/or the files and directories you are working with.

Also this command will show you the SELinux context info for a directory listing:
ls -Z
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 05:13 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration