LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 11-21-2007, 11:20 AM   #1
Biswajit Ransingh
LQ Newbie
 
Registered: Nov 2007
Posts: 11
Blog Entries: 1

Rep: Reputation: 0
Post installing vlc


i tried to install vlc but i could not.This is the results
[root@localhost kcpati]# yum install vlc
Loading "protectbase" plugin
Loading "installonlyn" plugin
Setting up Install Process
Setting up repositories
Reading repository metadata in from local files
0 packages excluded due to repository protections
Parsing package install arguments
Resolving Dependencies
--> Populating transaction set with selected packages. Please wait.
---> Package vlc.i386 0:0.8.6c-4.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: liba52.so.0 for package: vlc
--> Processing Dependency: libdirac_encoder.so.0 for package: vlc
--> Processing Dependency: libfaad.so.0 for package: vlc
--> Processing Dependency: libtar.so.1 for package: vlc
--> Processing Dependency: libcdio.so.7(CDIO_7) for package: vlc
--> Processing Dependency: libdts.so.0 for package: vlc
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0 for package: vlc
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6) for package: vlc
--> Processing Dependency: libfaac.so.0 for package: vlc
--> Processing Dependency: libSDL_image-1.2.so.0 for package: vlc
--> Processing Dependency: libvga.so.1 for package: vlc
--> Processing Dependency: libjack.so.0 for package: vlc
--> Processing Dependency: libcdio.so.7 for package: vlc
--> Processing Dependency: libavutil.so.49 for package: vlc
--> Processing Dependency: libcddb.so.2 for package: vlc
--> Processing Dependency: libiso9660.so.5 for package: vlc
--> Processing Dependency: libwx_baseu-2.6.so.0(WXU_2.6) for package: vlc
--> Processing Dependency: libwx_gtk2u_xrc-2.6.so.0 for package: vlc
--> Processing Dependency: libwx_gtk2u_adv-2.6.so.0(WXU_2.6) for package: vlc
--> Processing Dependency: libebml.so.0 for package: vlc
--> Processing Dependency: libvcdinfo.so.0 for package: vlc
--> Processing Dependency: libvcdinfo.so.0(VCDINFO_0) for package: vlc
--> Processing Dependency: libcdio_cdda.so.0 for package: vlc
--> Processing Dependency: libdvbpsi.so.4 for package: vlc
--> Processing Dependency: libwx_baseu_xml-2.6.so.0 for package: vlc
--> Processing Dependency: libshout.so.3 for package: vlc
--> Processing Dependency: libmp3lame.so.0 for package: vlc
--> Processing Dependency: libcdio_paranoia.so.0 for package: vlc
--> Processing Dependency: libtwolame.so.0 for package: vlc
--> Processing Dependency: libpostproc.so.51 for package: vlc
--> Processing Dependency: libxosd.so.2 for package: vlc
--> Processing Dependency: libavformat.so.51 for package: vlc
--> Processing Dependency: libmatroska.so.0 for package: vlc
--> Processing Dependency: libavcodec.so.51 for package: vlc
--> Processing Dependency: libwx_gtk2u_qa-2.6.so.0 for package: vlc
--> Processing Dependency: libid3tag.so.0 for package: vlc
--> Processing Dependency: libwx_baseu-2.6.so.0 for package: vlc
--> Processing Dependency: libwx_gtk2u_core-2.6.so.0(WXU_2.6.2) for package: vlc
--> Processing Dependency: libcdio_paranoia.so.0(CDIO_PARANOIA_0) for package: vlc
--> Processing Dependency: libvgagl.so.1 for package: vlc
--> Processing Dependency: libwx_baseu_net-2.6.so.0 for package: vlc
--> Processing Dependency: libupnp.so.3 for package: vlc
--> Processing Dependency: libdirac_decoder.so.0 for package: vlc
--> Processing Dependency: libcdio_cdda.so.0(CDIO_CDDA_0) for package: vlc
--> Processing Dependency: libwx_gtk2u_html-2.6.so.0 for package: vlc
--> Processing Dependency: libwx_gtk2u_adv-2.6.so.0 for package: vlc
--> Processing Dependency: libx264.so.54 for package: vlc
--> Processing Dependency: libmpeg2.so.0 for package: vlc
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libtar.i386 0:1.2.11-8.fc6 set to be updated
---> Package libdca.i386 0:0.0.2-3.lvn6 set to be updated
---> Package lame.i386 0:3.97-1.fc6 set to be updated
---> Package x264.i386 0:0.0.0-0.3.20061214.fc6 set to be updated
---> Package ffmpeg.i386 0:0.4.9-0.8.20070109.fc6 set to be updated
---> Package wxGTK.i386 0:2.6.3-2.6.3.2.3.fc6 set to be updated
---> Package libshout.i386 0:2.2.2-1.fc6 set to be updated
---> Package SDL_image.i386 0:1.2.5-4.fc6 set to be updated
---> Package libmatroska.i386 0:0.8.0-4.fc6 set to be updated
---> Package a52dec.i386 0:0.7.4-10.lvn6 set to be updated
---> Package faad2.i386 0:2.5-2.fc6 set to be updated
---> Package libcdio.i386 0:0.78.2-2.fc6 set to be updated
---> Package dirac-libs.i386 0:0.7.0-1.fc6 set to be updated
---> Package libebml.i386 0:0.7.7-2.fc6 set to be updated
---> Package svgalib.i386 0:1.9.25-3.fc6 set to be updated
---> Package libdvbpsi.i386 0:0.1.5-2.lvn6 set to be updated
---> Package twolame.i386 0:0.3.10-1.lvn6 set to be updated
---> Package vcdimager.i386 0:0.7.23-5.fc6 set to be updated
---> Package jack-audio-connection-kit.i386 0:0.103.0-1.fc6 set to be updated
---> Package mpeg2dec.i386 0:0.4.1-2.lvn6 set to be updated
---> Package libupnp.i386 0:1.6.0-1.fc6 set to be updated
---> Package libid3tag.i386 0:0.15.1b-3.fc6 set to be updated
---> Package xosd.i386 0:2.2.14-9.fc6 set to be updated
---> Package ffmpeg-libs.i386 0:0.4.9-0.37.20070503.lvn6 set to be updated
---> Package libcddb.i386 0:1.3.0-1.fc6 set to be updated
---> Package faac.i386 0:1.25-2.lvn6 set to be updated
--> Running transaction check
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Processing Dependency: libfreebob.so.0 for package: jack-audio-connection-kit
--> Processing Dependency: libsndfile.so.1 for package: twolame
--> Processing Dependency: libImlib2.so.1 for package: ffmpeg-libs
--> Processing Dependency: libgsm.so.1 for package: ffmpeg-libs
--> Processing Dependency: libmp4v2.so.0 for package: faac
--> Processing Dependency: libsndfile.so.1(libsndfile.so.1.0) for package: twolame
--> Processing Dependency: libImlib2.so.1 for package: ffmpeg
--> Processing Dependency: libgsm.so.1 for package: ffmpeg
--> Processing Conflict: vlc conflicts faad2 >= 2.5
--> Restarting Dependency Resolution with new changes.
--> Populating transaction set with selected packages. Please wait.
---> Package libsndfile.i386 0:1.0.17-2.fc6 set to be updated
---> Package libmp4v2.i386 0:1.5.0.1-3.fc6 set to be updated
---> Package libfreebob.i386 0:1.0.0-3.fc6 set to be updated
---> Package gsm.i386 0:1.0.12-3.fc6 set to be updated
---> Package imlib2.i386 0:1.3.0-3.fc6 set to be updated
--> Running transaction check
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Processing Conflict: vlc conflicts faad2 >= 2.5
--> Finished Dependency Resolution
Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs
Error: vlc conflicts with faad2 >= 2.5
 
Old 11-22-2007, 05:41 PM   #2
evilkorn
LQ Newbie
 
Registered: Jun 2007
Location: Boynton Beach Flordia
Distribution: Ubuntu 7.10
Posts: 18

Rep: Reputation: 0
Quote:
--> Processing Dependency: faad2 < 2.5 for package: ffmpeg-libs
--> Processing Conflict: vlc conflicts faad2 >= 2.5
--> Finished Dependency Resolution
Error: Missing Dependency: faad2 < 2.5 is needed by package ffmpeg-libs
Error: vlc conflicts with faad2 >= 2.5
I would uninstall faad2, then install a sub 2.5 version, then install VLC. You might have to uninstall FFmpeg also because it uses faad2.
 
Old 11-22-2007, 09:30 PM   #3
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 394

Rep: Reputation: 52
Just a thought. Would VLC from FreshRPMs work?
 
Old 11-23-2007, 02:06 AM   #4
Biswajit Ransingh
LQ Newbie
 
Registered: Nov 2007
Posts: 11

Original Poster
Blog Entries: 1

Rep: Reputation: 0
Quote:
Originally Posted by evilkorn View Post
I would uninstall faad2, then install a sub 2.5 version, then install VLC. You might have to uninstall FFmpeg also because it uses faad2.
Thank you.
 
Old 11-26-2007, 06:57 AM   #5
Kropotkin
Member
 
Registered: Oct 2004
Location: /usr/home
Distribution: Linux Mint, FreeBSD, Android
Posts: 358

Rep: Reputation: 32
I encountered this problem as well, and I solved it by removing FAAD and installing an earlier version from the livna repo, like this:

Code:
# yum -y install faad2-2.0-19.20050131.lvn6.i386
 
Old 11-27-2007, 05:13 AM   #6
Biswajit Ransingh
LQ Newbie
 
Registered: Nov 2007
Posts: 11

Original Poster
Blog Entries: 1

Rep: Reputation: 0
Quote:
Originally Posted by Kropotkin View Post
I encountered this problem as well, and I solved it by removing FAAD and installing an earlier version from the livna repo, like this:

Code:
# yum -y install faad2-2.0-19.20050131.lvn6.i386
Thank you.
with regards
Biswajit Ransingh
 
Old 04-02-2008, 01:54 AM   #7
Biswajit Ransingh
LQ Newbie
 
Registered: Nov 2007
Posts: 11

Original Poster
Blog Entries: 1

Rep: Reputation: 0
How to upgrade FC8 TO FC9
 
Old 04-02-2008, 03:36 AM   #8
Glennzo
Member
 
Registered: May 2003
Location: Salem, Mass USA
Distribution: Fedora
Posts: 394

Rep: Reputation: 52
Basically all you need to do is to enable the development repo. That file is /etc/yum.repos.d/fedora-development.repo. Open it with a text editor and change the line that reads enabled=0 to read enabled=1. Run yum update. There will be hundreds of updates and it will take quite a while to complete. Once done, reboot and you're running rawhide, since Fedora 9 is not final yet.
 
Old 04-02-2008, 05:16 AM   #9
lazlow
Senior Member
 
Registered: Jan 2006
Posts: 4,363

Rep: Reputation: 172Reputation: 172
Fedora STRONGLY advises against upgrading versions via yum. If you get part way through an upgrade and ANYTHING goes wrong you will be left with a non working system. By anything I really mean anything (server goes down, internet connection gets disconnected, power goes off, it does not like something about your system, and the list goes on). You can download the DVD or livecd and go from there.
 
  


Reply

Tags
vlc


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Problems installing vlc kantor_98 Linux - Newbie 1 05-02-2007 03:28 AM
Help installing Vlc and other software Dark_Horz Fedora 3 09-23-2006 08:23 AM
help installing vlc on 9.3 shadowsa SUSE / openSUSE 1 09-28-2005 03:40 AM
Installing VLC st95accord Fedora 4 05-15-2005 12:26 PM
installing vlc flames2112 Fedora 1 03-07-2005 03:41 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 09:02 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration