LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Closed Thread
  Search this Thread
Old 06-29-2009, 08:35 AM   #1
uxan
Member
 
Registered: Jun 2006
Location: Rwanda, Kigali
Distribution: Fedora core
Posts: 60

Rep: Reputation: 15
INIT: id "co" respawning too fast: disabled for 5 minutes


Hello,

I get this message when I am using the linux text mode and It is deactivated so how can resolve this problem.

INIT: id "co" respawning too fast: disabled for 5 minutes

Thank you
 
Old 06-29-2009, 09:35 AM   #2
uxan
Member
 
Registered: Jun 2006
Location: Rwanda, Kigali
Distribution: Fedora core
Posts: 60

Original Poster
Rep: Reputation: 15
INIT: id "co" respawning too fast: disabled for 5 minutes Reply to Thread

i just find how to resolve it , just editing /etc/inittab and see what wrong in that file if there is a line which is wrong i put comment on it and save. Then after i run this command init q to restart inittab to be able to take effect I made.
 
Old 07-10-2009, 08:48 PM   #3
gvsbnarayana
LQ Newbie
 
Registered: Jan 2008
Posts: 9

Rep: Reputation: 0
Hi,
I am having the same problem. I went through several posts on net but couldn't get the exact point.
Can you please suggest, how can I know which line in /etc/inittab is wrong?
Thanks a lot.
Regards,
Badri.
 
Old 08-11-2009, 07:30 AM   #4
geedoubleya
LQ Newbie
 
Registered: Aug 2009
Posts: 2

Rep: Reputation: 0
Hi Badri

I think the line that uxan is referring to is the one similar to this :

co:2345:respawn:/sbin/agetty ttyS0 9600 vt100-nav

It is used to create a tty login session to ttyS0 which should be the serial console port on your server.
By commenting this out and entering "init q", the error should disappear, however, you will no longer have a login prompt via your LOM (if configured). I understand that a similar entry exists for use with Xen, but the ttyS0 will be different.
I am still looking into this issue and if I resolve then I will update the post.
Regards

Graham
 
Old 06-13-2014, 11:24 AM   #5
Zonker
LQ Newbie
 
Registered: Jun 2014
Posts: 3

Rep: Reputation: Disabled
Smile Why you see the "co" respawn error...

Your version of Linux wants to see the "ttys0" or "S1" format to identify the default serial console device. Maybe you upgraded to a secure version... maybe you switched distributions... or maybe someone inserted code from some Q and A website without understanding it. But, the reply below was correct (put a hash mark at the beginning of the line, to comment it out, because it's not doing anything useful on your current version of Linux).

Look at the other lines in the file. Do you have other lines with the agetty command? That's probably doing what you need already, if your serial console is working.

In my case, I had the old style, but invoking the secure version of the OS required a different syntax. I kept the old one, commented out and added further comment, so that the next sysadmin won't remove the comment mark by mistake. Part of my inittab look like this...

# Run gettys in standard runlevels
S1:12345:respawn:/sbin/agetty -L ttyS1 9600n8 vt100
#co:2345:respawn:/sbin/agetty ttyS0 9600 vt100-nav #Line above used instead of this line for console redirection.
1:2345:respawn:/sbin/mingetty tty1
2:2345:respawn:/sbin/mingetty tty2
3:2345:respawn:/sbin/mingetty tty3

Hoping you have happy consoles,
-Zonker-
 
Old 06-13-2014, 11:55 AM   #6
unSpawn
Moderator
 
Registered: May 2001
Posts: 28,722
Blog Entries: 55

Rep: Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325Reputation: 3325
Thanks but before you post please look at the date. Unless the information you provide is complete and current (and not just asking the OP a question for example) posting responses to stale threads is commonly frowned upon. So please be careful.
 
  


Closed Thread


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
X Server broken. start w/ "INIT: ld "x" respawning too fast: disabled for 5 minutes&q tektone Linux - Hardware 5 07-25-2007 07:18 PM
FC7 with XEN : init: Id "x" respawning too fast: disabled for 5 minutes erikjan Fedora - Installation 0 07-11-2007 03:08 PM
RH9 INIT: ID "x" respawning too fast: disabled for 5 minutes valimare Linux - Newbie 4 02-16-2007 04:53 AM
INIT:Id "x" respawning too fast: disabled for 5 minutes problem satimis Red Hat 4 07-22-2004 06:03 AM
INIT: Id "x" respawning too fast: disabled for 5 minutes" Lego3 Linux - Software 0 06-16-2004 08:01 AM


All times are GMT -5. The time now is 01:28 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration