LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 06-10-2004, 02:10 AM   #16
Linner
Member
 
Registered: May 2004
Distribution: Fedora
Posts: 71

Rep: Reputation: 15

#cp /etc/rndc.key /var/named/chroot/etc/

#service named restart (2x)

Last edited by Linner; 06-10-2004 at 02:12 AM.
 
Old 06-10-2004, 08:11 PM   #17
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Ubuntu 18.04LTS
Posts: 143

Original Poster
Rep: Reputation: 16
Hey thanks, that first line worked and got it back up and running again,
Now I have nameserver up and running, zone files done, do I have to actually configure apache before I can access my webserver via
www.tech-magic.net ? I noticed that right now I can ns1.tech-magic.net and access webserver.
 
Old 06-10-2004, 10:03 PM   #18
Linner
Member
 
Registered: May 2004
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
since you can access your website using ns1.tech-magic.net and httpd didnt complain during boot up, usually have a message of something like the fully qualified domain error, why not try to put a canonical name in your record.

something like this:

www CNAME ns1
 
Old 06-10-2004, 11:10 PM   #19
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Ubuntu 18.04LTS
Posts: 143

Original Poster
Rep: Reputation: 16
Sir, I have that in my records.
I've been studying this for hours every day, as I'm excited to get up & running, since the middle of last month, no matter how many how toos I read, copy, etc. It just doesn't want to work. After so much studying I've pretty much have it memorized how to do everything, yet It just doesn't work. I think I'm just missing something simple... Please Help...
Here is what my forward & reverse files look like.

; This file is Tech Magic's /var/named/tech-magic.forward



$TTL 86400
@ IN SOA ns1.tech-magic.net.
hostmaster.tech-magic.net. (
20040610019 ;Serial#
28800 ;Refresh
7200 ;Retry
604800 ;Expire
86400 ;Minimum TTL
)



NS ns1.tech-magic.net.


A 64.91.63.93




www CNAME ns1

email CNAME ns1








reverse:


This file is: /var/named/tech-magic.rev






$TTL 86400
@ IN SOA ns1.tech-magic.net.
hostmaster.tech-magic.net. (
20040610019 ;Serial#
28800 ;Refresh
7200 ;Refresh
604800 ;Expire
86400 ;Minimum TTL
)



IN NS ns1.tech-magic.net.



93 IN PTR www.tech-magic.net.

93 IN PTR email.tech-magic.net.





It does look a little different on this forum however. I also noticed that when I'm on my server I can type www.tech-magic.net in the address bar & it comes up, but only on the web server. I used to run windows IIS 5 server & 2000 advanced server DNS, I still have all the same ports forwarded on my router just the same, I also DMZ'd this webserver and it made no difference.

Last edited by bsurfin; 06-10-2004 at 11:15 PM.
 
Old 06-11-2004, 12:32 AM   #20
Linner
Member
 
Registered: May 2004
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
well you know i am newbie too, so do not expect that i can help here..:-), it just happen that i have noticed this thread goes for almost three weeks now.

i have a running Web, DNS on Fedora and did not encounter much trouble during setup.

the only problem i got on configuring DNS is when i try to put all my configuration and zone file on the default location which is /etc/ and /var/named/ respectively. and realize that my rootdir on /etc/sysconfig/named is pointing to ROOTDIR=/var/named/chroot, and of course always forgot to change serial number after the modification of zone files...lol.

and with regards to httpd, i was able to run it just by adding a fully qualified domain, and play around with virtual hosting feature.

anyway, hope experts here would come up and give us advise on how this could be solved.

GOODLUCK.
 
Old 06-11-2004, 01:36 AM   #21
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Ubuntu 18.04LTS
Posts: 143

Original Poster
Rep: Reputation: 16
My /etc/sysconfig/named is pointing to ROOTDIR=/var/named/chroot
also, that really sucks, the fedora book I bought to get fedora core 1 doesn't even mention doing anything with that file, then /etc/named.conf says: directory "/var/named"; "that's damn decieving"
So how can I overcome this problem? I just don't know what to do, the tutorials never mention this stuff either, the other advice I get is go here and there read this and that, it all says the same stuff and none of it is working, except Linner's advice so far. Thanks Linner
 
Old 06-11-2004, 02:00 AM   #22
Linner
Member
 
Registered: May 2004
Distribution: Fedora
Posts: 71

Rep: Reputation: 15
so you better copy all your zone files to /var/named/chroot/var/named directory and your named.conf, rndc.key and other configuration files (if there are more) on /var/named/chroot/etc

im still reading info about dns, wow a lot to read tsk tsk.
 
Old 06-11-2004, 02:01 AM   #23
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 32
bsurfin

As you like reading so much I think this link may help, worked for me, there is a section explaining the file location in Fedora
DNS

Hope it helps

Pete
 
Old 06-11-2004, 02:15 AM   #24
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Ubuntu 18.04LTS
Posts: 143

Original Poster
Rep: Reputation: 16
Wow good stuff, I guess I kinda get to start all over again in a way, anyway I'll let you guys know... Thanks Bunches...

Linner, you are quite a guy for a newbie... :-))
 
Old 06-12-2004, 04:24 PM   #25
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Ubuntu 18.04LTS
Posts: 143

Original Poster
Rep: Reputation: 16
As soon as I cd into the /var/named/chroot/etc directory and then vi named.conf, then copied text out of original and put into my new file, I noticed that named quit running and will not fire back up, How can I fix this?
eg: I'm now back to rndc:connect failed: connection refused

I removed rndc.conf & rndc.key from the /etc/ directory, now when trying to restart named it says
rndc: neither /etc/rndc.conf nor /etc/rndc.key was found

Technically after doing everything as per the documentation my nameserver should be up & running...

is there any documentation out there on any distribution that actually works?

If I reinstall fedora and just cp /etc/rndc.key /var/named/chroot/etc/rndc.key , so I can get named to run, then vi into /etc/named.conf and change the directory to: tell it that the zone files are in /var/named/chroot/var/named

Think this may work?

Last edited by bsurfin; 06-12-2004 at 07:17 PM.
 
Old 06-12-2004, 08:32 PM   #26
GufyMike
Member
 
Registered: Apr 2004
Location: Los(t) Angeles
Distribution: Fedora Core2, RH9, FreeBSD, Debian, Knoppix,
Posts: 53

Rep: Reputation: 15
1) Edit /etc/named.conf
2) search "rndckey" (without quotes) and change it to "rndc-key" (without quotes again).
3) restart BIND - /etc/init.d/named restart

<-- Helped witha RH9 Server.
 
Old 06-13-2004, 02:07 PM   #27
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Ubuntu 18.04LTS
Posts: 143

Original Poster
Rep: Reputation: 16
My Named file doesn't have search "rndckey" anywhere in it, so I put it in there, and it didn't do any good, still at the drawing board...
 
Old 06-13-2004, 02:13 PM   #28
bsurfin
Member
 
Registered: May 2004
Location: Kalispell Montana
Distribution: Ubuntu 18.04LTS
Posts: 143

Original Poster
Rep: Reputation: 16
I just noticed I can go to add and remove programs and uninstall the chroot tree for bind nameserver, will this get rid of the problem?
What files could i modify to get around all the chroot stuff that doesn't seem to allow bind to work?
 
Old 06-13-2004, 03:02 PM   #29
GufyMike
Member
 
Registered: Apr 2004
Location: Los(t) Angeles
Distribution: Fedora Core2, RH9, FreeBSD, Debian, Knoppix,
Posts: 53

Rep: Reputation: 15
Quote:
// Tech Magic's ns1 file /etc/named.conf

// generated by named-bootconf.pl

options {
directory "/var/named";
/*
* If there is a firewall between you and nameservers you want
* to talk to, you might need to uncomment the query-source
* directive below. Previous versions of BIND always asked
* questions using port 53, but BIND 8.1 uses an unprivileged
* port by default.
*/
query-source address * port 53;
};

//
//
controls {
inet 127.0.0.1 allow { localhost; } keys { rndckey; };
};
zone "." IN {
type hint;
file "named.ca";
};

zone "localhost" IN {
type master;
file "localhost.zone";
allow-update { none; };
};

zone "0.0.127.in-addr.arpa" IN {
type master;
file "named.local";
allow-update { none; };
};





<-- the bolded entry is the one I'm talking about.
 
Old 06-13-2004, 03:48 PM   #30
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 32
bsurfin

Your problem with not being able to connect to your web server using www was simply a zone file problem, put the files back as they were see if named will start then we can sort it out

Pete
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
dns trouble isales Linux - Networking 6 10-22-2004 02:31 AM
Trouble with DNS technician Linux - Networking 17 08-02-2004 03:46 PM
Trouble setting up DNS on Mandrake 9.1 wildscribe Linux - Networking 1 11-17-2003 01:49 PM
DNS trouble pmh6310 Linux - Newbie 2 06-12-2003 12:13 PM
DNS trouble MojoLuv Linux - Networking 2 05-06-2003 08:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 09:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration