LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora
User Name
Password
Fedora This forum is for the discussion of the Fedora Project.

Notices


Reply
  Search this Thread
Old 08-18-2008, 04:01 PM   #1
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 544

Rep: Reputation: 30
cannot select webcore fonts


Hi

I cannot seem to select any of the webcore fonts ( http://avi.alkalay.net/software/webcore-fonts/ ) such as Tahoma Verdana etc.

The fonts seem to get installed into /usr/share/fonts/webcore after using rpm -i
Code:
# ls /usr/share/fonts/webcore
andalemo.ttf  courbi.ttf    impact.ttf    timesi.ttf    verdanaz.ttf
arialbd.ttf   couri.ttf     l_10646.ttf   times.ttf     webdings.ttf
arialbi.ttf   cour.ttf      lucon.ttf     trebucbd.ttf  wingding.ttf
ariali.ttf    fonts.dir     micross.ttf   trebucbi.ttf  WINGDNG2.TTF
arial.ttf     fonts.scale   symbol.ttf    trebucit.ttf  WINGDNG3.TTF
ariblk.ttf    georgiab.ttf  tahomabd.ttf  trebuc.ttf
comicbd.ttf   georgiai.ttf  tahoma.ttf    verdanab.ttf
comic.ttf     georgia.ttf   timesbd.ttf   verdanai.ttf
courbd.ttf    georgiaz.ttf  timesbi.ttf   verdana.ttf
but a restart of X didnt refresh the fonts .. I can select them in GNOME -> System -> Preferences -> Look and Feel -> Appearance -> Fonts. They are not there.

I tried inserting this into xorg.conf
Code:
Section "Files"
        FontPath "/usr/share/fonts/default/Type1"
        FontPath "/usr/share/fonts/default/ghostscript"
        FontPath "/usr/share/fonts/webcore"
        FontPath "/usr/share/fonts/webcore-vista"
        FontPath "/usr/share/fonts/ISO8859-2/100dpi"
        FontPath "/usr/share/fonts/KOI8-R/100dpi"
        FontPath "/usr/share/fonts/ISO8859-2/misc"
        FontPath "/usr/share/fonts/KOI8-R/misc"
EndSection
however then I get some error about "missing default 'misc' fonts" in the Xorg.log file and X does not start.

Commenting out the entire Files section and fontpaths, removes the error and X starts but still no webcore fonts.

any ideas?
 
Old 08-18-2008, 04:15 PM   #2
keratos
Member
 
Registered: May 2007
Location: London, UK.
Distribution: Major:FC8. Others:Debian;Zenwalk; Arch; Slack; RHEL.
Posts: 544

Original Poster
Rep: Reputation: 30
bump

sorry, I should have read this first...

http://www.redhat.com/docs/en-US/Red...onfig-add.html

all is okay now :-)
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
A frontend to change the fonts of xterm/mrxvt using the ~/.fonts folder ? frenchn00b Linux - General 1 05-28-2008 12:28 PM
[Console] an xterm type with ttf fonts as fonts ? frenchn00b Linux - Desktop 1 08-04-2007 04:32 PM
Can't select all fonts in all programs rickh Debian 0 09-07-2006 12:41 PM
MS Webcore fonts not rendering properly in KDE sc0undrel Mandriva 4 01-18-2006 12:15 AM
Select() did not select my socket thvo Programming 1 05-08-2005 12:20 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Fedora

All times are GMT -5. The time now is 07:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration