LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-07-2016, 12:27 PM   #1
mattthumper
LQ Newbie
 
Registered: Jan 2016
Posts: 19

Rep: Reputation: Disabled
USB Microphone Works with Audacity but not on the Web


Hi,

I recently got my USB microphone working with Audacity under:
Debian 3.16.7-ckt20-1+deb8u1 (2015-12-14) i686 GNU/Linux

What I'd like to do is use that same microphone at the following Google/Chrome link in order to convert speech to text (mostly for the purposes of automating my note-taking process.):
https://www.google.com/intl/en/chrome/demos/speech.html

But the the microphone is never recognized, so nothing happens.
(And, BTW, the same microphone works fine on that same link/site when I'm using my Windoze box instead of the Linux machine.)

Here's further information:
My mic (from lsusb) - Bus 005 Device 003: ID 0d8c:013c C-Media Electronics, Inc. CM108 Audio Controller

Audacity Devices - Host: ALSA; Playback Device: default; Recording: USB PnP Sound Device: Audio (hw:1,0): Mic:0; Channels: 1 (Mono)

Audacity Recording - Overdub (checked); Latency: Audio to buffer: 100; Latency correction: -130; Sound Activation Recording (checked); Sound Activation Level -50

Audacity Quality - Default Sample Rate: 44100 Hz; Real-time Conversion Default Sample Format: 32-bit float; Sample Rate Converter: Medium Quality; Dither: None;
High-quality Conversion Sample Rate Converter: Best Quality (Slowest) Dither: Shaped


How do I get the microphone to be recognized by my Google-Chrome browser?
TIA, Matt
 
Old 01-07-2016, 01:17 PM   #2
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 279Reputation: 279Reputation: 279
Is pulseaudio installed? If so, you need to select the mic there. Pulseaudio can be a PITA to configure, and it's not always stable. The site can't see the device if pulseaudio doesn't show it.
 
Old 01-08-2016, 10:45 AM   #3
mattthumper
LQ Newbie
 
Registered: Jan 2016
Posts: 19

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by sgosnell View Post
Is pulseaudio installed? If so, you need to select the mic there. Pulseaudio can be a PITA to configure, and it's not always stable. The site can't see the device if pulseaudio doesn't show it.
Thanks for the reply.
It's installed, but cannot run:
/home/matthew : [861]

pulseaudio &
[3] 5957

/home/matthew : [862]

E: [pulseaudio] pid.c: Daemon already running.
E: [pulseaudio] main.c: pa_pid_file_create() failed.

[3]+ Exit 1 pulseaudio


-----
Any ideas?

Thanks again.
 
Old 01-08-2016, 04:02 PM   #4
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 279Reputation: 279Reputation: 279
It can't run because it's already running. You can't run multiple instances of it, only one, and it plainly says it's already running. I would suggest installing the pulseaudio volume control, run it, and see what is actually being selected as the microphone to use.
 
Old 01-09-2016, 08:08 AM   #5
mattthumper
LQ Newbie
 
Registered: Jan 2016
Posts: 19

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by sgosnell View Post
It can't run because it's already running. You can't run multiple instances of it, only one, and it plainly says it's already running. I would suggest installing the pulseaudio volume control, run it, and see what is actually being selected as the microphone to use.
Again, thanks for your patience.

When I run pavucontrol I see my mic on the Input Devices tab as well as the Configuration tab.
On the Input Devices tab it shows up as "CM108 Audio Controller Analog Mono", Port: Microphone; "Built-in Audio Analog Stereo", Port: Microphone/Microphone 1

On the Configuration tab it shows up as "CM108 Audio Controller", Profile: Analog Mono Input; "Built-in Audio", Profile: Analog Stereo Duplex

FWIW, I got 'arecord' to work also, via:
arecord --format=S16_LE --rate=44100 -D hw:1,0 --duration=5 /home/matthew/testme2.wav


Any ideas on what I should do now?

TIA, Matt

Last edited by mattthumper; 01-09-2016 at 08:49 AM.
 
Old 01-09-2016, 09:39 AM   #6
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 279Reputation: 279Reputation: 279
Is it actually selected in pavucontrol? You probably have to have an input application working in order to change selections. It's showing two ports, but I can't tell which is being used. The gui control on my system shows the chrome input and output, and clicking on whichever is displayed shows all the possible devices with a radio button to select one. If you're running pavucontrol from the command line, I need to research that, I haven't used it in some time so my memory isn't complete on it.
 
Old 01-09-2016, 10:02 AM   #7
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 279Reputation: 279Reputation: 279
I just tried pavucontrol, and it uses the same GUI as from the menus. ISTR a different interface once, but perhaps my memory is failing. In any case, open the website and pavucontrol, then make sure your USB mic is selected as the input source, and that audio is being detected from it. The vu control underneath it should show that. Actually, as an input device it should be detected without having the website loaded. Select it and see if it reflects audio input. Pulseaudio is not intuitive, and you may need to select the proper port for recording and output. To select the port for recording, you must have an application for recording open and running. Also, on the Configuration tab, make sure the USB mic is turned on. If it works under Audacity it should be, but it's worth checking.
 
Old 01-09-2016, 11:54 AM   #8
mattthumper
LQ Newbie
 
Registered: Jan 2016
Posts: 19

Original Poster
Rep: Reputation: Disabled
Thumbs up Solved

Thanks for the help.
It now works.
 
Old 01-09-2016, 12:03 PM   #9
sgosnell
Senior Member
 
Registered: Jan 2008
Location: Baja Oklahoma
Distribution: Debian
Posts: 1,054

Rep: Reputation: 279Reputation: 279Reputation: 279
Glad you got it sorted out. Pulseaudio is an abomination, from the same dev who brought out systemd. User-friendliness is not something he understands, or even suspects.
 
1 members found this post helpful.
Old 01-21-2016, 03:56 PM   #10
patrick295767
Member
 
Registered: Feb 2006
Distribution: FreeBSD, Linux, Slackware, LFS, Gparted
Posts: 624

Rep: Reputation: 135Reputation: 135
Quote:
Originally Posted by sgosnell View Post
Glad you got it sorted out. Pulseaudio is an abomination, from the same dev who brought out systemd. User-friendliness is not something he understands, or even suspects.
indeed.

Pulseaudio is not your friend, it will more raise problems than solve anything.

A classical .asoundrc might look like this.

Code:
 pcm.!default { 
          type asym 
          playback.pcm { 
                  type plug 
                  slave.pcm "hw:1,0" 
          } 
          capture.pcm { 
                  type plug 
                  slave.pcm "hw:1,0" 
          }  
 }
(on card #1, alsamixer -c1)

Simply use apulse if you need skype.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Microphone problem with skype & audacity ... =( malikcpp Slackware 2 03-26-2012 08:20 PM
[SOLVED] how do I disable builtin microphone in audacity? nokangaroo Linux - Software 6 11-27-2010 05:12 PM
[audacity][skype] can't get a microphone to work RRH Linux - Software 3 10-03-2009 05:46 AM
microphone, audacity, skype, recording le1 Linux - Hardware 10 08-21-2008 09:28 AM
no microphone signal with audacity Hewson Linux - Software 1 10-26-2007 06:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:51 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration