LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-21-2011, 10:58 PM   #1
apt-get
Member
 
Registered: Dec 2010
Distribution: Debian Squeeze (Console Only)
Posts: 79

Rep: Reputation: 7
System Beep on Shutdown, Not Related to pcspkr


Hey everyone, I need a little help here.

Whenever I tell my laptop to shut down, it gives me that horrid loud noise. When my headphones are plugged in, it comes in through there, and when they're not, it comes out the regular speakers. This is regardless of my mixer settings and pcspkr. I blacklisted that module and it still does this.

Any help please? Running Debian Squeeze on a laptop so ripping out the speaker inside isn't feasable, and still, the sound's not coming through there anyway.

I did a lot of googling and it's all the same answers that I've already tried, like blacklisting pcspkr and changing the mixer settings.

Help please?
 
Old 02-22-2011, 03:35 AM   #2
TobiSGD
Moderator
 
Registered: Dec 2009
Location: Germany
Distribution: Whatever fits the task best
Posts: 17,148
Blog Entries: 2

Rep: Reputation: 4858Reputation: 4858Reputation: 4858Reputation: 4858Reputation: 4858Reputation: 4858Reputation: 4858Reputation: 4858Reputation: 4858Reputation: 4858Reputation: 4858
Had a similar issue sometime ago, for me it was changing the kernel that worked (now using the one from Liquorix).
 
Old 02-23-2011, 01:15 AM   #3
oOarthurOo
LQ Newbie
 
Registered: Feb 2011
Location: ZZ9 Plural Z Alpha
Distribution: Debian
Posts: 17

Rep: Reputation: 5
audio card model and name would be helpful

when you muted your audio channels did you store the settings before shutting down (alsactl store)?

blacklisting wouldn't guarantee it's not loaded. Before shutting down do you confirm that the pcspkr module isn't there?
 
Old 09-20-2011, 02:28 PM   #4
pgreenwood
LQ Newbie
 
Registered: Nov 2003
Location: Omaha, Nebraska USA
Distribution: Debian and derivatives; dabbled in others
Posts: 26

Rep: Reputation: 1
Quote:
Originally Posted by apt-get View Post
Hey everyone, I need a little help here.

Whenever I tell my laptop to shut down, it gives me that horrid loud noise. When my headphones are plugged in, it comes in through there, and when they're not, it comes out the regular speakers. This is regardless of my mixer settings and pcspkr. I blacklisted that module and it still does this.

Any help please? Running Debian Squeeze on a laptop so ripping out the speaker inside isn't feasable, and still, the sound's not coming through there anyway.

I did a lot of googling and it's all the same answers that I've already tried, like blacklisting pcspkr and changing the mixer settings.

Help please?
This issue has been bothering me for a long time too. Now it bothers me enough that I want to do something about it. As best I can determine, the bell on
Code:
shutdown -h now
comes from wall, because when I invoke wall by itself, I get the same bell or "beep" that I get when I invoke
Code:
halt
or shutdown. If I shutdown from X within GDM, I get the same bell I cannot silence whether or not there are xterms or gnome terminals open in X.

I'm the only user on this system. I really don't want a bell to sound every time I shut down the system. Where does one go to disable or comment-out the bell called by wall? Thanks.

Debian squeeze/sid amd64 on Vostro 1520 laptop with intel soundcard.
 
Old 09-20-2011, 05:01 PM   #5
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,079

Rep: Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135
It's never really bothered me enough to want to disable it... but if you uncomment the line

Code:
set bell-style none
In /etc/inputrc the bell should be disabled system wide.
 
Old 09-20-2011, 09:27 PM   #6
pgreenwood
LQ Newbie
 
Registered: Nov 2003
Location: Omaha, Nebraska USA
Distribution: Debian and derivatives; dabbled in others
Posts: 26

Rep: Reputation: 1
Quote:
Originally Posted by Caravel View Post
It's never really bothered me enough to want to disable it... but if you uncomment the line

Code:
set bell-style none
In /etc/inputrc the bell should be disabled system wide.
Thanks for the response, Caravel, but that doesn't silence the bell on shutdown, halt or /usr/bin/wall. I will keep looking. Let me know if you think of anything else.
 
Old 09-21-2011, 12:36 AM   #7
Cheesesteak
Member
 
Registered: Jun 2008
Distribution: Slackware
Posts: 102

Rep: Reputation: 24
Check and see if the module snd_pcsp is loaded. You may need to unload/blacklist it.
 
Old 09-21-2011, 08:51 PM   #8
pgreenwood
LQ Newbie
 
Registered: Nov 2003
Location: Omaha, Nebraska USA
Distribution: Debian and derivatives; dabbled in others
Posts: 26

Rep: Reputation: 1
Quote:
Originally Posted by Cheesesteak View Post
Check and see if the module snd_pcsp is loaded. You may need to unload/blacklist it.
I have a lot of snd_* modules loaded, but snd_pcsp is not one of them.

snd_hda_codec_idt
snd_hda_intel
snd_hda_codec
snd_hwdep
snd_pcm
snd_seq
snd_timer
snd_seq_device
soundcore
snd_page_alloc
sd_mod
sdhci_pci
sdhci

Thanks
 
Old 09-22-2011, 04:13 AM   #9
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,079

Rep: Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135Reputation: 1135
You're right it's nothing to do with the bell or pc speaker. I've had this before on a certain kernel while squeeze was still in testing. It's a loud beep which comes via the sound chip/card as soon as you shut down and not pc speaker.

Try the following first as a troubleshooting exercise:

Exit from your DE back to gdm then do CTRL+Alt+Fn (1/2/3/4/5/6) login/su to root

Code:
/etc/init.d/gdm stop && shutdown -h now
Is there a beep on shut down?
 
Old 09-23-2011, 07:10 PM   #10
pgreenwood
LQ Newbie
 
Registered: Nov 2003
Location: Omaha, Nebraska USA
Distribution: Debian and derivatives; dabbled in others
Posts: 26

Rep: Reputation: 1
Quote:
Originally Posted by Caravel View Post

Try the following first as a troubleshooting exercise:

Exit from your DE back to gdm then do CTRL+Alt+Fn (1/2/3/4/5/6) login/su to root

Code:
/etc/init.d/gdm stop && shutdown -h now
Is there a beep on shut down?
Yes, it still beeps.
 
Old 10-08-2011, 01:42 AM   #11
deb-wrangler
LQ Newbie
 
Registered: Oct 2011
Posts: 1

Rep: Reputation: Disabled
might be alsa mixer bug

Sounds like exactly the trouble I had, and the process I've been through. One possibility is to check the alsamixer settings - even if the PC speaker is set to 0 volume, the beep still comes through at full volume - if you mute it (press 'm' or ',' key if you are in the command line gui) it should stop all system beeps - at least that's what worked for me. You can
also simply type
Code:
amixer set "PC Beep" off
which also worked for me.

Because this thread comes up early in google results I would also like to re-iterate that
disabling pcspkr or snd_pcsp DOES NOT WORK -at least not in Debian Squeeze, which I'm pretty sure doesn't load these modules anyway. Neither does changing bell settings in the terminal.

Hope this helps.
 
1 members found this post helpful.
Old 10-09-2011, 02:43 PM   #12
pgreenwood
LQ Newbie
 
Registered: Nov 2003
Location: Omaha, Nebraska USA
Distribution: Debian and derivatives; dabbled in others
Posts: 26

Rep: Reputation: 1
Quote:
Originally Posted by deb-wrangler View Post
Sounds like exactly the trouble I had <snip> simply type
Code:
amixer set "PC Beep" off
which also worked for me. <snip>
Code:
amixer set "PC Beep" off
...seems to work. If I find out differently, I will post.

<bowing in homage>My wife, my neighbors and total strangers thank you, deb-wrangler, for your suggestion and solution!</bowing in homage>
 
Old 10-13-2011, 04:11 PM   #13
dru8274
Member
 
Registered: Oct 2011
Location: New Zealand
Distribution: Debian
Posts: 105

Rep: Reputation: 37
I have had the same problem. And, I recently posted a question about it on the debian forums here.

In my case, the beep related to the gdm3 display manager. And blacklisting various modules didn't help. Modifying gdm3's config files didn't resolve it for me either. But someone suggested that I install gnome-alsamixer, and choose the disable beep option... and that fixed it for me.

Annoying beeps are a special curse, because there can be several possible causes...

Last edited by dru8274; 10-13-2011 at 04:27 PM. Reason: missing word
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Terminal Shutdown -h -P with a beep? Amdx2_x64 Linux - General 3 11-03-2010 12:59 PM
[SOLVED] How to Disable the Terminal Beep when running the Shutdown command? Zoot Linux - General 6 09-03-2009 02:06 PM
shutdown goes back to GDM and makes PC speaker beep powerpleb Linux - Newbie 3 04-20-2008 12:39 AM
hard drive making emerg. parking beep at shutdown Geocritter Linux - Laptop and Netbook 4 01-20-2007 02:11 PM
disable reboot/shutdown beep yiang Linux - Newbie 13 04-26-2006 11:47 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 01:37 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration