LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-18-2007, 04:55 PM   #1
lindberg.bill
Member
 
Registered: Jan 2007
Distribution: Slackware 11, ubuntu edgy, debian
Posts: 60

Rep: Reputation: Disabled
simple mistake I'm sure


I'm trying to dual monitor. One video card. I've never used debian before, but I assumed that I could install nvidia via synaptic then use twinview by modifing x86config-4, Ive installed by synaptic once and with the terminal once, neither time after reconfiguring x did my settings take effect. the xf86config-4 stays the same. also no changes that I make on the xf86config-4 seem to make any difference or take effect. Am I looking at the right file to exit.

Just to avoid confusion I've used the ubuntu forum twinview tutorial inorder to get twinview options. It just doesn't work.

I have done this before loads of times in ubuntu and slackware what is the difference this is quite troubling.
 
Old 03-18-2007, 06:20 PM   #2
lindberg.bill
Member
 
Registered: Jan 2007
Distribution: Slackware 11, ubuntu edgy, debian
Posts: 60

Original Poster
Rep: Reputation: Disabled
I'm going to try etch

upgrading to etch and I'll try dual monitors again, I'll post what happens
 
Old 03-18-2007, 06:32 PM   #3
Dutch Master
Senior Member
 
Registered: Dec 2005
Posts: 1,686

Rep: Reputation: 124Reputation: 124
Did you install Stable or Testing? You mention XFree 86, but maybe you're overlooking the Xorg config files used in Testing (Etch).

nVidia only provides proprietary 3D drivers, which will *never* be in the Debian repositories. Download and install them manually. Keep in mind that Debian is not equal to Ubuntu!!

After you've installed the nVidia drivers, use the command nvidia-settings as root to adjust your screen(s). Make sure to save the file after you've applied the changes.
 
Old 03-19-2007, 04:00 PM   #4
lindberg.bill
Member
 
Registered: Jan 2007
Distribution: Slackware 11, ubuntu edgy, debian
Posts: 60

Original Poster
Rep: Reputation: Disabled
Now I've done it. Switching to ETCH from SARGE made all the difference. I'm not sure why it didn't work in sarge, but with etch all that is needed is to install nvidia and twinview as in the many examples available on the net. Simple fix indeed! Too bad it takes so long to upgrade the distro.
 
Old 03-23-2007, 09:01 AM   #5
lancest
Member
 
Registered: Jun 2002
Location: ASIA
Distribution: Ubuntu, Fedora
Posts: 49

Rep: Reputation: 15
Can you post your working xorg with Twinview?

Linux Mint. Nvidia Geforce Go 7400 on ASUS W7J notebook
Have not been able to configure Twinview working though I previously had it in SuSE 10.2 using SaX2. Can you post yours?
 
Old 03-25-2007, 08:00 PM   #6
lindberg.bill
Member
 
Registered: Jan 2007
Distribution: Slackware 11, ubuntu edgy, debian
Posts: 60

Original Poster
Rep: Reputation: Disabled
Please note that I have made these changes in accordance with the ubuntu forums suggestions on twinview, and only after successfully installing the nvidia proprietary drivers which are availble on their website
http://www.ubuntuforums.org/showthread.php?p=1773584
http://www.nvidia.com/object/linux_d..._1.0-9755.html
I have used this method in Slackware 11, Ubuntu Edgy & Drapper, Debian Etch, but not Debian Sarge (I'm sure it would have worked if I hadn't given up so that I could upgrade to Etch, which by the way seems much easier to work with)

this is, obviously, only the device section of my /etc/X11/xorg.conf

Section "Device"
Identifier "NVIDIA Corporation NV43 [GeForce 6600 GT]"
Driver "nvidia"
Option "TwinView" "True"
Option "TwinViewOrientation" "RightOf"
Option "UseEdidFreqs" "True"
Option "MetaModes" "1280x1024,1280x1024; 1024x768,1024x768"
Option "UseDisplayDevice" "CRT"
EndSection

I hope this helps. I love having two monitors, for what I do it helps.
 
Old 03-26-2007, 12:05 AM   #7
lancest
Member
 
Registered: Jun 2002
Location: ASIA
Distribution: Ubuntu, Fedora
Posts: 49

Rep: Reputation: 15
Would this config work for a laptop? Thanks

On a laptop also? 1280x800 native for projector would need 1024x800
Your Twinview is similar to the Ubuntu forums posted one - I tried with no success. I will try it again- I think there may be a line or two difference.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
simple php class basics mistake spoody_goon Programming 5 07-10-2006 10:46 PM
rpm mistake rsarson Linux - Software 2 07-18-2004 08:50 AM
My up2date mistake onewhoknows Linux - Newbie 1 07-14-2004 07:37 PM
what mistake am i doing for this simple sharing mobassir Linux - Networking 9 10-29-2003 09:50 AM
I made a mistake! Need help now jcksrobbins Mandriva 8 08-30-2003 10:17 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 01:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration