View the Most Wanted LQ Wiki articles.
Go Back > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Debian This forum is for the discussion of Debian Linux.


  Search this Thread
Old 03-20-2012, 02:47 PM   #1
Registered: Nov 2006
Location: Argentina
Distribution: Debian
Posts: 320
Blog Entries: 1

Rep: Reputation: 31
Problem with wheezy/Sid PXE installation

I'm setting a PXE boot environment in order to easily install the distro that I more frequently use. My goal is create a menu and then select which version of Debian install.

I set up a PXE booting environment following this procedure:

I created directories tree for:

squeeze, lenny, wheezy and sid.
Wrote the menu, etc.
Installation goes just fine with Squeeze and Lenny.
But if I tried booting both wheezy or sid the installer doesn't detect the hard disk. I'm running test from and old box (P. III whit p-ata hard disk).

For wheezy I got linux image and initrd from here:
I tried the same procedure with a Virtualbox VM, booting over PXE. And I got the same error using stock ide virtualization.
Does anybody have an idea of what could be wrong?

Last edited by matiasar; 03-20-2012 at 02:58 PM. Reason: adding info
Old 04-03-2012, 10:33 PM   #2
Registered: Jul 2010
Location: Skynet
Distribution: Debian + Emacs
Posts: 467
Blog Entries: 60

Rep: Reputation: 51
I'm not a Debian user so much, but I remember I while back there was a switch in the kernel from an old IDE subsystem to a newer one layered on top of libata. IIRC, the new subsystem doesn't handle some of the older drives. I vaguely remember losing access to an old drive under Gentoo because of this. I'm guessing that sid and wheezy are using the newer kernels. Additional reading:


install, pxe, wheezy

Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
wheezy netinst iso installation problem? shams Debian 5 07-14-2012 11:24 PM
[SOLVED] Java and Vuze installation on KDE Debian Wheezy sid infoslaw Linux - Newbie 11 12-28-2011 09:24 AM
synaptics touchpad not found : Wheezy/sid bennethos Debian 3 05-12-2011 05:54 AM
LXer: Living on the bleeding edge: Debian wheezy/sid LXer Syndicated Linux News 0 02-14-2011 08:20 PM
PXE installation problem - can only select A series packages for installation Nylex Slackware 4 08-19-2010 03:15 PM

All times are GMT -5. The time now is 12:40 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration