LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 06-28-2012, 04:38 PM   #1
tondalar
LQ Newbie
 
Registered: Oct 2011
Posts: 19

Rep: Reputation: Disabled
nm-applet works in Gnome, not in Fluxbox


I'm having an odd issue setting up Fluxbox.

When using Gnome 3, nm-applet works perfectly. I can see and connect to wireless signals without a problem. However, when I run Fluxbox, nm-applet refuses to run with the following error:

Code:
** Message: applet now removed from the notification area

(nm-applet:5320): GdkPixbuf-CRITICAL **: gdk_pixbuf_scale_simple: assertion `dest_width > 0' failed
Everything I've found through Google says to add "nm-applet &" to the end of ~/.fluxbox/startup. That does nothing to help me, obviously.

Nothing appears in the Slit, nor anywhere else. nm-applet will just hang at that error when I run it manually in terminal. And, obviously, nothing at all happens when Fluxbox starts it when I login.

I've also tried using wicd, but that doesn't seem to recognize my wireless card at all to begin with.
 
Old 06-28-2012, 05:55 PM   #2
jim_p
Member
 
Registered: Aug 2009
Distribution: Debian testing
Posts: 556

Rep: Reputation: 127Reputation: 127
Due to the fact that I have no idea about fluxbox configuration, I suggest disabling the tray or the panel altogether and using another panel+tray app, like fbpanel or tint2 to check if the problem still occurs.
If it does, there is some problem with fluxbox's built in tray.

As for wicd, please check if your card is listed as wlan1 or something else in ifconfig, and set it accordingly in wicd's options.
And wicd and nm do not match, so when running one, remove the other.

Last edited by jim_p; 06-28-2012 at 05:56 PM.
 
1 members found this post helpful.
Old 06-28-2012, 09:53 PM   #3
tondalar
LQ Newbie
 
Registered: Oct 2011
Posts: 19

Original Poster
Rep: Reputation: Disabled
I have tried it without Fluxbox's tray active, no change.
Tried with tint2, no change
However, even if fluxbox's tray is active, if I bring up gnome-panel it works fine.

I'll double check the wicd config. And yes, when I bring up one I make sure to kill the process for the other.
 
Old 06-29-2012, 02:26 PM   #4
tondalar
LQ Newbie
 
Registered: Oct 2011
Posts: 19

Original Poster
Rep: Reputation: Disabled
Ok, so I checked and indeed wicd was pointing to a non-existent wireless device. Now I see the wifi networks fine. However, I'm having major issues connecting to WPA protected networks. The wicd log always shows an "Operation failed" error after a DHCP attempt begins.

I've tried having wicd use dhchcd, dhclient, pump and udhcpc. All fail to the same. Pump did work once, but when I disconnected once I can no longer connect at all again, even after reboots. All the dhcp packages are at the latest version.
 
Old 06-29-2012, 05:28 PM   #5
cynwulf
Senior Member
 
Registered: Apr 2005
Posts: 2,186
Blog Entries: 5

Rep: Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248Reputation: 1248
Works fine here in openbox with tint2, Debian Sid.
Code:
$ nm-applet &
[1] 3391
$ ** Message: applet now removed from the notification area
** Message: applet now embedded in the notification area

(nm-applet:3391): libnotify-WARNING **: Failed to connect to proxy

** (nm-applet:3391): WARNING **: Failed to show notification: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.freedesktop.Notifications was not provided by any .service files
//edit also working in fluxbox. I do see the same error you reported but the applet is there on the far right hand side of the panel.

If you're running stable install the network-manager-gnome from backports, if that doesn't help or you're running testing/unstable - no idea. Have a look at bug reports... http://bugs.debian.org/cgi-bin/pkgre...;dist=unstable

Last edited by cynwulf; 06-29-2012 at 06:00 PM.
 
Old 07-03-2012, 05:51 PM   #6
bitches_brew
LQ Newbie
 
Registered: Jul 2012
Posts: 1

Rep: Reputation: Disabled
same problem here... PLEASE HELP! this is really annoying.

I use Xubuntu 12.04 with fluxbox.

icons of "update-notifier" and "crash reports" also don't work.

I have noticed that problem occurs only if toolbar height is <= 14px.
If toolbar height > 14px evetything works fine.

-------

because problem is with the function gdk_pixbuf_scale_simple.
Maybe scaling these icons to toolbar size manually would be a workaround?

I tried to scale all icons called nm-* in /usr/share/icons/Humanity/*, but it didn't work ;/

What icons exactly should I scale?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
gnome applet shogun1234 Programming 0 06-06-2010 04:03 AM
fluxbox taskbar applet for managing sound in ubuntu 8.10 Mechfly Linux - Desktop 5 03-22-2009 08:52 PM
Applet works on Windows, Ubuntu and Mac, but not on Redhat and Fedora bhaskar_e Programming 3 10-22-2008 03:00 AM
How do I run a kicker applet in my fluxbox system tray? jerkface Linux - Desktop 1 09-25-2006 10:06 PM
mixer applet in fluxbox fransemail Linux - Software 2 04-24-2004 02:42 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 08:01 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration