LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 01-06-2006, 09:28 AM   #1
Ephracis
Senior Member
 
Registered: Sep 2004
Location: Sweden
Distribution: Ubuntu, Debian
Posts: 1,109

Rep: Reputation: 49
KDE and Gnome freezes at startup (testing)


I was just recently upgrading my installed packages and a lot of kde packages was upgraded from 3.3.X (I think) to 3.4.3 (if anyone can give me hints about how to see update history I would be glad).

After that I made a small restart and another apt-get dist-upgrade. After that everything went fine until I rebooted the box again. Now I can't seem to get into either KDE or Gnome. After KDM has logged in it starts to load KDE and freezes before it gets inside. The same with Gnome, even if I don't run KDM before, just types "startx".

I've had problems with the nvidia drivers after updating xorg but that doesn't seem to be the problem now. I can't even get anywhere if I try to run on a different driver like nv or vesa. Fluxbox seems to be running fine, tou.

Is there any logfiles I can check into? Xorg.log tells me everything is fine and the only errors I get from kdm.log is that the glx module can't be loaded for some reason.

How should I approach this problem?
 
Old 01-07-2006, 02:28 PM   #2
halvy
Member
 
Registered: Aug 2005
Location: Anchorage, Alaska (soon EU, hopefully)
Distribution: Anything NOT SystemD (ie. M$) related.
Posts: 918

Rep: Reputation: 42
i'd check out glx problem mentioned by kde.

also make sure you give gnome and kde enuff time to initiallly load-- sometimes it wants to sit there and think about the new upgrade info.. and that could take several minutes.

you say fluke box boots up tho.. so that is a good sign (does fluke use glx?).

as far as 'roll backing' is concerned.. my roll back is called a backup partitian

Last edited by halvy; 01-07-2006 at 02:29 PM.
 
Old 01-07-2006, 04:20 PM   #3
Ephracis
Senior Member
 
Registered: Sep 2004
Location: Sweden
Distribution: Ubuntu, Debian
Posts: 1,109

Original Poster
Rep: Reputation: 49
Quote:
Originally Posted by halvy
i'd check out glx problem mentioned by kde <snip>
you say fluke box boots up tho.. so that is a good sign (does fluke use glx?).
Haven't heard of this but I've been having some problems with glx for my nvidia card. Anyway, I reinstalled Debian and after a few problems solved it is working now. Don't know what's the difference, tho. :/
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Gnome menu mixed with KDE in Debian Testing Underhill Debian 1 09-14-2005 06:15 PM
Gnome freezes during startup after installing fvwm2 deep_inda_jungl Mandriva 0 05-09-2005 09:16 AM
Gnome AND KDE hanging on startup! pascal16 Linux - Software 4 03-23-2005 12:14 PM
couple of qs, gnome ftp, removing kde or improving speed of kde, startup modprobe darkleaf Linux - Software 2 07-20-2004 09:54 AM
Gnome freezes while KDE works Relja Linux - General 0 01-28-2003 10:07 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 02:54 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration