LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 05-27-2004, 02:16 PM   #1
novel15
LQ Newbie
 
Registered: May 2004
Posts: 6

Rep: Reputation: 0
Wink i cannot mount a ntfs partition


Hi

I am a new user of linux debian .I have some problemes und i hope that someone can
help me to resolve this probleme.

well I am trying to mount a NTFS partition but i can't.I became always the following Error.


root # mount -t ntfs /dev/hda1 /mnt/XP

mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems

root:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda6 none swap sw 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hdc /media/cdrom iso9660 ro,user,noauto 0 0
/dev/hdc /cdrom iso9660 ro,user,noauto 0 0
/dev/hda1 /mnt/XP ntfs ro,users,owner,umask=000 0 0


root # fdisk -l

Disk /dev/hda: 40.0 GB, 40007761920 bytes
255 heads, 63 sectors/track, 4864 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes

Device Boot Start End Blocks Id System
/dev/hda1 * 1 1530 12289693+ 7 HPFS/NTFS
/dev/hda2 1531 4018 19984860 83 Linux
/dev/hda3 4019 4863 6787462+ f W95 Ext'd (LBA)
/dev/hda5 4081 4863 6289416 e W95 FAT16 (LBA)
/dev/hda6 4019 4080 497952 82 Linux swap

Partition table entries are not in disk order
root# df -h
Filesystem Size Used Avail Use% Mounted on
/dev/hda2 19G 1.3G 17G 8% /
tmpfs 248M 0 248M 0% /dev/shm


root# lsmod |grep ntfs
ntfs 79436 0


I don' t know what to do maybe someone can help me ?

Thank you for your interesting .
 
Old 05-27-2004, 04:19 PM   #2
Zoombie
Member
 
Registered: Jul 2003
Distribution: Debian Testing
Posts: 180

Rep: Reputation: 30
Seems like it should work. Maybe the permissions for /dev/hda1 are messed up.
 
Old 05-27-2004, 04:30 PM   #3
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Rep: Reputation: 32
hello and welcome to the forum...
this is my fstab file for debian sid....

# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda1 /mnt/hda1 ntfs user,exec,ro 0 0
/dev/hda5 /mnt/hda5 vfat user,exec 0 2
/dev/hda6 /mnt/hda6 vfat user,exec 0 2
/dev/hda9 none swap sw 0 0
/dev/hda7 /boot ext3 defaults 0 2
/dev/hda8 / ext3 defaults,errors=remount-ro 0 1
/dev/hdc /media/cdrom iso9660 ro,user,noauto 0 0
/dev/hdc /media/cdrom0 iso9660 ro,user,noauto 0 0
/dev/hdd /media/cdrom1 iso9660 ro,user,noauto 0 0
/dev/fd0 /media/floppy auto rw,user,noauto 0 0
/dev/hdc /cdrom iso9660 ro,user,noauto 0 0


on my system hda2 is the extended partition for the balance ot the drive so nothing is mounted on it.....
 
Old 05-27-2004, 06:23 PM   #4
novel15
LQ Newbie
 
Registered: May 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you for your interessting

i think the problem ist not due to the permission messing ,because "mount" has already worked as i crearted for the first time the mount point /mnt/XP.
but now he don't work and I become still the seam ERROR.
 
Old 05-27-2004, 06:53 PM   #5
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Rep: Reputation: 32
Re: i cannot mount a ntfs partition

Quote:
Originally posted by novel15
[B]Hi

I am a new user of linux debian .I have some problemes und i hope that someone can
help me to resolve this probleme.

well I am trying to mount a NTFS partition but i can't.I became always the following Error.


root # mount -t ntfs /dev/hda1 /mnt/XP

mount: wrong fs type, bad option, bad superblock on /dev/hda1,
or too many mounted file systems

root:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
/dev/hda6 none swap sw 0 0
/dev/hda2 / ext3 defaults,errors=remount-ro 0 1
/dev/hdc /media/cdrom iso9660 ro,user,noauto 0 0
/dev/hdc /cdrom iso9660 ro,user,noauto 0 0
/dev/hda1 /mnt/XP ntfs ro,users ,owner,umask=000 0 0
also ...is owner necessary.....since owner would also be a user...?

should the part i outline in red by user and not users..?
 
Old 05-27-2004, 07:39 PM   #6
novel15
LQ Newbie
 
Registered: May 2004
Posts: 6

Original Poster
Rep: Reputation: 0
Thank you tanya

But i have changed users with user but the ERROR is still exist
 
Old 05-28-2004, 12:42 AM   #7
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Rep: Reputation: 32
Quote:
Originally posted by novel15
Thank you tanya

But i have changed users with user but the ERROR is still exist
change your hda1 line to this...

try this:
# cd /mnt/
mkdir hda1
cd /etc
cp fstab /fstab.bak

now change your hda1 line to

/dev/hda1 /mnt/hda1 ntfs user,exec,ro 0 0
and reboot...

see what happens....we can always change back

oh btw....my name is not tanya.....
it is utanja.....(tonya is also ok.) but not tanya
 
Old 05-28-2004, 04:50 PM   #8
novel15
LQ Newbie
 
Registered: May 2004
Posts: 6

Original Poster
Rep: Reputation: 0
I am sorry Tonya

It s good idee ,but sadly it does 't work.

thanks
 
Old 05-28-2004, 05:21 PM   #9
utanja
Member
 
Registered: Apr 2004
Location: Europe:Salzburg Austria USA:Orlando,Florida;
Distribution: Debian
Posts: 643

Rep: Reputation: 32
Quote:
Originally posted by novel15
I am sorry Tonya

It s good idee ,but sadly it does 't work.

thanks
as i said earlier...

the PC basically can only support one expanded partition.... the rest must be extended partitions located on the expanded partition.....sort of virtual drives....

i believe this is your problem,.......

i access NTFS and VFAT as well as ext3 and ext2 partitions....on debian
 
Old 05-20-2007, 02:58 AM   #10
tescovee
LQ Newbie
 
Registered: May 2005
Posts: 1

Rep: Reputation: 0
a day late and a dollar short



sudo mount -t ntfs -o umask=0 /dev/hdc1 /media/windows
 
Old 05-22-2007, 12:38 AM   #11
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
I had ntfs-3g installed on my Etch when it was the testing distribution, below is a copy of the /etc/fstab line I used that I found in some tutorial, the nls=utf8 is one I've seen in all fstab lines created by installers of the distributions I've installed that set up the ntfs partition. Do not put the "3g" after "ntfs" if you do not have ntfs-3g installed which gives everybody read/write access to ntfs:
Code:
/dev/sda3       /mnt/data       ntfs-3g umask=0,nls=utf8        0       0
Also, because it reported a bad super block, it may be necessary to re-boot Windows twice to have Windows clear any filesystem errors it is broadcasting.
EDIT: Also, did you create the directory XP with command:
Code:
mkdir /mnt/XP
You did mention you did, and the errors do not mention it is missing.

Last edited by Junior Hacker; 05-22-2007 at 12:44 AM.
 
Old 07-14-2007, 04:06 AM   #12
skimeer
Member
 
Registered: Jun 2007
Posts: 62
Blog Entries: 1

Rep: Reputation: 0
hi, i'm having some doubts for mount commnd
what is mean by bad superblock error in mount command?
we can't mount cdr/w without having media in it?

Hoping positive response?
 
Old 07-14-2007, 11:31 AM   #13
Junior Hacker
Senior Member
 
Registered: Jan 2005
Location: North America
Distribution: Debian testing Mandriva Ubuntu
Posts: 2,687

Rep: Reputation: 61
In the other person's case, sometimes you do the wrong thing when trying to access ntfs partition from Linux, then the Windows ntfs file system has something in the journal that is meant to tell the operating system (Windows), that the file system may be corrupt and should be checked before it can be mounted. So booting up Windows is necessary to have it check the integrity of the file system.
Quote:
we can't mount cdr/w without having media in it?
This is perfectly normal, a CD is like another storage device similar to a hard drive, if it's not there, it can't be accessed/mounted.
 
Old 07-14-2007, 12:09 PM   #14
jschiwal
LQ Guru
 
Registered: Aug 2001
Location: Fargo, ND
Distribution: SuSE AMD64
Posts: 15,733

Rep: Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677Reputation: 677
You might try adding the options: "errors=continue,errors=recover"

Also, check the filesystem itself for errors. That same error message could mean a bad filesystem, or bad mount options.

Last edited by jschiwal; 07-14-2007 at 10:19 PM.
 
Old 07-15-2007, 06:29 AM   #15
skimeer
Member
 
Registered: Jun 2007
Posts: 62
Blog Entries: 1

Rep: Reputation: 0
reply

Quote:
Originally Posted by jschiwal
You might try adding the options: "errors=continue,errors=recover"

Also, check the filesystem itself for errors. That same error message could mean a bad filesystem, or bad mount options.
Thanks for the reply but it can't work Does it need some extra package to mount Ntfs in rhel5

thank's again
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
mount ntfs partition alaios Linux - General 2 09-09-2005 11:35 AM
How can I mount a NTFS partition? LegendBreath Fedora 1 06-05-2005 12:02 PM
How do you mount an NTFS partition? karaite SUSE / openSUSE 5 11-01-2004 01:18 PM
cannot mount partition (says it's NTFS but it's not!) d33pdream Linux - General 5 02-22-2003 10:46 PM
Mount an NTFS Partition? oostevo Linux - General 3 11-23-2001 07:17 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 04:39 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration