LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 02-16-2006, 12:49 PM   #1
fyanardi
Member
 
Registered: Aug 2005
Distribution: Debian sid
Posts: 40

Rep: Reputation: 15
http://localhost works in firefox but not in Konqueror


Hi all,

I installed apache2 from unstable repository, and I can view http://localhost from firefox browser, but if I try to open it using Konqueror, I got this message:

Server Error
The following error occurred:
[code=CANT_CONNECT_LOOPBACK] Cannot connect due to potential loopback problems
Please contact the administrator.

I don't know what's wrong here, as I didn't change any default configuration for the apache. I've also tried to RTFM & STFW but still no luck.

Thanks for any help
 
Old 02-16-2006, 04:18 PM   #2
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,618

Rep: Reputation: 104Reputation: 104
Do you have this line in your /etc/hosts?
Code:
127.0.0.1       localhost.localdomain   localhost
 
Old 02-16-2006, 06:04 PM   #3
fyanardi
Member
 
Registered: Aug 2005
Distribution: Debian sid
Posts: 40

Original Poster
Rep: Reputation: 15
Hi, thanks for your reply, I have this line in /etc/hosts:

127.0.0.1 localhost debian

I also tried to change to 127.0.0.1 localhost.localdomain localhost, but still get same problem.

Oh ya, when I start / restart the apache server, I get this message:

Starting apache 2.0 web server...apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName.

Thanks
 
Old 02-16-2006, 06:24 PM   #4
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
You can use the directive:
ServerName my.domain.here
 
Old 02-16-2006, 06:35 PM   #5
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,618

Rep: Reputation: 104Reputation: 104
Quote:
Originally Posted by fyanardi
Hi, thanks for your reply, I have this line in /etc/hosts:

127.0.0.1 localhost debian

I also tried to change to 127.0.0.1 localhost.localdomain localhost, but still get same problem.

Oh ya, when I start / restart the apache server, I get this message:

Starting apache 2.0 web server...apache2: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName.

Thanks
Ok do you have a lines like these ones in your /etc/network/interfaces then.

Code:
auto lo
iface lo inet loopback
The apache warning is just telling you that you do not have a domain name defined in the /etc/hosts file. It is not needed to access the pages you should be able to use the localhost and 127.0.0.1.
 
Old 02-16-2006, 09:41 PM   #6
fyanardi
Member
 
Registered: Aug 2005
Distribution: Debian sid
Posts: 40

Original Poster
Rep: Reputation: 15
Yes, i have those lines in my /etc/network/interfaces I also got this problem when I try it using lynx, only firefox does not give me this problem. Might it be something wrong with my apache configuration file?

Thanks
 
Old 02-16-2006, 09:47 PM   #7
dracae
Member
 
Registered: Feb 2006
Location: Oklahoma
Distribution: Debian Sid and Etch
Posts: 423

Rep: Reputation: 30
What is your hostname?
append your actual hostname to your hosts file like
120.0.0.1 localhost.localdomain localhost realhostname.localdomain realhostname
or if you have a static address add a new line
my.sta.tic.ip realhostname.localdomain realhostname
 
Old 02-17-2006, 02:16 AM   #8
fyanardi
Member
 
Registered: Aug 2005
Distribution: Debian sid
Posts: 40

Original Poster
Rep: Reputation: 15
My hostname is debian, so i should put this:
127.0.0.1 localhost.localdomain localhost debian.localdomain debian, shouldn't i? I tried that, but sill get the same error. Sorry, I didn't really get your first reply. I also have these following lines in my /etc/hosts:

Code:
127.0.0.1       localhost.localdomain localhost debian.localdomain debian

# The following lines are desirable for IPv6 capable hosts
# (added automatically by netbase upgrade)

::1     ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
ff02::3 ip6-allhosts
My network uses DHCP, so I won't have a static ip address, am I right?

My friend from my local university network is able to see my webserver using my ip address (She is using Firefox in Windows)

Btw, thanks for all your replies.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Konqueror works but firefox or opera doesn't! pcustance Linux - Software 14 05-25-2006 06:29 PM
konqueror works but firefox doesn't kimster Linux - Networking 15 03-13-2006 12:45 PM
Firefox - HTTPS works, but HTTP doesn't, any ideas? (Newbie question) RichardDarling Linux - Networking 2 11-03-2005 08:23 AM
Proxy works in Firefox but not in Konqueror qscomputing Linux - Networking 2 09-22-2005 12:45 AM
mplayerplug-in not recognized in Konqueror, works in Firefox public Fedora 2 02-03-2005 12:51 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 10:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration