LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 05-25-2005, 10:01 AM   #1
ovidiugm
LQ Newbie
 
Registered: May 2005
Posts: 2

Rep: Reputation: 0
How to get Debian Woody on HP w/Adaptec 2610sa RAID?


Hi all,

I unsuccessfully tried to install Debian Woody on a HP ProLiant ML110 G2.
I used David Kimdon's ďvanilla-3.0.23-mini.isoĒ boot image, but the installer couldnít recognize my storage configuration, saying that thereís no available harddrive in the system.

The server uses an Adaptec 2610sa SerialATA RAID controller, installed on a PCI-X slot. I learned that this controller is an OEM one, unsupported by Adaptec (it doesnít even appear on their lists of controllers).

There are two 80 GB Maxtor HDDs connected to it, and a mirroring partition defined.

I searched for Linux drivers on HPís site, Adaptecís site, driver CD provided, and any other place I could think of, but with no luck.
I will also try to use Debianís CD1 installer (the image is downloading right now) but I donít think itíll make a difference.

Do you have any suggestions? I saw that BSD has drivers that support a large number of controllers from Adaptec (more like a generic driver). Isnít there anything like this for Debian/Linux?

Thanks in advance for your help,
Ovidiu.
 
Old 05-25-2005, 11:31 AM   #2
m_yates
Senior Member
 
Registered: Aug 2003
Location: Upstate
Distribution: Debian, Mint, Mythbuntu
Posts: 1,248

Rep: Reputation: 79
I'd suggest the new Sarge installer: http://cdimage.debian.org/pub/cdimag...86-netinst.iso It has much better hardware support and will be Debian "stable" in a few weeks.
 
Old 05-25-2005, 05:06 PM   #3
ovidiugm
LQ Newbie
 
Registered: May 2005
Posts: 2

Original Poster
Rep: Reputation: 0
Thanks, m_yates, I'll give it a try
(unfortunately, the full-CD installer made no difference )



***** Later edit *****

I tried the Sarge installer, http://cdimage.debian.org/pub/cdimag...6-netinst.iso, as m_yates suggested, but at hardware detection I receive the error message:

Error while running 'modprobe -v aacraid'

Then, of course, no hard drive is detected

I also did a modprobe in a shell, without the -v switch, but with the same result.
If you have any other suggestions, please let me know.

Last edited by ovidiugm; 05-26-2005 at 03:29 AM.
 
Old 06-02-2005, 05:10 PM   #4
stoffell
Member
 
Registered: Apr 2003
Location: belgium
Distribution: debian
Posts: 72

Rep: Reputation: 15
You can also have a look at http://debian.catsanddogs.com/forum/ for some tips concerning Debian and HP servers..

cheers
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Adaptec SATA RAID Ab2kgj Linux - Hardware 4 11-19-2005 08:17 PM
Perc3Di SCSI RAID + Adaptec 2810SA RAID = Fatal Grub Error? LinuxOnTheEdge Linux - General 2 03-19-2005 02:35 PM
cannot use Adaptec RAID controller jobe17 Linux - Hardware 7 12-04-2004 03:55 PM
Adaptec 1210sa RAID not seen lindsayjones Red Hat 1 05-15-2004 06:20 PM
Debian Woody r1 Installer won't detect SATA RAID HDDs on SiI 3122A bluPSU Linux - Hardware 11 01-20-2004 03:36 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 06:04 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration