LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-29-2009, 06:03 PM   #1
tmick
Member
 
Registered: Jun 2005
Location: Riverdale, Utah
Distribution: Debian Jessie
Posts: 148

Rep: Reputation: 15
Question Fedora to Debian convert questions


I recently installed Debian 5 Lenny and need some useable answers about the Kernel versions. In Fedora the Kernels are i586, 686, etc and if 64 bit there is a version for that. If you have 2Gb of RAM then you use the PAE kernel.

My first question is,
If I launch Synaptic and search for kernels I get Linux-headers 2.6.26-2-686 2.26-19lenny2 Linux2.26image on PPro/Celeron/P1/PII/PIII/P4 and a bunch more to include bigmem, amd64, openvz, vserver, xen. I'm guessing the amd64, openvz, vserver, xen are for 64 bit and Virtulization. So it's the 2.6.26-2-686 2.26-19lenny2 Linux2.26image on PPro/Celeron/P1/PII/PIII/P4 if you aren't going to run anything special,right?

Question number two is:
If I want to run Virtual machines do I need a multi-core processor to do this or can I use a single core processor? If I can use an AMD Atholon 2500 single core then which Kernel version do I use?

Question number three is:
Does the Kernel that is loaded have drivers for video cards included or is that a separate install? I have a Radeon 9000 video card and it doesn't appear to working correctly. When I am in GNOME the left side of the screen is dark (almost black) and if I launch a program I have to drag the window to the center of the screen to get the display to lighten up to where I can see the window I am using.

Question number four:
In Fedora I can load debug packages by running the command debuginfo-install <package-name> is there something like that in Debian?

Question number five:
If I try to launch a Web Browser, either IceWeasel or Epiphany, it will show in the bottom bar as "starting web browser" and then it never launches. dmesg doesn't show any errors and bug-buddy never tries to send any bug reports. Is there some config file somewhere I need to tweak? If so how do I go about this?
 
Old 11-29-2009, 07:07 PM   #2
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614
1. If you have an AMD Athlon 2500, install a 686 kernel.

2. If you want to run virtual machines, it doesn't really matter how many cores you have. You just need enough CPU power and RAM to comfortably run them.

3. The kernel has basic and free (as in speech) drivers. Radeons may need attention; ask Google.

5. Not enough information. It should just work. Try starting the program from an xterm window and watch for output.
 
1 members found this post helpful.
Old 11-29-2009, 11:00 PM   #3
tmick
Member
 
Registered: Jun 2005
Location: Riverdale, Utah
Distribution: Debian Jessie
Posts: 148

Original Poster
Rep: Reputation: 15
Quote:
Originally Posted by AlucardZero View Post

2. If you want to run virtual machines, it doesn't really matter how many cores you have. You just need enough CPU power and RAM to comfortably run them.
ok so where do I find information on the openvz and vserver kernels?

Quote:

5. Not enough information. It should just work. Try starting the program from an xterm window and watch for output.
Output from Epiphany when launched from command line:
Code:
:~$ epiphany-browser
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
** Message: GetValue variable 1 (1)
** Message: GetValue variable 2 (2)
Unsupported movie property id with value "google_flash_embed"
Unsupported movie property wmode with value "opaque"
Unsupported movie property allowscriptaccess with value "never"
Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
unhandled event 19
Loading stream: http://pagead2.googlesyndication.com/pagead/imgad?id=COOO4Yb5_-6ZRRDQAhiYAjIIJtM3hSNeOEk
Unsupported movie property id with value "google_flash_embed"
Unsupported movie property wmode with value "opaque"
Unsupported movie property allowscriptaccess with value "never"
Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
unhandled event 19
Loading stream: http://pagead2.googlesyndication.com/pagead/imgad?id=CIL239z-5bKu6gEQoAEY2AQyCHR6wsEXd58K
Unsupported movie property id with value "google_flash_embed"
Unsupported movie property wmode with value "opaque"
Unsupported movie property allowscriptaccess with value "never"
Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
Loading stream: http://pagead2.googlesyndication.com/pagead/imgad?id=COOO4Yb5_-6ZRRDQAhiYAjIIJtM3hSNeOEk
unhandled event 19
Unsupported movie property id with value "google_flash_embed"
Unsupported movie property wmode with value "opaque"
Unsupported movie property allowscriptaccess with value "never"
Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
Loading stream: http://pagead2.googlesyndication.com/pagead/imgad?id=CIL239z-5bKu6gEQoAEY2AQyCHR6wsEXd58K
unhandled event 19
Unsupported movie property id with value "google_flash_embed"
Unsupported movie property wmode with value "opaque"
Unsupported movie property allowscriptaccess with value "never"
Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
Loading stream: http://pagead2.googlesyndication.com/pagead/imgad?id=COOO4Yb5_-6ZRRDQAhiYAjIIJtM3hSNeOEk
unhandled event 19
Unsupported movie property id with value "google_flash_embed"
Unsupported movie property wmode with value "opaque"
Unsupported movie property allowscriptaccess with value "never"
Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
unhandled event 19
Loading stream: http://tpc.googlesyndication.com/pagead/imgad?id=CIL239z-5bKu6gEQoAEY2AQyCHR6wsEXd58K
Unsupported movie property id with value "google_flash_embed"
Unsupported movie property wmode with value "opaque"
Unsupported movie property allowscriptaccess with value "never"
Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
Loading stream: http://pagead2.googlesyndication.com/pagead/imgad?id=COOO4Yb5_-6ZRRDQAhiYAjIIJtM3hSNeOEk
unhandled event 19
Unsupported movie property id with value "google_flash_embed"
Unsupported movie property wmode with value "opaque"
Unsupported movie property allowscriptaccess with value "never"
Unsupported movie property pluginspage with value "http://www.macromedia.com/go/getflashplayer"
unhandled event 19
Loading stream: http://pagead2.googlesyndication.com/pagead/imgad?id=CN7n24zhh9qUExCgARjYBDIISntxQT4WrJs
Note it launches from CLI, clicking on thwe browser icon in taskbar fails to launch the browser.
If it helps any I get a Nautalus error about lib-bonabo server needing restarting when GDM launches Gnome.
 
Old 11-30-2009, 06:18 AM   #4
AlucardZero
Senior Member
 
Registered: May 2006
Location: USA
Distribution: Debian
Posts: 4,824

Rep: Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614Reputation: 614
http://www.google.com/search?hl=en&s...kernel&spell=1
http://www.google.com/search?hl=en&s...kernel&spell=1
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
trying to convert over to debian... nomb Debian 29 07-10-2007 09:16 AM
Convert to fedora 6 from debian 3.1 aman1973 Fedora 2 02-05-2007 08:25 PM
Questions from a new linux convert... the doubts wedgea18 Linux - Newbie 8 02-08-2006 01:47 PM
Complete newbie who wants to convert to Fedora - questions to alleviate my fears Ebisusan Fedora - Installation 14 06-27-2005 05:43 AM
questions about linux - may convert pyrotechnik Linux - Newbie 30 01-12-2005 08:46 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 03:11 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration