LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-27-2005, 09:26 PM   #1
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Rep: Reputation: 49
Dependency error in apt-get. How to solve?


I am using the Debian Sarge version(stable repository, kernel 2.6.8-2-386). Recently I decided to install qt3 librarries so happily I did
Code:
apt-get install libqt3-mt-dev
but to my disappointment I got the following error message:
Code:
barb-xp:~# apt-get install libqt3-mt-dev
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libqt3-mt-dev: Depends: xlibs-static-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
                 Depends: libxext-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
                 Depends: libxrandr-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
                 Depends: libsm-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
                 Depends: libxmu-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
                 Depends: libice-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
                 Depends: libx11-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
                 Depends: libxt-dev (>= 4.3.0.dfsg.1-4) but it is not going to be installed
                 Depends: xlibmesa-gl-dev but it is not going to be installed or                          libgl-dev
                 Depends: xlibmesa-glu-dev but it is not going to be installed or
                          libglu1-mesa-dev but it is not going to be installed or
                          libglu-dev
                 Depends: libxft-dev but it is not going to be installed
                 Depends: libxrender-dev but it is not going to be installed
                 Depends: libxcursor-dev but it is not going to be installed
E: Broken packages
Can anybody tell me how can we solve these kind of problems? This is not the first time I am getting such kinds of error. Some time back I tried installing some other application and it did the same thing. I won;t allow me to do so.

What is the best and easiest way to solve such problems? I am addicted to apt-get and I need to know how to solve this problem.

thanks
 
Old 11-27-2005, 10:22 PM   #2
Tons of Fun
Member
 
Registered: Dec 2004
Location: Orlando, Florida
Distribution: Debian Wheezy / BackTrack 5/ Linux Mint 17
Posts: 379

Rep: Reputation: 37
That error you got is telling you that the list of dependencies are broken, so it wont install them. My suggestion is to wait until the dependencies are fixed. I am running into the same problem with Samba. A few of the dependencies are broken, so apt won't install it. I could go download the source code and compile it, but the dependancy issue might still be there, and apt won't know it is installed, so it won't update it. I know it's frustrating sometimes, but I feel it is better for me to wait.

Good Luck.

 
Old 11-28-2005, 12:36 PM   #3
kushalkoolwal
Senior Member
 
Registered: Feb 2004
Location: Middle of nowhere
Distribution: Debian Squeeze
Posts: 1,249

Original Poster
Rep: Reputation: 49
Quote:
Originally posted by Tons of Fun
That error you got is telling you that the list of dependencies are broken, so it wont install them. My suggestion is to wait until the dependencies are fixed. I am running into the same problem with Samba. A few of the dependencies are broken, so apt won't install it. I could go download the source code and compile it, but the dependancy issue might still be there, and apt won't know it is installed, so it won't update it. I know it's frustrating sometimes, but I feel it is better for me to wait.

Good Luck.


hmm. that really frustating. I am so addicted to use make xconfig and therfore I wanted to install the QT library. now I guess I will have to use not so good make menuconfig.

I thought if I use aptitude or dselect I would be able to solve the problem.. Is there any other alternative other than compiling from source.

thanks you very much.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
apt-get dependency problem (with skype) eantoranz Linux - Software 7 02-16-2006 07:26 PM
how to solve failed dependency when dependency exists dwcramer Linux - Newbie 2 08-24-2004 09:03 PM
gimp2.0/apt-get dependency weirdness edwardOG Debian 3 05-04-2004 03:07 PM
apt-get dependency problems with libqt3c102-mt smith847be Debian 1 01-01-2004 04:58 PM
apt-get Created Dependency Hell!! Shinobi Linux - Software 6 04-07-2003 11:35 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 09:40 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration