LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 11-27-2003, 07:07 PM   #1
bro
LQ Newbie
 
Registered: Aug 2003
Location: Florida
Distribution: Debian Sarge
Posts: 10

Rep: Reputation: 0
configuring local domains on sarge


Hi folks,

I've been using linux for a long long time, but never got deep
into the networking config stuff -- mine just happened to work...
So... now I've got a problem.

I just installed sarge from Knoppix and everything went beautifully!
(Knoppix is really a cool thing!!)

*Except* .... I'm missing something about configuring my local domain
to have virtual hosts..

I used to have a bunch of local domain names (*.vnet) assigned to
192.168.1.n (under RH7.1)
But now they don't respond to ping,
and Apache says "connection refused".
(that's what I use them for: local virtual hosts on the web server).

I've got the names and numbers in /etc/hosts
'ns' shows the names are mapped to ip numbers,
"ip route list" says 192.168.1.0/24 is recognized,
and when I ping the domain names they map to numbers,
but they do not respond.

ifconfig shows only my VPN on .97 and default route
is .254 (dsl modem).
netstat says I'm listening for www on 192.168.1.0
but that number replies "refused" too.. (well, it's not in httpd.conf, so that's ok)
but even localhost and 127.0.0.1 only responds partially!!
(was working at one point, but now for example it shows one frame, and not the other
and refuses to reload!! )

Everything else seems to work just fine!

I've googled my butt off -- to no avail,
(and man ifconfig confuses the hell out of me)
Can someone help?
or at least point me to a newbie HOWTO for this?

Thanks a million in advance.

John
 
Old 11-28-2003, 10:23 PM   #2
bro
LQ Newbie
 
Registered: Aug 2003
Location: Florida
Distribution: Debian Sarge
Posts: 10

Original Poster
Rep: Reputation: 0
geez... doesn't anybody else do this?

I have learned in the mean time about /etc/network/interfaces
but still don't know how to configure it so that
my adsl connection, vpn tunnel and local domains
can all be handled through a single ethernet card.

When I have tried iface ... static,
I lose my dhcp/vpn.

Can I make a bogus eth1 aliased to eth0 ?
I'm afraid LinuxQuestions.org has spoiled me.
I've asked 2 questions before and gotten instant quality responses!
Can somebody set me straight here?

thanks

j.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to spoof multipule domains on local server? Rundi Linux - Networking 1 07-08-2005 05:54 PM
Problem when configuring apt after installing sarge tomj88 Debian 3 06-08-2005 02:25 PM
Trying to add local printer in sarge jolphil Debian 11 03-11-2005 01:58 PM
? Configuring GRUB on Debian/sarge to boot Knoppix from HDD? killerwh Debian 4 10-14-2004 09:38 AM
Need help configuring virtual domains on home network CRUZN8R Linux - Networking 4 04-14-2003 12:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:17 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration