LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 03-16-2020, 05:58 PM   #1
Shreda
LQ Newbie
 
Registered: Mar 2020
Posts: 7

Rep: Reputation: Disabled
Cannot set up a "bootable flag" for a new fourth disk when installing Debian Buster 10.3


Hi,

I've got a desktop with 3 disks. On the 1st disk there is Win 7 (with a bootable flag). NTFS
On the 2nd disk there is Debian Stretch (/ and /home) (with a bootable flag). EXT4
On the 3rd disk there are data. EXT4
I want to keep data on all disks and install Debian Buster on a fourth disk.
I reformated SWAP on the 2nd disk and renamed / and /home.
I put the the bootable flag on the 2nd disk to "off."

On the 4th disk (6TB) on which I want to have / and /home I'm trying to install
Debian Buster 10.3

But Debian Installation does not allow me to set up the bootable flag on it.

Why?

What should I do? Disconnect the 2nd and 3rd disks, install the Debian Buster on the 4th
and then reconnect them again? Will they clash (the 2nd disk will still have / on it)?
Will the installer allow me to put the Bootable Flag on the 4th disk when the 2nd disk is
disconnected?

Thanks,

Shreda.
 
Old 03-16-2020, 06:23 PM   #2
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 18,999

Rep: Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288
The boot flag is a Windows anachronism from a century long past. It is irrelevant to (and ignored by) Linux boot-loaders.
Some (very) old BIOS used to require it, but the flag on the Win7 partition will satisfy that. There is no need for a boot flag at all on the other disks. It only leads to the confusion you are experiencing. If the Debian installer insists on it raise a bug against Debain. Else simply ignore it.
 
Old 03-16-2020, 06:34 PM   #3
ehartman
Senior Member
 
Registered: Jul 2007
Location: Delft, The Netherlands
Distribution: Slackware
Posts: 1,674

Rep: Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872Reputation: 872
Quote:
Originally Posted by Shreda View Post
But Debian Installation does not allow me to set up the bootable flag on it.

Why?
Why would you want to?
Linux does NOT use the bootable flag at all, it is the bootloader (probably grub) that decides which partitions can be booted from.
So when you add that partition on your 4th disk to the bootloader table, you can boot from it (as one of the alternatives).
For instance: on my old Dell the Windows partition (#1) is marked as bootable, because Windows needs that, but the system normally boots from the Linux partition, which is #4 (and the bootloader has Windows as one of the options).

PS: the system came with Windows installed, but I shrank its partition, added an extended partition, a swap one and the Linux root one, so that's why the rather strange order of the partions:
1 - W95 FAT32 (LBA) boot flag
2 - W95 Ext'd (LBA)
3 - Linux swap
4 - Linux (root)
5 - W95 FAT32 (LBA) # shared between Windows and Linux
6 - Linux
7 - Linux
in which 5 thru 7, of course, are in the extended partition.
 
Old 03-16-2020, 07:58 PM   #4
Shreda
LQ Newbie
 
Registered: Mar 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
It seems that the disk is faulty (although it's a brand new WD Black 6TB).

Bootable flag can be put on and off for any partition of any other disks except for that one.

But even ignoring the Bootable Flag issue I get the following errors after partitioning the 4th disk:

Either "Error fsyncing/closing /dev/sdd. Input/output error." or "Error opening /dev/sdd. No such file or directory. ERROR."

When I click "Ignore" I get:

"The creation of swap space in partition #3 of /dev/sdd failed."

I suppose I should ask for a new disk.
 
Old 03-16-2020, 08:08 PM   #5
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,951

Rep: Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146
There can only be one.. from what I know
 
Old 03-16-2020, 08:22 PM   #6
Shreda
LQ Newbie
 
Registered: Mar 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
Only one Immortal can claim a new disk by being the last one to receive a Quickening? :-)
 
Old 03-16-2020, 08:29 PM   #7
BW-userx
LQ Guru
 
Registered: Sep 2013
Location: Somewhere in my head.
Distribution: Slackware (current), FreeBSD, Win10, It varies
Posts: 9,951

Rep: Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146Reputation: 2146
Quote:
Originally Posted by Shreda View Post
Only one Immortal can claim a new disk by being the last one to receive a Quickening? :-)
some one got that ... lmao...
 
Old 03-20-2020, 10:11 PM   #8
Shreda
LQ Newbie
 
Registered: Mar 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
As a service to the community, I would like to close this tread with its resolution.

Astoundingly, one cannot install Debian on a any disk larger than 2TB straight away,
in 2020, almost 10 years after they appeared in the market and that is the reason
why the "bootable flag" didn't work. Details are as follows.
Fdisk which handles the installation of Debian Buster 10.3 (released on Feb 8, 2020!!!)
doesn't see more than 2TB of a 6TB (or 4, or 8, ...) disk. So, even when you choose
/ and /home to be within 2TB you cannot put swap at the end of the disk.

The only option to install Debian on larger disks is to first partion them via "parted,"
so as to slice it to a 2TB part and the rest of it, on another computer or via Knoppix
and only then carry out the installation. Supposedly, you can also put / /home and swap
in the first 2TB via fdisk and carry out further partitioning via "parted" after
completing the installation. I carried out the 1st approach. (I suppose the 2nd approach
would work too). In doing so I had no problem with setting the "bootable flag" to on.

Taken together, it is really flabbergasting that the Debian creators did not set up a
procedure which would enable users to use large disks (e.g., via "parted") and to enable
putting / and /home on a partions larger than 2TB and putting swap at the end of a disk
and it is even more flabbergasting that, after deciding not to do so, they didn't at
least build in some indication of the problem in the fdisk.

On the other hand, it is equally amazing that the store accepted my complaint based on
the fdisk error message above ("Error fsyncing/closing /dev/sdd. Input/output error.")
and gave me a new disk. (They obviously were not informed of the problem, either.)
 
Old 03-20-2020, 10:49 PM   #9
syg00
LQ Veteran
 
Registered: Aug 2003
Location: Australia
Distribution: Lots ...
Posts: 18,999

Rep: Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288Reputation: 3288
Hmmm - that sounds like a MBR vs. gpt issue. fdisk was re-written quite some time back to handle gpt disk. I have never used Debian, but I'd be surprised if this wouldn't work for a gpt formatted disk.
 
Old 03-21-2020, 07:01 AM   #10
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 4,533

Rep: Reputation: 807Reputation: 807Reputation: 807Reputation: 807Reputation: 807Reputation: 807Reputation: 807
My guess is the orignal 6tb disk was set as a gpt type disk, henceforth the cause or your original problem of not able to set the boot flag.
Systems that came with Windows 7 boot in legacy mode and have a msdos type disk. A 6tb type msdos disk can't use the disk past the 2tb,but should able to set boot flag.
A gpt type disk used mostly on efi systems can access the whole 6tb disk. For grub to install on gpt in legacy mode need a 1MB-2MB partition flagged as bios-boot. Some legacy bios won't boot a gpt disk unless it has a hybrid protective mbr.
https://wiki.gentoo.org/wiki/Hybrid_partition_table

The problem with the gpt hybrid mbr is later on if you try to use it on an efi machine it may not boot unless you redo the gpt protective mbr.

Last edited by colorpurple21859; 03-21-2020 at 07:12 AM.
 
Old 03-21-2020, 10:08 AM   #11
Shreda
LQ Newbie
 
Registered: Mar 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
"My guess is the orignal 6tb disk was set as a gpt type disk"

No, it came as "raw." Not even "FREE SPACE."
 
Old 03-21-2020, 01:09 PM   #12
Shreda
LQ Newbie
 
Registered: Mar 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
To be more precise, fdisk first initializes the 6TB disk so as to implement 6TB of FREE SPACE.
Then fdisk tries to partition it as follows: / 200GB (beginning), swap 32GB (end), /home 3TB, /srv 2.768TB,
or some variant of it. I've tried a number of them.
However, fdisk cannot write anything of the kind to the disk (input/output error).
I've also tried the same on another PC and via Knoppix on both of them. The same no-go.
 
Old 03-21-2020, 02:32 PM   #13
yancek
LQ Guru
 
Registered: Apr 2008
Distribution: PCLinux, Slackware
Posts: 9,062

Rep: Reputation: 1939Reputation: 1939Reputation: 1939Reputation: 1939Reputation: 1939Reputation: 1939Reputation: 1939Reputation: 1939Reputation: 1939Reputation: 1939Reputation: 1939
If you run fdisk -l and see the output: Disklabel type: dos all you can use is 2TB
If it shows Disklabel type: gpt you can use the entire drive which is what you were told in post #10.
 
Old 03-21-2020, 02:38 PM   #14
colorpurple21859
Senior Member
 
Registered: Jan 2008
Location: florida panhandle
Distribution: slackware64-current, fedora,Xubuntu, others
Posts: 4,533

Rep: Reputation: 807Reputation: 807Reputation: 807Reputation: 807Reputation: 807Reputation: 807Reputation: 807
what happens if you use gdisk/cgdisk instead of fdisk/cfdisk?
 
Old 03-21-2020, 06:55 PM   #15
Shreda
LQ Newbie
 
Registered: Mar 2020
Posts: 7

Original Poster
Rep: Reputation: Disabled
As for the disklabel type at the beginning, I don't think it appeared at all, since my first step was to set the type to gpt

# parted /dev/sda

(parted) print
Error: /dev/sda: unrecognised disk label

(parted) mklabel gpt


As for "what happens if you use gdisk/cgdisk" I cannot tell because I didn't try that, but the Debian Installer does not make use of gdisk, anyhow.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] After having a successful installation of Debian Buster, Lenovo computer refuses to boot into Debian Buster 10.2 PicardDefendingData Debian 4 12-21-2019 07:51 PM
I cannot set a quota on Debian Buster. usernameatdomain Linux - General 4 08-28-2019 02:51 PM
[SOLVED] Gparted - to "flag" or NOT to "flag" as "raid" ? helen314 Linux - Newbie 3 06-28-2019 03:02 PM
LXer: Debian 11 "Bullseye" and Debian 12 "Bookworm" Are Coming After Debian 10 "Buster" LXer Syndicated Linux News 0 04-18-2018 12:26 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 12:46 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration