LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian
User Name
Password
Debian This forum is for the discussion of Debian Linux.

Notices


Reply
  Search this Thread
Old 08-28-2003, 11:23 AM   #1
TippExed
LQ Newbie
 
Registered: Sep 2002
Location: Glasgow
Distribution: Debian (Knoppix)
Posts: 20

Rep: Reputation: 0
A wee bit slow


Hi,

Has anyone else experienced slow access to disks in debian? I installed a second knoppix 3.2 installation and updated it to sid, but ever since disk access has been a tad slower and it causes the KDE gui to slow down and become jittery. This only happens with data above 20meg, but that never really hurt before... the console might become unresponsive for the duration of the copy, etc, but the gui wasn't that affected. Even at 20 it's only for a sec or two, but it gets worse with size. Maybe I just never noticed it before?

I haven't used the experimental branch of debian before, and just want to know if it's normal or there's something to speed it up a wee bitty.

Also after the upgrade the root partition doesn't mount as read only for an fsck at the start of boot. This is no bother, I only mention it in case it's related...



Chris
 
Old 08-28-2003, 11:40 AM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
What are your hdparm settings/timings?
Code:
Thu Aug 28 12:39pm root@uilleann ~ # hdparm /dev/hda

/dev/hda:
 multcount    = 16 (on)
 I/O support  =  0 (default 16-bit)
 unmaskirq    =  0 (off)
 using_dma    =  1 (on)
 keepsettings =  0 (off)
 nowerr       =  0 (off)
 readonly     =  0 (off)
 readahead    =  8 (on)
 geometry     = 4865/255/63, sectors = 78165360, start = 0
 busstate     =  1 (on)
Thu Aug 28 12:39pm root@uilleann ~ # hdparm -Tt /dev/hd{a,a,a}

/dev/hda:
 Timing buffer-cache reads:   128 MB in  1.08 seconds =118.52 MB/sec
 Timing buffered disk reads:  64 MB in  1.45 seconds = 44.14 MB/sec

/dev/hda:
 Timing buffer-cache reads:   128 MB in  1.08 seconds =118.52 MB/sec
 Timing buffered disk reads:  64 MB in  1.46 seconds = 43.84 MB/sec

/dev/hda:
 Timing buffer-cache reads:   128 MB in  1.07 seconds =119.63 MB/sec
 Timing buffered disk reads:  64 MB in  1.46 seconds = 43.84 MB/sec
Thu Aug 28 12:40pm root@uilleann ~ #
 
Old 08-30-2003, 12:44 PM   #3
TippExed
LQ Newbie
 
Registered: Sep 2002
Location: Glasgow
Distribution: Debian (Knoppix)
Posts: 20

Original Poster
Rep: Reputation: 0
Hi,

They are

root@arwen:/home/faramir# hdparm /dev/hdd

/dev/hdd:
multcount = 16 (on)
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 0 (off)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 155061/16/63, sectors = 156301488, start = 0
root@arwen:/home/faramir# hdparm -Tt /dev/hd{d,d,d}

/dev/hdd:
Timing buffer-cache reads: 1056 MB in 2.00 seconds = 528.00 MB/sec
Timing buffered disk reads: 22 MB in 3.10 seconds = 7.10 MB/sec

/dev/hdd:
Timing buffer-cache reads: 1044 MB in 2.00 seconds = 522.00 MB/sec
Timing buffered disk reads: 22 MB in 3.01 seconds = 7.31 MB/sec

/dev/hdd:
Timing buffer-cache reads: 1044 MB in 2.00 seconds = 522.00 MB/sec
Timing buffered disk reads: 22 MB in 3.03 seconds = 7.26 MB/sec
root@arwen:/home/faramir#


Is it the DMA then? How can you turn DMA on?


Cheers,
Chris

Last edited by TippExed; 08-30-2003 at 12:45 PM.
 
Old 08-30-2003, 01:01 PM   #4
TippExed
LQ Newbie
 
Registered: Sep 2002
Location: Glasgow
Distribution: Debian (Knoppix)
Posts: 20

Original Poster
Rep: Reputation: 0
Yeah it's the DMA. The other hd install has timings and results similar to the ones fancypiper gave.

root@willow:/home/danx# hdparm /dev/hdd

/dev/hdd:
multcount = 16 (on)
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 8 (on)
geometry = 155061/16/63, sectors = 156301488, start = 0
root@willow:/home/danx# hdparm -Tt /dev/hd{d,d,d}

/dev/hdd:
Timing buffer-cache reads: 128 MB in 0.51 seconds =250.98 MB/sec
Timing buffered disk reads: 64 MB in 1.39 seconds = 46.04 MB/sec

/dev/hdd:
Timing buffer-cache reads: 128 MB in 0.51 seconds =250.98 MB/sec
Timing buffered disk reads: 64 MB in 1.38 seconds = 46.38 MB/sec

/dev/hdd:
Timing buffer-cache reads: 128 MB in 0.51 seconds =250.98 MB/sec
Timing buffered disk reads: 64 MB in 1.39 seconds = 46.04 MB/sec
root@willow:/home/danx#

Last edited by TippExed; 08-30-2003 at 01:02 PM.
 
Old 08-30-2003, 01:03 PM   #5
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Is the file /etc/rc.d/rc.local on your system? If so, try these settings out and check the timings after changing each one.

hdparm -d1 -u1 -m16 -c3 /dev/hdd

If that drive is a slave to a CDROM, it will be slower than if on an IDE cable with only hard drives attached.

See this article:

# Hard drive tweak
Speeding up Linux Using hdparm
Not mentioned in the article but could possibly freeze the box:
UDMA 33/66/100. Add the -X option, and then this number i.e. (-X 69)
-X 33 ====> Multiword DMA
-X 66 ====> ATA-33 (UDMA2)
-X 68 ====> ATA-66 (UDMA4)
-X 69 ====> ATA-100 (UDMA 5)

I can't tell any difference with the X settings, myself.
 
Old 08-30-2003, 04:05 PM   #6
HappyTux
Senior Member
 
Registered: Mar 2003
Location: Nova Scotia, Canada
Distribution: Debian AMD64
Posts: 3,634

Rep: Reputation: 109Reputation: 109
On your Knoppix install edit the file /etc/init.d/bootmisc.sh and uncomment the hdparm line that should already be at the bottom of the file. BTW if you had booted Knoppix with the dma cheat code before you installed it would have been turned on by default you may also want to use the line suggested above instead of just the hdparm -qd1 /dev/hdd that will be there.
 
Old 08-31-2003, 04:45 PM   #7
TippExed
LQ Newbie
 
Registered: Sep 2002
Location: Glasgow
Distribution: Debian (Knoppix)
Posts: 20

Original Poster
Rep: Reputation: 0
Hi,

Cheers guys. I reinstalled debian sid and watched what it did. It replaces /etc/init.d/bootmisc.sh which is where Knoppix calls hdparm to set dma. Copying the two lines from a backup to the end of the file fixed it.



Cheers,
Chris
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
et is a bit slow.. munkie_poo Linux - Games 3 05-05-2005 09:27 PM
I'm having but a wee WINE problem. Wassman Linux - Software 1 02-29-2004 09:25 PM
wee bit laggish php_rocks Slackware 4 07-02-2003 09:33 AM
RedHat 7.3 is just a bit too slow isolationist Linux - Software 3 04-17-2003 08:47 PM
mozilla (bit slow) skeletal29 Linux - General 4 05-06-2002 02:33 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Debian

All times are GMT -5. The time now is 03:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration