LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi
User Name
Password
Bodhi This forum is for the discussion of Bodhi Linux.

Notices


Reply
  Search this Thread
Old 04-04-2019, 05:36 AM   #1
RonCam
Member
 
Registered: Dec 2008
Posts: 111

Rep: Reputation: 47
Question Daylight saving time hour change not working


All of my other 'devices' seem to have registered the time shift correctly, but Bodhi remains on 'winter time'. Is my Bodhi 5.0 installation lacking something, that might fix this?

I'm trying to make the change manually, but can't find where to increment the hour setting. I'm seeing all sorts of other options (changing the day the week begins, date and time formatting options, and so forth) but nothing about the option to change the time itself.

Help!

Last edited by RonCam; 04-04-2019 at 05:38 AM.
 
Old 04-04-2019, 05:51 AM   #2
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 387

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
sudo apt install ntp
 
2 members found this post helpful.
Old 04-04-2019, 05:54 AM   #3
Guttorm
Senior Member
 
Registered: Dec 2003
Location: Trondheim, Norway
Distribution: Debian and Ubuntu
Posts: 1,328

Rep: Reputation: 361Reputation: 361Reputation: 361Reputation: 361
Hi

I don't know about Bodhi, but in general you should check what timezone the computer is in. It's in the file /etc/timezone

I've done the mistake of setting it to CET or GMT+1, which is incorrect in the summer time.

https://www.wikihow.com/Change-the-Timezone-in-Linux
 
2 members found this post helpful.
Old 04-04-2019, 06:23 AM   #4
RonCam
Member
 
Registered: Dec 2008
Posts: 111

Original Poster
Rep: Reputation: 47
Possible to manually set date and time, from within Moksha?

Quote:
Originally Posted by the_waiter View Post
sudo apt install ntp
Quote:
Originally Posted by Guttorm View Post
... in general you should check what timezone the computer is in. It's in the file /etc/timezone
https://www.wikihow.com/Change-the-Timezone-in-Linux
Thanks to both for the rapid reply! I think I should do both.


On the other part of my question, is there somewhere in Moksha where one may make a manual time adjustment?

For example, I'm in KDE right now and when I right-click the time display, a box pops up with the option Adjust Date and Time ...

I was looking for something similar in Moksha, but couldn't find it. Maybe I'm lacking a special Module? Any advice?

Last edited by RonCam; 04-04-2019 at 06:26 AM. Reason: Adding a title
 
1 members found this post helpful.
Old 04-04-2019, 06:33 AM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 18,348

Rep: Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604
I don't know Bodhi either but while ntp keeps the system clock synced to UTC it is the timezone setting that converts UTC to local time and the timezone database for your timezone that contains the dates that switch between standard/winter and daylight saving/summer time.

Either your timezone is not set correctly or the database is not correct. You can always use the command line date utility to set the system clock and hwclock to set the hardware clock.

Last edited by michaelk; 04-04-2019 at 06:36 AM.
 
2 members found this post helpful.
Old 04-04-2019, 06:45 AM   #6
hazel
Senior Member
 
Registered: Mar 2016
Location: Harrow, UK
Distribution: LFS, AntiX, Slackware
Posts: 2,786
Blog Entries: 7

Rep: Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445Reputation: 1445
Oddly enough that happened to me in my recently installed Slackware. When I noticed that the clock had not gone forward, I used hwclock --debug --show to find out what time the hardware clock was actually showing. This showed that the clock was correct (it was set to UTC) but that the system had not made the summertime correction and was still showing exactly the same time as the clock. That meant it was a time zone error.

I checked /etc/localtime. It turned out to be a link to GMT (Greenwich Mean Time) instead of to London. Obviously a careless mistake during installation. We all make them!
 
2 members found this post helpful.
Old 04-04-2019, 06:58 AM   #7
michaelk
Moderator
 
Registered: Aug 2002
Posts: 18,348

Rep: Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604Reputation: 2604
In addition awhile back a member's country had changed the dates but appeared not have sent the changes to IANA which maintains the timezone database.
 
1 members found this post helpful.
Old 04-04-2019, 07:01 AM   #8
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.0
Posts: 247

Rep: Reputation: 47
Quote:
Originally Posted by RonCam View Post
On the other part of my question, is there somewhere in Moksha where one may make a manual time adjustment?
in my bodhi 5 64-bit apppack install i found it under settings -> system -> time and date. i am still poking around in 32-bit, but haven't found it yet.
 
1 members found this post helpful.
Old 04-04-2019, 07:05 AM   #9
RonCam
Member
 
Registered: Dec 2008
Posts: 111

Original Poster
Rep: Reputation: 47
Thanks to hazel, michaelk, Guttorm and the waiter, I now have several things to check and info on how to troubleshoot this.

Unless I hear otherwise, I'll assume Moksha doesn't have a facility similar to the one I described, that KDE (and other desktop environments) have? I thought, it must be there, but hidden away in some unexpected location?
 
1 members found this post helpful.
Old 04-04-2019, 07:16 AM   #10
RonCam
Member
 
Registered: Dec 2008
Posts: 111

Original Poster
Rep: Reputation: 47
Quote:
Originally Posted by cordx View Post
in my bodhi 5 64-bit apppack install i found it under settings -> system -> time and date. i am still poking around in 32-bit, but haven't found it yet.
Thanks for jumping into the thread while I was replying to the earlier responders!

I have 32-bit, and in the Main Menu, there is no 'System' submenu entry under 'Settings'.

Am I correct, the AppPack release is 64-bit only, so I do not have the option of installing that. Could whatever it has to give that extra menu selection be installed, by me, into the 32-bit Legacy release?

Last edited by RonCam; 04-04-2019 at 07:36 AM.
 
1 members found this post helpful.
Old 04-04-2019, 07:50 AM   #11
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.0
Posts: 247

Rep: Reputation: 47
Quote:
Originally Posted by RonCam View Post
Thanks for jumping into the thread while I was replying to the earlier responders!

I have 32-bit, and in the Main Menu, there is no 'System' submenu entry under 'Settings'.

Am I correct, the AppPack release is 64-bit only, so I do not have the option of installing that. Could whatever it has to give that extra menu selection be installed, by me, into the 32-bit Legacy release?
in my 32-bit i have a System submenu when i open the settings panel to full screen. with my screen resolution, the last submenu at the top right is "Extensions". after i click on that, there is a small arrow just above and to the right of the word Extensions. pressing that twice moves over past the Preferences submenu and lands in the System submenu. there is no date and time there in mine however.

in the thread linked below

https://www.linuxquestions.org/quest...lp-4175646697/

bobl01 has as part of his script installing the apppack with the following command:

Code:
sudo apt install bodhi-apppack
i have not tried that on my 32-bit system as i don't use it for much that would require that specific install; therefore, i don't know if it would help with the time and date issue. just saying it might be possible to install the apppack from what i have read
 
1 members found this post helpful.
Old 04-04-2019, 08:05 AM   #12
RonCam
Member
 
Registered: Dec 2008
Posts: 111

Original Poster
Rep: Reputation: 47
Many thanks to cordx for the detective work. I'll back-up the system first, then give it a try. Then, revert the system if I see no advantages from the apppack installation. And, I thought that AppPack was just one of the releases ... my mistake!
 
1 members found this post helpful.
Old 04-04-2019, 08:41 AM   #13
RonCam
Member
 
Registered: Dec 2008
Posts: 111

Original Poster
Rep: Reputation: 47
I have looked at exactly what the AppPack contains and I don't see anything that leads me to believe it would add time and date settings to the Menu ...
 
1 members found this post helpful.
Old 04-04-2019, 09:36 AM   #14
the_waiter
Bodhi Developer
 
Registered: Jun 2018
Location: Banská Bystrica, Slovakia
Distribution: Bodhi Linux
Posts: 387

Rep: Reputation: 348Reputation: 348Reputation: 348Reputation: 348
You should find the System-Settings under Menu-Applications-System tool and open the quick launcher and start typing Swami.

https://i.imgur.com/FP1RwJM.jpg

Here is the dialog with time settings.
 
2 members found this post helpful.
Old 04-04-2019, 04:16 PM   #15
cordx
Member
 
Registered: Oct 2018
Location: texas
Distribution: bodhi 5.0
Posts: 247

Rep: Reputation: 47
i forget swami for everything other than adding a script to autostart anymore. it seems like it would be helpful to have that either in the system tools or somewhere in the settings panel.
 
  


Reply

Tags
settings, time


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Zorin OS 12: change 24 hour time to 12 hour time display ghoracek Zorin OS 4 01-23-2019 06:42 PM
How do I adjust the time of my system with daylight saving time in effect? awmian Linux - Newbie 3 09-04-2008 08:57 AM
Doub about `net time set` and daylight saving time Thakowbbery Linux - Software 0 10-17-2005 05:23 AM
DO NOT use Daylight Saving Time - how? EcceVery Debian 4 05-28-2005 02:21 PM
change clock from 24 hour to 12 hour in suse 9.2/KDE 3.3 jmlumpkin Linux - Newbie 1 01-22-2005 11:45 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Bodhi

All times are GMT -5. The time now is 05:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration