LinuxQuestions.org
Register a domain and help support LQ
Go Back   LinuxQuestions.org > Blogs > tp11235
User Name
Password

Notices

Rate this Entry

Creating my Gentoo System

Posted 08-22-2006 at 06:01 AM by tp11235

I used to have SuSE system that I was very happy with - it was a lot faster and more reliable as a webserver than Windows. However, there was a lot of stuff on there that my old PC (P3-450) could not use and was probably slowing it down.

I tried to use the LiveCD install disk from Gentoo, it booted but assumed my Voodoo3 graphics card was Voodoo4 and tried to drive my monitor at 75Hz. The poor old monitor kept resetting and I cannot afford a new one yet. I know that I shall be able to configure the final system for Voodoo3 during installation, but not for the LiveCD itself. I also wanted to learn more about how Linux is put together and the LiveCD does a lot of work for you.

Instead I downloaded and burnt a minimal install CD for the x86 / 2006.0 version of Gentoo. This was very quick and easy.

When I booted it I got some confusing errors that seemed to be related to the old (trashed) SuSE installation. So I used FDISK to delete the existing partitions (I used an old W98 disk to do this - sorry).

Then the Gentoo disk booted cleanly and gave me a simple command line interface that does not stress the monitor.
Posted in Uncategorized
Views 1522 Comments 12
« Prev     Main     Next »
Total Comments 12

Comments

  1. Old Comment
    The thing about using the minimal install CD is that you need to get the sources from the internet.

    Before booting the CD I made sure that my router was using DHCP to set ip addresses and DNS addresses. I do nto usually use it this way for the server, but it makes life easier at installation.

    Once I had the command prompt I ran /sbin/ifconfig exactly as the documentation said. This told me that my network was set up and working OK already (no effort at all). I pinged the BBC website www.bbc.co.uk and that worked too.

    The advantage of using the minimal install CD is that this seems to be the method assumed in the documention and what you see on the screen conforms to the documentation.

    http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=1&chap=3

    My network was working so I moved on to chapter 4 to set up the disks.

    Again - nice and easy - just do exactly what the docs say: it works!!

    I accepted the recommended layout for my system - no reason not to.

    Then, I followed through the documentation for creating the filesystems and mounting them. Again, no problems.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  2. Old Comment
    I was initially unclear on what bits of software constituted Gentoo. Thinking about this helps a bit.

    There are three elements: The Stage (I used stage 3), The Portage Snapshot and The Kernel. You will need to download all three. The LiveCD has them, but I could not use it and I strongly recommend hooking up to the internet and having the system download what it needs as you go along.

    Choose you mirror with care, the default (in Georgia) offered me 20Kb/s - my local (English) one provided 120Kb/s.

    Again the docs were good - just work through step by step.

    Getting the hang of links is a good idea: very easy and useful.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  3. Old Comment
    This took me a while and I have yet to see if it works. I want a fairly spartan server - just the LAMP elements plus KDE. No multimedia stuff (my P3 will not handle them well enough). I read the details of all the USE options online and compiled a list of what I wanted. http://www.gentoo.org/dyn/use-index.xml

    Then I checked the defaults and edited my list to exclude defaults I did not want and deleted items on my list that were in the default list.

    I then used nano to edit the make.conf file and include a USE variable. Mine is:

    USE="3dfx -alsa -arts -eds -emboss -encode -esd bzip2 -cdr clamav firefox ftp gcj -gnome gphoto2 -gstreamer hardened
    hardenedphp imap innodb ipv6 java javascript ldap -mad -mikmod -mp3 -mpeg milter mime mysql mysqli -oss pdf perl php postgres
    ppds -spell spl samba scanner slp sockets ssl tiff -vorbis voodoo3 xml -xmms -xv zlib"

    We shall see later if it works.

    I could not get locale-gen to work - it does not seem to be inplace yet. It is optional so probably not an issue. I'll try again when I have the system up and running. Maybe the command will be in place then. Maybe I will need to upgrade GCC for it to work.

    I downloaded the gentoo kernel in the hope of performance improvements. I am configuring it now. The main changes from the defaults are to exclude sound card related stuff - I do not need it. I do need USB storage support for my external hard disk that I use as a backup device. That needs bothe SCSI legacy support and USB support.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  4. Old Comment
    I followed the docs to the letter and no problem with the OS at run level 3. I did get a problem of my own making: I have still not got the console keyboard right. It works fine in Nano - but has no # key in console. This was a problem because my root password as set had a # in it. So no log on on first boot.

    I went back, booted the CD again, mounted the temporary directories like mnt/gentoo etc., chrooted to the real system and reset root to a straightforward word.

    This worked.

    Now it is spending hours setting up Xorg.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  5. Old Comment
    Well, it all worked well as far getting the base linux system in. I followed the docs and they worked.

    However, it all went wrong when I tried to get Xorg-X11 up and running. It took nearly 18 hours to emerge it!! My P3-450 was showing its age. Then it did not work. It would not bind to a socket (maybe an issue, maybe not since I will not be serving other machines. More improtantly it would ne drive my Voodoo3 card. I had selected Voodoo3 support and 3dfx as USE variables and enabled the framebuffer support and specific 3dfx support in the kernel. It was looking for a driver module called tdfx - but the driver was built in. It was also called tdfxfb. I tried telling it the new name - no good. I gave it the full path to the file, but it came back with "Unexpected object in driver file".

    I recompiled the kernel with the driver as a module because that is what Xorg wanted - still no good.

    I have given up for the moment. I shall try XFREE86 instead. In the meantime I need to install Apache and get my webserver back on line before term starts.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  6. Old Comment
    I ran emerge apache.
    I changed the path in the config file to point to my web documents on the disk.
    It worked.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  7. Old Comment
    I think SSHD was already on the system, emerge is so easy I have forgotten if I used it.

    Anyway, no configuration changes required at all.

    I ran ./sshd start from /etc/init.d and waited a while for it to generate the keys.

    Then it was working. I put it in the rc default and it is up and running.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  8. Old Comment
    This was a little more confusing. I found lots of references to ftp in Portage so I did emerge ftp and got a package. However, it is the ftp client not the server daemon.

    I am a fan of Pure-FTP so I tried emerge -p pure-ftpd and bingo - it was there. It is installing itself now.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  9. Old Comment
    Long gap from last post. Many hours of heart-ache over X-Windows. I could not get the Xorg-X11 opensource X Server to work with my ageing Voodoo3 card. I think it is suppose dot, but I also found a lot of grief on the web from people unable to get it to work.

    In the end I unmerged Xorg-X11 and manually installed Xfree86 (Sorry!)

    This was not as difficult as I expected. I downloaded the sources and unzipped them into the X11R6 directory I had created in /usr.

    make World, then make install and make install.man was all it took to get it in place.

    I ran X -autoconfig to set it up. This was a great contrast to Xorg-X11 which would go nowhere near autoconfig without errors with my card.

    I ran startx and it was working - honest!!

    It took me a while to figure out how to set up an .xinitrc file in my home directory to control the X server. I have a good book on Linux and it had the basics.

    This included Ctrl-Alt-BackSpace as the xit command from the basic server screen of fine black and white lines that looks like a crash!

    This is the final version:

    #!/bin/sh
    # Sample .xinitrc shell script

    # Start xterms
    #xterm -geometry 80x40+10+100 -fg black -bg white &
    #xterm -geometry -20+10 -fn 7x13bold -fg darkslategray -bg white &
    #xterm -geometry -20-30 -fn 7x13bold -fg black -bg white &

    # Other useful X clients
    #oclock -geometry 70x70+5+5 &
    #xload -geometry 85x60+85+5 &
    #xbiff -geometry +200+5 &
    #xsetroot -solid darkslateblue &

    # Start the window manager
    #exec twm
    #exec kwin
    # Start KDE
    exec startkde

    I started with the Xterms uncommented and the X clients likewise. I used twm as a window manager.

    The I re ran startx and it ran with the modifications.

    I then wanted to get KDE running so I returned to Gentoo and ran emerge kde. This ended with an error about qt. However, it still worked.

    I may try and install KDE 3.5.4 rather than the 3.5.2 that Gentoo supplies to ensure that I am controlling all parts of the graphics setup.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  10. Old Comment
    I cannot make the FTP server work right. It used to but I did something and now it won't.

    It is fine from Localhost, but not remotely.

    I have recently installed PAM and ClamAV. The Gentoo Forum came up with the idea that it must be firewall related.

    Gentoo has no hosts.allow file as far as I can see so I don't know where to look.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  11. Old Comment
    I found that the problem was caused by the daemon not accepting my hostname as a parameter for the $SERVER instruction in ftpd.conf file. I think this is related to another problem I got.

    The other problem was a sudden refusal to get external internet access. I discovered that when I was playing around with kde and tried some network configuration from a kde tool it put a couple of lines at the bottom of the "net" file in /etc/conf.d that were deleting the name server lines from etc/resolv.conf!!

    Anyway all working now.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
  12. Old Comment
    The final task was to get the APC UPS going. I bought an APC UPS - Back-UPS CS 500 off e-bay. This came with a USB cable so and I was fairly confident that it would work with Linux.

    There is an excellent HOW-TO on the Gentoo Forums

    http://forums.gentoo.org/viewtopic.php?t=135468

    and a related discussion forum:

    http://forums.gentoo.org/viewtopic-t-221323-postdays-0-postorder-asc-start-0.html

    These take you through the process very quickly and easily.

    I got stuck because the the apcupsd daemon relies on the USB Human Interface Device drivers to communicate with the UPS. I had removed these from my kernel to save space because I ahve neither a USB mouse nor keyboard. Putting them back fixed the problem and the system works fine now.
    Posted 12-31-1969 at 07:00 PM by tp11235 tp11235 is offline
 

  



All times are GMT -5. The time now is 02:43 AM.

Main Menu
Advertisement

My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration