Share your knowledge at the LQ Wiki.
Go Back > Blogs > drask
User Name


Rating: 5 votes, 4.00 average.

Restoring the KRDC menu

Posted 03-12-2009 at 10:32 AM by drask

The company I work for is a windows shop. Since I'm a Linux guy and telecommute most of the time, I rely on KVpnc and KRDC to connect to my remote desktop when I need to work with company Windows Only applications.

I recently had a problem with KRDC version 3.93 in OpenSuSE 10.3. When I first started it up, I was playing with the menu options and either clicked on "Settings->Show Menu Bar" or typed CTRL-M to see what would happen. What happened was my main menu disappeared, and with it my access to useful things like Bookmarks and Settings. Pressing CTRL-M failed to restore it, I assume because the menu, once closed, is no longer listening for the keyboard shortcuts.

It took me a long time to come up with a solution because I'm busy and I could live with it. Googling didn't return any results that seemed relevant to my situation. I also could not find a forum for KRDC developers. I finally figured it out, so I'm sharing this with anyone who might have the same issue.

The configuration file in question is ~/.kde4/share/config/krdcrc

You need to either add the following line to the [MainWindow] section

or modify the existing line and change Disabled to Enabled. Make sure KRDC is closed when you do it, or it will overwrite the configuration when you close it.

When you re-open KRDC, the menu is back.
Posted in Uncategorized
Views 12943 Comments 2
« Prev     Main     Next »
Total Comments 2


  1. Old Comment
    Thank you sir. This is exactly what I was looking for.
    Posted 03-24-2009 at 01:41 PM by djeepp djeepp is offline
  2. Old Comment
    thanks, did not know that and mine was set to MenuBar=Disable

    However, if you bookmark a site that you logged into often but change the password, KRDC will try to log you in with old password each time. I tried to delete bookmark, and the bookmark the remote pc again, but alas, still keeps old password.

    Do you know of way to change this?

    Thx though for above tip.
    Posted 07-17-2009 at 08:20 AM by Soo-Zah Soo-Zah is offline


All times are GMT -5. The time now is 03:44 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration