Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back > Blogs > ted_chou12
User Name


  1. Old Comment

    ibus input How TO

    Does it still work on Slackware64 14.2 ?
    The folder xinput.d does not exist, and the file could not be created.
    Posted 04-17-2017 at 10:36 AM by limpingstone limpingstone is offline
  2. Old Comment
    Posted 09-13-2013 at 03:36 PM by ted_chou12 ted_chou12 is offline
  3. Old Comment

    audio with tv tuner card

    mencoder -oac copy -ovc copy -o test2.avi mms://
    Posted 09-13-2013 at 12:43 PM by ted_chou12 ted_chou12 is offline
  4. Old Comment

    bluetooth how to, hcitool, obexftp, rfcomm

    if you lack "OBEX File Transfer" or something like "OBEX FTP", ANND you are using an android fone, you could try downloading bluetooth file transfer by searching for "OBEX" in googleplay. And the service appears as:
    Service Name: OBEX FTP
    Service RecHandle: 0x10007
    Service Class ID List:
      UUID 128: 00001106-0000-1000-8000-00805f9b34fb
    Protocol Descriptor List:
      "L2CAP" (0x0100)
      "RFCOMM" (0x0003)
        Channel: 30
    Posted 03-03-2013 at 09:33 AM by ted_chou12 ted_chou12 is offline
  5. Old Comment

    sync folder script

    Found this useful info:
    I've created two samba shares, /media/disk1 and /media/disk2
    say the structure is like this:
    /media/disk1/dir2 links to /media/disk1/dir1
    /media/disk2/dir1 links to /media/disk1/dir1

    so I can access /media/disk1/dir1 and /media/disk1/dir2 from samba share, but I cannot access /media/disk2/dir1, on Windows 7 it throws:

    [Window Title]
    Location is not available

    N:\dir1 is not accessible.

    Access is denied.


    In conclusion, symbolic inside the same drive is okay, but when cross-drive links happened, I cannot access them..
    Is there anything I have missing or done wrongly? Thanks.

    Last edited by qip; January 10th, 2011 at 07:03 AM..

    View Public Profile
    Send a private message to qip
    Find More Posts by qip

    January 10th, 2011 #2
    Has an Ubuntu Drip

    Join Date: Oct 2009
    Location: Tucson, AZ
    Beans: 782
    Ubuntu 10.10 Maverick Meerkat Re: samba share cannot access symbolic links to other drives


    You need to set

    follow symlinks = yes
    wide links = yesfor the share in smb.conf for Samba to follow symlinks out of the file share.

    ETA: You will also need to add:

    unix extensions = noto your [global] sections for security reasons. For more information, see
    Posted 02-19-2013 at 05:44 AM by ted_chou12 ted_chou12 is offline
  6. Old Comment

    ntp server for vectorlinux

    I notice the old ntp server is off by 5 MINUTES!! These are the official Taiwanese ntp servers, I am pretty sure they are well maintained:
    Posted 02-08-2013 at 09:17 PM by ted_chou12 ted_chou12 is offline
  7. Old Comment

    how to wake on lan?

    Please note that you have to disable the old alarm first, if you want
    to set a new alarm. Otherwise, you get an error. Example:

    echo 12345 > /sys/class/rtc/rtc0/wakealarm
    echo 0 > /sys/class/rtc/rtc0/wakealarm
    echo 23456 > /sys/class/rtc/rtc0/wakealarm
    Posted 10-13-2012 at 09:52 PM by ted_chou12 ted_chou12 is offline
  8. Old Comment

    how to wake on lan?


    Turning on computers remotely

    Posted by Steve on Wed 20 Apr 2005 at 08:42

    Tags: boot, network booting, wakeonlan

    To save power it's often useful to turn systems off, but of course when you do that you cannot use them! This is especially frustrating when you turn off a machine which is physically remote from you, but it doesn't need to be. Many modern PCs have the ability to be remotely "woken up" and turned on.

    "WakeOnLan" is the term which is used for remotely powering on machines, as this is done by sending "magic network packets" to switch on machines.

    To use wakeonlan you'll need either:
    •A network card which supports WakeOnLan, which usually has a jumper which connects to your system's motherboard.
    •An on-board network interface which supports this functionality.

    Many modern systems with on-board NICs support wakeonlan, but it must be enabled in the BIOS. (Look for the option in the "power management" section of your BIOS, it might be called "wakeonlan", "netboot", or "wake on ring events").

    If you have the requisite hardware support can see if it's enabled by your system by running the ethtool command, this shows whether the wakeonlan option is supported by your card, and whether it is enabled.

    If you don't have this installed run:
    apt-get install ethtool

    Once it's installed run it with the name of your network interface:
    root@lappy:~# ethtool eth0
    Settings for eth0:
    Supports Wake-on: g
    Wake-on: d
    Link detected: yes

    Here we can see that wakeonlan support is available because of the g, but it's disabled. (This is explained in the manpage which you can read with "man ethtool"). To enable the magic packet support run:
    root@lappy:~# ethtool -s eth0 wol g

    Now you should be able to see that it's turned on:
    root@lappy:~# ethtool eth0
    Settings for eth0:
    Supports Wake-on: g
    Wake-on: g
    Link detected: yes

    Now that you know it's turned on you need to do one more thing. Wakeonlan software requires that you know the MAC address of the machine you wish to switch on, rather than the IP address.

    To determine the MAC address you can either:
    •Discover it on the machine itself before it is switched off, by using ifconfig
    •Determine it remotely, whilst the machine is powered on and running.

    To determine the MAC address via ifconfig just run it:
    skx@mystery:~$ /sbin/ifconfig
    eth0 Link encap:Ethernet HWaddr 00:0A:E6:F6:A3:F4
    inet addr: Bcast: Mask:
    inet6 addr: fe80::20a:e6ff:fef6:a3f4/64 Scope:Link
    RX packets:2218390 errors:0 dropped:0 overruns:0 frame:0
    TX packets:3098440 errors:0 dropped:0 overruns:0 carrier:0
    collisions:0 txqueuelen:1000
    RX bytes:1624008578 (1.5 GiB) TX bytes:1368310661 (1.2 GiB)
    Interrupt:10 Base address:0xd400

    Here the MAC address is 00:0A:E6:F6:A3:F4, it's on the first line and is described as the "HWaddr" or "hardware address".

    If you're looking for the MAC address of another machine upon your LAN you can ping the machine, then look at the arp cache.

    For example if I wished to determine the MAC address of the machine from my current host I'd run the following two commands:
    kx@mystery:~$ ping -c 1 sun
    PING ( 56(84) bytes of data.
    64 bytes from sun ( icmp_seq=1 ttl=64 time=0.202 ms

    --- ping statistics ---
    1 packets transmitted, 1 received, 0% packet loss, time 0ms
    rtt min/avg/max/mdev = 0.202/0.202/0.202/0.000 ms
    skx@mystery:~$ /usr/sbin/arp sun
    Address HWtype HWaddress Flags Mask Iface
    sun ether 08:00:20:C2:1E:F6 C eth0

    The arp command shows the machine's MAC address, the ping being required first to make sure that my current machine knew the MAC address in the first place.

    Once you have the MAC address you can shutdown the system you wish to test, and then attempt to restart it remotely.

    There are several pieces of software for sending the wakeonlan packets inside the Debian archive:
    •etherwake ◦Requires root privileges and available in all Debian distributions.

    •wakeonlan ◦Can be used by all users, but only in the Sarge (testing) and unstable (Sid) repositories

    I'm going to use wakeonlan, since it's already installed and can be used by non-root users:
    skx@mystery:~$ wakeonlan 08:00:20:C2:1E:F6
    Sending magic packet to with 08:00:20:C2:1E:F6

    This sends the magic wake on lan packet to the machine on the LAN with the hardware address "08:00:20:C2:1E:F6" which we previously determined belonged to the machine sun.

    If all goes well the machine will begin to boot shortly after recieving the packet.
    How to automatically wake up your computer at a particular time ( Resume by RTC alarm in Arch Linux )

    August 15, 2011 by Rag Sagar.V രാഗ് സാഗര്*.വി

    My ISP provides unlimited download from 2am to 8am. So i was not able to sleep after 2 from the time i switched to the new broadband plan. Keeping the system on and setting a cronjob to start downloading after 2 was an option. But i was more concerned about the increasing electricity charge, than my sleep. Besides it is my social responsibility to save energy as a gonna-be software engineer . After a bit of googling and hacking i was able to wake up my system at a particular time. Here i am going to explain how i made my arch linux system to boot automatically at 2 am.

    The configuration is done in Arch Linux. For automatic wakeup it needs a BIOS which supports RTC alarm. Most of them manufactured after 2000 supports this feature.

    1) Check if your BIOS supports automatic wakeup

    Execute the command below as root.


    # grep rtc /var/log/messages.log


    rtc_cmos 00:03: RTC can wake from S4


    rtc0: alarms up to one month

    If you can find something like this in the output.It says that the system can wakeup and a wakeup time can be setup.

    2) Enable automatic wakeup in BIOS

    Go to your BIOS setup, Under Power Management search for something like “Wake by RTC Alarm” or “Resume by RTC alarm” or “RTC resume”.Then enable it.

    3) Set the hardware clock time standard as UTC

    Edit the /etc/rc.conf file as root and set the HARDWARECLOCK variable to UTC


    [ragsagar@h4ckb0x ~]$ grep ^HARDWARECLOCK /etc/rc.conf



    Make sure that your timezone is set correctly in /etc/rc.conf
    More help :

    4) Set the alarm time

    Execute the following commands as root


    # echo 0 > /sys/class/rtc/rtc0/wakealarm


    # echo `date '+%s' -d '+ 5 minutes'` > /sys/class/rtc/rtc0/wakealarm

    This will set the the alarm time as 5 minutes into the future.

    Now run


    $ cat /sys/class/rtc/rtc0/wakealarm

    If the output of above command is something like “1313383930″, the alarm is set. It is epoch time. If it doesn’t yield any result make sure that the HARDWARECLOCK variable is set to UTC and reboot and try again to set the alarm time.

    Now run


    $ cat /proc/driver/rtc

    Go through rtc_time, alrm_time and alrm_date and check if they are correct(will be in UTC).Turn off the system and leave the power on. Check if the system is booting automatically after five mintues.

    5) Setting the alarm to a particular time and date.

    To set the alarm to woke up the system at 16th Aug 2:05am, Run the following as root


    # echo 0 > /sys/class/rtc/rtc0/wakealarm


    # date --date "Aug 16 , 2011 02:05:00" +%s > /sys/class/rtc/rtc0/wakealarm

    You can convert the epoch time to readable format and check the alarm time is correct.


    [root@h4ckb0x ragsagar]# cat /sys/class/rtc/rtc0/wakealarm




    [root@h4ckb0x ragsagar]# date -d @1313440500 +%F" "%T


    2011-08-16 02:05:00

    Note : The mythtv wiki about acpi wakeup says that setting the hardware clock after setting alarm will disable the alarm while most of the linux distribution sets hardware clock during shutdown. They suggest to disable hardware clock adjusting during shutdown. To do that in Archlinux set the HARDWARECLOCK=”" in /etc/rc.conf . But in my arch system the alarm was not working when i set HARDWARECLOCK=”" whereas it worked when i gave HARDWARECLOCK=”UTC”. So if the wake up alarm is not working do try after changing the value of this variable.

    To start downloading when the system boots up, i added a cronjob to restart the router at 2:15 and 7:45 (to account the download in happy hours). Also added “transmission-gtk” to the gnome-session-properties. So that transmission will be launched on startup and downloading will be started.
    Posted 10-06-2012 at 03:17 PM by ted_chou12 ted_chou12 is offline
  9. Old Comment
    Posted 09-28-2012 at 04:30 AM by ted_chou12 ted_chou12 is offline
  10. Old Comment

    ntp server for vectorlinux

    Not sure what you mean.
    I tested now ntp with vector Linux and it seems to run ok.
    For the occasional user ntpdate someserver is fine.
    If you want to run the ntp daemon, I've found a good tutorial for slackware that is applicable to vector linux:

    Went you install ntp package, with gslapt for example, the /etc/ntp.conf and /etc/rc.d/rc.ntpd files are created automatically. But you have to make sure rc.ntpd file is executable by running chmod+x /etc/rc.d/rc.ntpd

    Posted 09-07-2012 at 12:52 PM by oldpenguin oldpenguin is offline
  11. Old Comment

    ibus input How TO

    For launching ibus at startup, you must add
    ibus-daemon -rxd
    in .~/.icewm/startup file.
    Posted 08-24-2012 at 07:16 AM by ted_chou12 ted_chou12 is offline
  12. Old Comment

    Let me post something unrelated...Cause Im MAD

    Great idea - but then... The bank gets their turn as well. They will allow paypal to submit the transaction,
    charge your account an overdraft fee , and then return an nsf (non sufficient funds) notice to paypal
    , which then allows them to levy more fees. Ask me how I know about this, and why I would rather not!
    Posted 08-19-2012 at 09:54 AM by bgovan bgovan is offline
  13. Old Comment

    transmission rc.local

    An improvement:
    # description: Transmission daemon
    # GNU GPL (c) Written by Ted C. as right authorized to any (2012)
    #         (c) Vector Linux. 2004
    # Include the functions declared in the /etc/rc.d/functions file
    source /etc/rc.d/functions
    case "$1" in
    	echon "Starting Transmission Daemon....."
    	loadproc $PATH -g $CONF -x $PID -e $LOG 
    	echon "Stopping Transmission Daemon....."
    	killproc $PATH
    	echon "Reloading Transmission Daemon....."
    	reloadproc $PATH -g $CONF -x $PID -e $LOG
    	$0 stop
    	/bin/sleep 1
    	$0 start
    	echo "Usage: $0 {start|stop|reload|restart}"
    	exit 1
    # End /etc/init.d/
    This is a bootup script that works for Slackware (designed especially for vectorlinux)
    Posted 08-17-2012 at 03:18 AM by ted_chou12 ted_chou12 is offline
  14. Old Comment
    Posted 08-16-2012 at 06:17 AM by ted_chou12 ted_chou12 is offline
  15. Old Comment

    cifs not able to mount by hostname only by ip (solved)

    From what little has been posted I would suspect that you are not running DNS, can't access your DNS, or do not have NAS defined in a zone. Thus NAS is unresolvable, which is what mount is complaining about. So adding an address and host to your host file takes care of NAS being unresolvable. This is the function of the hosts file and in fact the host file was the way all Internet address were resolved. That takes us back a good 40+ years ago. These days we use DNS instead of the host file. Either way and you find your solution.
    Posted 08-16-2012 at 03:40 AM by countrygrrl_ak countrygrrl_ak is offline
  16. Old Comment

    Let me post something unrelated...Cause Im MAD

    My brother set up a PayPal account for eBay that is linked to a savings account which is *NOT* linked to any of his other bank/charge accounts. That way when (and note I said "when", not "if") ebay/paypal decides to do something bad/incorrect/corrupt with his account, they will have very little to screw with (he figures when he gets paid for an item, he'll simply remove the transferred money *immediately* so thay have little to no funds around to screw him out of).
    Posted 08-15-2012 at 07:14 PM by jelabarre59 jelabarre59 is offline
  17. Old Comment

    cifs not able to mount by hostname only by ip (solved)

    Start scripts for gui
    Kill scripts for gui
    Start scripts for tui
    Kill scripts for tui

    vector linux os
    Posted 08-15-2012 at 06:03 AM by ted_chou12 ted_chou12 is offline
  18. Old Comment

    Let me post something unrelated...Cause Im MAD

    But what do their terms of conditions say w.r.t this problem?
    Posted 08-13-2012 at 09:32 PM by TheIndependentAquarius TheIndependentAquarius is offline
  19. Old Comment

    transmission rc.local

    Yes, changing to:
    transmission-daemon -u root -v xxxxxxxx -g /root/.config/transmission-daemon
    in /etc/rc.local does initiate transmission perfectly.
    In addition, I found that the transmission-daemon does not terminate smoothly during shutdown, this caused some conflicts with the firewall.
    Posted 08-12-2012 at 03:59 PM by ted_chou12 ted_chou12 is offline
  20. Old Comment

    What there is a blog?

    They should add "like" button to this too! :P
    Posted 03-28-2011 at 05:17 AM by ted_chou12 ted_chou12 is offline


All times are GMT -5. The time now is 02:10 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration