Help answer threads with 0 replies.
Go Back > Blogs > jere21
User Name


Rate this Entry

Current^WFixed Intel HD Graphics 4000 (Ivy Bridge, kernel driver i915) / Debian Jessie issues

Posted 12-03-2014 at 12:00 PM by jere21
Updated 05-21-2015 at 01:31 PM by jere21 (Everything fixed)

How to report intel graphics related bugs (independent if they relate to kernel, mesa or whatever):

Howto find the offending change in the kernel:

  1. Freeze/Crash when using some software that uses certain graphics hardware stuff.
    Getting the following error message:
    Failed to open BO for returned DRI2 buffer (1600x900, dri2 back buffer, named 11).
    This is likely a bug in the X Server that will lead to a crash soon.)
    Bug reports:

    Workaround: Enable SNA
    Add /etc/X11/xorg.conf.d/20-intel.conf with the following content:
    Section "Device"
        Identifier  "Intel Graphics"
        Driver      "intel"
        Option      "AccelMethod"  "sna"
        Option      "TearFree"    "true"
    Note 2015-05-21: This is the default in Debian since 2:2.99.911+git20140529-1~exp2 (Stop overriding default upstream acceleration method (i.e. default to SNA instead of UXA).

  2. Black laptop screen
    Most times my laptop screen (LVDS1) is completely dimmed (= black) after boot at the GDM login prompt, if the external monitor (HDMI1) is or gets plugged in. Trying to increase the brightness (Fn+F3) shows the brightness OSD on HDMI1, but the bar only moves up to about max. 5% (which is still a black screen).

    Thus the GDM login prompt (which is placed on LVDS1) is not visible, while HDMI1 works but has no content to display.

    Switching to tty1 and back fixes the brightness level (= normal LVDS1 with visible login prompt). But it still can't be regulated below about 95% then.

    After login in Gnome brightness can be regulated again.

    This started to happen with Linux 3.16.
    The initial brightness level is ok again with Linux 3.17, but is still not regulatable.

    Workaround: Disable native backlight
    Set in /etc/default/grub
    GRUB_CMDLINE_LINUX_DEFAULT="quiet video.use_native_backlight=0"
    and execute "update-grub" once.
    This adds /sys/class/backlight/acpi_video0 next to /sys/class/backlight/intel_backlight. The laptop display at the GDM prompt then has a reasonable brightness level, which is also adjustable again.
    This was default until Linux 3.14.

    Bug reports:
    Note 2015-05-21: My fix has been accepted in Linux 4.0 and backported to Debian's 3.16 kernel.

    Note for other models:
    intel_backlight causes problems for several models. The solution is to add the above workaround on a per model basis to the linux code. So if you've got brightness issues with intel graphics after kernel 3.14 just file another bugreport at freedesktop, so that acpi can be used for your machine again, too. Once accepted and if you use an older kernel nudge the maintainer to backport the fix (which is trivial).

    Not relevant:
    Error messages shown on TTY before login. But I get them always, independently if the screen is dark or not, and also with linux 3.17. So I don't know if this is related. (And a web search shows there is much noise around them.)
    kernel: [    2.352424] [drm:cpt_set_fifo_underrun_reporting] *ERROR* uncleared pch fifo underrun on pch transcoder A
    kernel: [    2.352425] [drm:cpt_serr_int_handler] *ERROR* PCH transcoder A FIFO underrun
Posted in Uncategorized
Views 4527 Comments 0
« Prev     Main     Next »
Total Comments 0




All times are GMT -5. The time now is 06:25 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration