LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch
User Name
Password
Arch This Forum is for the discussion of Arch Linux.

Notices


Reply
  Search this Thread
Old 01-19-2011, 02:43 PM   #1
Ipozya
Member
 
Registered: Dec 2010
Distribution: Arch
Posts: 54

Rep: Reputation: 2
NetworkManager


Hi everyone,

I have an issue regardin NetworkManager. I have installed networkmanager, nm-applet, and other dependencies correctly. I can run the program as root (have the applet show on the bottom bar of fluxbox) and am able to successfully connect to the wireless network. The issue lies when I try to run the program as a regular user. When I type nm-applet into bash I receive the following:

Code:
** (nm-applet:1576): WARNING **: <WARN> request_name(): Could not acquire the NetworkManagerUserSettings service.
Error: (9) Connection ":1.27" is not allowed to own the service "org.freedesktop.NetworkManagerUserSettings" due to security policies in the configuration file
I have googled this error and have been returned with a great number of bug listings and discussions about it (seems to be some new feature that came with an update. After following some of the advice in the forums, I still have not been able to fix the issue.

For example, one suggestion was to change .xinitrc to include
Code:
exec ck-launch-session startfluxbox
instead of

Code:
exec startfluxbox
If I add the ck-launch-session, however, SLiM returns an error and can't log in. Others made changes to the NetworkManager config files that I mimicked without solving the issue. Could anyone point me in the right direction?

Thank you in advance.
 
Old 01-19-2011, 02:58 PM   #2
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003
Can you check who the user is that owns the NetworkManager binary? Most likely not the problem, but doesn't hurt to double check.
 
Old 01-19-2011, 05:11 PM   #3
Ipozya
Member
 
Registered: Dec 2010
Distribution: Arch
Posts: 54

Original Poster
Rep: Reputation: 2
The root user owns the binary. I think that the problem may lie in the following files:

/etc/dbus-1/system.d/NetworkManager.conf:
Code:
<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
        <policy user="root">
                <allow own="org.freedesktop.NetworkManager"/>
                <allow own="org.freedesktop.NetworkManagerSystemSettings"/>

                <allow send_destination="org.freedesktop.NetworkManager"/>
                <allow send_destination="org.freedesktop.NetworkManagerSystemSettings"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.PPP"/>
        </policy>
        <policy at_console="true">
                <allow send_destination="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.DBus.Introspectable"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.DBus.Properties"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.AccessPoint"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Connection.Active"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Cdma"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Wired"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Gsm"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Serial"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device.Wireless"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.Device"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.DHCP4Config"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.IP4Config"/>

                <allow send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager.VPN.Connection"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="SetLogging"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="Sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="wake"/>
        </policy>
        <policy context="default">
                <deny own="org.freedesktop.NetworkManager"/>
                <deny own="org.freedesktop.NetworkManagerSystemSettings"/>

                <deny send_destination="org.freedesktop.NetworkManager"/>
                <allow send_destination="org.freedesktop.NetworkManagerSystemSettings"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="SetLogging"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="Sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="sleep"/>

                <deny send_destination="org.freedesktop.NetworkManager"
                       send_interface="org.freedesktop.NetworkManager"
                       send_member="wake"/>

                <!-- The org.freedesktop.NetworkManagerSettings.Connection.Secrets
                     interface is secured via PolicyKit.
                  -->
        </policy>

        <limit name="max_replies_per_connection">512</limit>
</busconfig>
/etc/dbus-1/system.d/nm-applet.conf:
Code:
<!DOCTYPE busconfig PUBLIC
 "-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
 "http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
<busconfig>
	<!--
	     WARNING: if running any D-Bus version prior to 1.2.6, you may be
	     vulnerable to information leakage via the NM D-Bus interface.
	     Previous D-Bus versions did not deny-by-default, and this permissions
	     config file assumes that D-Bus will deny rules by default unless
	     explicitly over-ridden with an <allow /> tag.
	 -->

        <policy user="root">
                <allow own="org.freedesktop.NetworkManagerUserSettings"/>

                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"
                       send_interface="org.freedesktop.NetworkManagerSettings"/>

                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"
                       send_interface="org.freedesktop.NetworkManagerSettings.Connection"/>

                <!-- Only root can get secrets -->
                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"
                       send_interface="org.freedesktop.NetworkManagerSettings.Connection.Secrets"/>
        </policy>
        <policy at_console="true">
                <allow own="org.freedesktop.NetworkManagerUserSettings"/>

                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"
                       send_interface="org.freedesktop.NetworkManagerSettings"/>

                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"
                       send_interface="org.freedesktop.NetworkManagerSettings.Connection"/>
        </policy>
        <policy context="default">
                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"
                       send_interface="org.freedesktop.DBus.Introspectable"/>
        </policy>

        <limit name="max_replies_per_connection">512</limit>
</busconfig>
Also, other posts have referred to issues with Hal. I do not have this installed (was not shown as a requirement in arch guide I followed), so I am not sure if this could be another point we could look at it. Thanks for your continued assistance.
 
1 members found this post helpful.
Old 01-19-2011, 07:28 PM   #4
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003
Hmm... could you try installing hal and see if it works? I never came across this problem ever before.
 
Old 01-19-2011, 07:35 PM   #5
Ipozya
Member
 
Registered: Dec 2010
Distribution: Arch
Posts: 54

Original Poster
Rep: Reputation: 2
But nm should not require hal to function properly o_0 I would rather not download more than necessary
 
Old 01-19-2011, 07:41 PM   #6
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003
Oh ok my bad, I thought it did.
 
Old 01-19-2011, 07:48 PM   #7
Ipozya
Member
 
Registered: Dec 2010
Distribution: Arch
Posts: 54

Original Poster
Rep: Reputation: 2
No problem. I found a "fix". The following as added to /etc/dbus-1/system.d/nm-applet.conf. Original credit goes to the author from the following link (I only slightly modified his change): https://bbs.archlinux.org/viewtopic.php?id=63576

Code:
<!-- hack -->
                <policy user="myusername">
                <allow own="org.freedesktop.NetworkManagerUserSettings"/>
                <allow send_destination="org.freedesktop.NetworkManagerUserSettings"/>
                <allow send_interface="org.freedesktop.NetworkManagerUserSettings"/>

                <deny send_interface="org.freedesktop.NetworkManagerSetting.Secrets"/>
        </policy>
<!-- end of hack -->
Edit:
This fixed the applet so that it appears in fluxbox, but now I am not able to connect to the wireless network, which worked previously as root >_<
New problem so I will try to fix it and post back if I can't. Thanks for the help corp

Last edited by Ipozya; 01-19-2011 at 07:53 PM.
 
1 members found this post helpful.
Old 01-19-2011, 08:13 PM   #8
Ipozya
Member
 
Registered: Dec 2010
Distribution: Arch
Posts: 54

Original Poster
Rep: Reputation: 2
Ok, so let's continue this discussion since I have solved one and brought another one upon myself :P

The network-applet now starts up when I log in. Whenever I try to connect to wireless, however, nothing happens (the symbol doesn't change in anyways, e.g. the green spheres circling). I am succesfully able to use my wired connection and in root both wireless and wired work just fine. This must be some sort of group setting or manual configuration in a network manager file, but I am not able to find anything (I have not had any of these issues with nm ever before, but then again arch does not provide me with much more than the basics so it was probably auto configured). Thanks for the help.
 
Old 01-19-2011, 10:54 PM   #9
Ipozya
Member
 
Registered: Dec 2010
Distribution: Arch
Posts: 54

Original Poster
Rep: Reputation: 2
Solved: Had to install consolekit and add "ck-launch-session" to my .xinitrc file when starting fluxbox. Please note that this also allowed me to remove the previous change to nm-applet.conf (no longer necessary)!
 
Old 01-20-2011, 09:22 AM   #10
corp769
LQ Guru
 
Registered: Apr 2005
Posts: 5,818

Rep: Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003Reputation: 1003
Awesome dude, glad to hear you were able to fix it. I checked out that link and saved it to my favorites just in case anyone ever comes to me with that problem. Thanks to you too lol
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
NetworkManager dbswifty Linux - Newbie 6 08-23-2010 05:05 PM
networkmanager giraf Ubuntu 7 05-05-2010 04:22 PM
NetworkManager + wpa_supplicant Zxarr Linux - Wireless Networking 2 07-07-2008 08:39 AM
Besides NetworkManager, shreks Fedora 1 01-18-2006 02:26 AM
NetworkManager baparekh Linux - Networking 1 07-28-2005 04:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Arch

All times are GMT -5. The time now is 07:19 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration