LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Other *NIX Forums > *BSD
User Name
Password
*BSD This forum is for the discussion of all BSD variants.
FreeBSD, OpenBSD, NetBSD, etc.

Notices


Reply
  Search this Thread
Old 07-07-2010, 10:40 AM   #1
altech2k3
LQ Newbie
 
Registered: May 2005
Location: Minnesota, USA
Distribution: Fedora, Ubuntu, OpenBSD, KNOPPIX
Posts: 24

Rep: Reputation: 7
Question uath won't configure Netgear WPN111 in FreeBSD-8.0


Hey all,

I have been working to find a solution to this problem. When I attach the usb network card, it begins as product id 0x5f01. I then use

Code:
$ uathload -d /dev/ugen4.2
My network card then shifts its product id to 0x5f02. I found an answer on this mailing list.

where it says in the usbdevs
Code:
...
-product NETGEAR3 WPN111     0x5f00 WPN111
product NETGEAR3 WPN111_NF   0x5f01 WPN111 (no firmware)
+product NETGEAR3 WPN111     0x5f02 WPN111
...
How should I interpret this information? Should I remove the line with the subtraction prefix and add the line with the addition prefix? Or should I just edit /sys/dev/usb/usbdevs with the two lines of code as is?

Also once I have made this change, are there any follow-up procedures I have to perform?

Sorry. I don't have much experience with this problem.

Thanks all.
 
Old 07-07-2010, 11:47 PM   #2
Mr-Bisquit
Member
 
Registered: Feb 2009
Distribution: FreeBSD, OpenBSD, NetBSD, Debian, Fedora
Posts: 770
Blog Entries: 52

Rep: Reputation: 68
http://unix.derkeiler.com/Mailing-Li.../msg00057.html
http://wiki.freebsd.org/Networking look for a mailing list link
Also try the general questions mailing list.
 
Old 07-11-2010, 01:12 PM   #3
altech2k3
LQ Newbie
 
Registered: May 2005
Location: Minnesota, USA
Distribution: Fedora, Ubuntu, OpenBSD, KNOPPIX
Posts: 24

Original Poster
Rep: Reputation: 7
I have used this setup. I've created a uath.conf in /etc/devd/.

Whenever I run 'ifconfig wlan create wlandev uath0,' I get an error message SIOCIFCREATE2: Device not configured.

I have tried to use a KNOPPIX LiveDVD to see if another system would configure, but I didn't succeed; it may be a faulty network card, but I have been able to configure it with Windows in the past. The firmware doesn't seem to be applying correctly under *nix environments.

Last edited by altech2k3; 07-11-2010 at 01:30 PM. Reason: incorrect error message and command-line options
 
Old 05-21-2011, 04:14 AM   #4
altech2k3
LQ Newbie
 
Registered: May 2005
Location: Minnesota, USA
Distribution: Fedora, Ubuntu, OpenBSD, KNOPPIX
Posts: 24

Original Poster
Rep: Reputation: 7
Post My Solution

Although this thread is way old, I thought that I would post a solution to the problem throughout this thread.

First, FreeBSD-8.0 would not configure my WPN111 (Atheros chipset) wireless usb device. I executed the following and still would not connect.

1) Apply the patch ...

The snippet from the .diff file further up removes one line containing a WPN111 firmware installed. When the device is inserted into a usb slot, a 'usbconfig -u 4 -a 2 dump_device_desc' yields "...0x5f01..." and it is associated in "usbdevs" as WPN111 (no firmware).

Executing 'uathload -d /dev/ugen4.2' should cause the device to decrement to 0x5f00; however, it does the opposite.

Applying the patch (diff file), it removes the line "product NETGEAR3 WPN111 0x5f00 WPN111" and adds the line "product NETGEAR3 WPN111 0x5f02" to /usr/src/sys/dev/usb/usbdevs -- a file containing usb definitions.

2) Rebuild the kernel...

In the directory "/usr/src," I executed 'make kernel.' After several minutes, the kernel had been installed and I then rebooted.

3) Enabling 'devd'...

In my /etc/rc.conf file, I added these two lines to provide KDE4 the facilities to work...
Code:
hald_enable="YES"
dbus_enable="YES"
devd is enabled within the kernel already.

4) Corrected /etc/devd/uath.conf ...

From this ...
Code:
# Netgear
#   WG111T and WPN111
notify 100 {
	match "system"		"USB";
	match "subsystem"	"DEVICE";
	match "type"		"ATTACH";
	match "vendor"		"0x1385";
	match "product"		"(0x4251|0x5f01)";
	action "/usr/sbin/uathload -d /dev/$cdev";
};
To this ...
Code:
# Netgear
#   WG111T and WPN111
attach 100 {
	device-name             "ugen[0-9]+";
	match "vendor"		"0x1385";
	match "product"		"(0x4251|0x5f01)";
	action "/usr/sbin/uathload -d /dev/$device-name";
};
5) Test ...

Inserted the WPN111 Wireless USB 2.0 into an open USB slot and shazzam the lights are on...

... but it turns out that no one is home.

6) Added to rc.conf...

Code:
wlans_ath0="wlan0"
ifconfig_wlan0="SYNCDHCP bssid 0a:1b:2c:3e:4d:5e wepmode on wepkey MY_KEY weptxkey 1"
7) We have a connection ...

"ifconfig wlan0" produces
"...inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255...
media: associated Wireless Ethernet OFDM/54Mbps mode 11g..."

Okay ... try "dhclient wlan0"
"DHCPDISCOVER media wlan0 broadcast 255.255.255.255 interval #
...No leases in database - sleeping"

"ifconfig wlan0" again produces the above.

In conclusion, I retired the whole notion of getting that NIC working on FreeBSD 8.0-RELEASE. I worked on the solution for a whole week (of my free time) and I tried virtually every angle.

I did manage to get my WPN111 (Atheros chipset) Wireless USB 2.0 NIC to work, but I shifted it over to an OpenBSD 4.9 system. Once the firmware was placed into "/etc/firmware" as "uath-ar5523," inserted the USB NIC, and executed "ifconfig uath0 nwid MY_WLAN nwkey MY_KEY up"

... and inet address 192.168.1.106.
 
1 members found this post helpful.
Old 05-21-2011, 04:18 AM   #5
EricTRA
LQ Guru
 
Registered: May 2009
Location: Gibraltar, Gibraltar
Distribution: Fedora 20 with Awesome WM
Posts: 6,805
Blog Entries: 1

Rep: Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295Reputation: 1295
Hello,

Doesn't matter that the thread is old, it's your thread, you started it. And the solution you're providing is very complete. I'm sure it will come in handy for a lot of users that find themselves in a similar situation. Have fun with Linux.

Kind regards,

Eric

Last edited by EricTRA; 05-22-2011 at 10:47 AM. Reason: Typo
 
Old 05-22-2011, 09:09 AM   #6
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 234Reputation: 234Reputation: 234
My thanks, too.
 
Old 05-22-2011, 03:32 PM   #7
altech2k3
LQ Newbie
 
Registered: May 2005
Location: Minnesota, USA
Distribution: Fedora, Ubuntu, OpenBSD, KNOPPIX
Posts: 24

Original Poster
Rep: Reputation: 7
My Ancient Thread

Thank you for posting your replies.

I realized that this was an old thread; however, the problem had been bothering me for that long. I figured that I would post a reply and make this thread solved.

Some individuals may view the above as meager and amateur, but I discovered that the real problem above was that there isn't a whole lot of documentation when it comes to applying .diff patches. After the .diff (patch) was applied, I soon learned the final issue was rebuilding the FreeBSD kernel, which (again) wasn't explicitly explained.

I figure that I'd post my lesson in .diff (patch) files and the FreeBSD kernel.

Thanks again for your interest.
 
Old 10-04-2018, 08:02 AM   #8
alcotross
LQ Newbie
 
Registered: Oct 2018
Location: Dallas, TX, USA
Posts: 1

Rep: Reputation: Disabled
Smile

Quote:
Originally Posted by altech2k3 View Post
Although this thread is way old, I thought that I would post a solution to the problem throughout this thread.

First, FreeBSD-8.0 would not configure my WPN111 (Atheros chipset) wireless usb device. I executed the following and still would not connect.

1) Apply the patch ...

The snippet from the .diff file further up removes one line containing a WPN111 firmware installed. When the device is inserted into a usb slot, a 'usbconfig -u 4 -a 2 dump_device_desc' yields "...0x5f01..." and it is associated in "usbdevs" as WPN111 (no firmware).

Executing 'uathload -d /dev/ugen4.2' should cause the device to decrement to 0x5f00; however, it does the opposite.

Applying the patch (diff file), it removes the line "product NETGEAR3 WPN111 0x5f00 WPN111" and adds the line "product NETGEAR3 WPN111 0x5f02" to /usr/src/sys/dev/usb/usbdevs -- a file containing usb definitions.

2) Rebuild the kernel...

In the directory "/usr/src," I executed 'make kernel.' After several minutes, the kernel had been installed and I then rebooted.

3) Enabling 'devd'...

In my /etc/rc.conf file, I added these two lines to provide KDE4 the facilities to work...
Code:
hald_enable="YES"
dbus_enable="YES"
devd is enabled within the kernel already.

4) Corrected /etc/devd/uath.conf ...

From this ...
Code:
# Netgear
#   WG111T and WPN111
notify 100 {
	match "system"		"USB";
	match "subsystem"	"DEVICE";
	match "type"		"ATTACH";
	match "vendor"		"0x1385";
	match "product"		"(0x4251|0x5f01)";
	action "/usr/sbin/uathload -d /dev/$cdev";
};
To this ...
Code:
# Netgear
#   WG111T and WPN111
attach 100 {
	device-name             "ugen[0-9]+";
	match "vendor"		"0x1385";
	match "product"		"(0x4251|0x5f01)";
	action "/usr/sbin/uathload -d /dev/$device-name";
};
5) Test ...

Inserted the WPN111 Wireless USB 2.0 into an open USB slot and shazzam the lights are on...

... but it turns out that no one is home.

6) Added to rc.conf...

Code:
wlans_ath0="wlan0"
ifconfig_wlan0="SYNCDHCP bssid 0a:1b:2c:3e:4d:5e wepmode on wepkey MY_KEY weptxkey 1"
7) We have a connection ...

"ifconfig wlan0" produces
"...inet 0.0.0.0 netmask 0xff000000 broadcast 255.255.255.255...
media: associated Wireless Ethernet OFDM/54Mbps mode 11g..."

Okay ... try "dhclient wlan0"
"DHCPDISCOVER media wlan0 broadcast 255.255.255.255 interval #
...No leases in database - sleeping"

"ifconfig wlan0" again produces the above.

In conclusion, I retired the whole notion of getting that NIC working on FreeBSD 8.0-RELEASE. I worked on the solution for a whole week (of my free time) and I tried virtually every angle.

I did manage to get my WPN111 (Atheros chipset) Wireless USB 2.0 NIC to work, but I shifted it over to an OpenBSD 4.9 system. Once the firmware was placed into "/etc/firmware" as "uath-ar5523," inserted the USB NIC, and executed "ifconfig uath0 nwid MY_WLAN nwkey MY_KEY up"

... and inet address 192.168.1.106.
Hi! it's a great discussion, I am trying to follow these steps. i seems it's helpful to me.
 
  


Reply

Tags
freebsd, netgear, wpn111


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Netgear wpn111 wireless setup? Ubuntu 8.4 tenchidbz Linux - Wireless Networking 1 06-26-2008 08:32 PM
Working with Netgear WPN111. Ultimo Linux - Wireless Networking 2 09-19-2007 01:47 AM
FC6 + netgear wpn111 usb card admart35 Linux - Wireless Networking 1 06-10-2007 03:49 PM
SuSE Linux Enterprise Desktop 10 + ADSL Netgear DG834GT + USB Netgear WPN111 paolinux Linux - Wireless Networking 1 12-31-2006 06:58 AM
Tring to get a Netgear WPN111 working. Ultimo Linux - Wireless Networking 0 10-20-2006 01:43 AM

LinuxQuestions.org > Forums > Other *NIX Forums > *BSD

All times are GMT -5. The time now is 05:17 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration