LinuxQuestions.org
Visit the LQ Articles and Editorials section
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 05-29-2008, 06:10 AM   #1
adcockp
LQ Newbie
 
Registered: Mar 2008
Location: Hungerford, UK
Distribution: Ubuntu 8.04 LTS
Posts: 7

Rep: Reputation: 0
Upgrade from 7.10 to 8.04 stops connection to mail server and selected internet sites


Hi,

Having just used the update manager to upgrade from 7.10 to 8.04 I have encountered a couple of problems that make no sense to me:

1. I can't get Evolution to connect to my Tiscali POP email account
either to send or receive. I have checked and re-checked the
credentials entered into the software and they are IDENTICAL to
the ones set-up on the other machines on the network. (WinXP
machines running Outlook).

Tiscali is my ISP. They have a POP server pop.tiscali.co.uk
that requires authentication to receive, and an SMTP server
smtp.tiscali.co.uk to send, that doesn't require
authentication.

2. Firefox reports "Address Not Found" for some (but not all) internet
sites. This is just MAD. I can get to all sorts of sites OK
including;linuxquestions.org, facebook.com, youtube.com, and
ask.com. But tiscali.co.uk, bbc.co.uk and google.co.uk come
back with the error. I'm probably being paranoid but its
like there is some kind of filter blocking access to the sites.
I can probably live without the BBC but not being able to access
Google is a bit of a problem.

I have network and internet access (via a router/DSL connection).
This appears to be working correctly: The Linux box is visible to the router and other machines on the network, and vice versa. The update manager can connect to software sources, and so can the application manager. So I am fairly sure I am getting out onto the web.

The only thing I have noticed is that all the servers I'm having difficulty reaching appear to have .co.uk domains.

Has anyone else encountered anything like this before?

If anyone can help please be aware that I am not a technical person. I guess I know enough to be dangerous, meaning that I can follow simple instructions and configure software using a GUI. I am new to Linux as a hobby interest, I am usually baffled by any and all things "networking", and am not very confident grappling with configuration files via Terminal.

Kind regards,
Pete
 
Old 05-29-2008, 10:36 AM   #2
cmnorton
Member
 
Registered: Feb 2005
Distribution: Ubuntu, CentOS
Posts: 585

Rep: Reputation: 35
Ubuntu Launchpad

Can you ping any of the sites you cannot reach?

By all means enter this as a bug in Ubuntu Launchpad https://launchpad.net/ubuntu because there have been many, many 8.04 annoyances.

I am waiting for the early July "point" release to 8.04. I tried an 8.04 upgrade, a full install, and wound up going back to 7.10.

I have new (Thinkpad T61p) hardware, as well, though I did not try this upgrade on non-laptop hardware, which I usually find an easier experience.
 
Old 05-29-2008, 04:14 PM   #3
adcockp
LQ Newbie
 
Registered: Mar 2008
Location: Hungerford, UK
Distribution: Ubuntu 8.04 LTS
Posts: 7

Original Poster
Rep: Reputation: 0
Ah now this is interesting!!!
But I'm not sure what it means...

If I ping via the domain name; i.e. "Ping www.google.co.uk"
ping reports a failure; i.e. "ping: unknown host www.google.co.uk"

However, if I ping the self-same server using its IP;
i.e. "Ping 64.233.183.104"
ping reports success; i.e.
"PING 64.233.183.104 (64.233.183.104) 56(84) bytes of data
64 bytes from 64.233.183.104: icmp_seq=1 ttl=242 time=57.6 ms
64 bytes from 64.233.183.104: icmp_seq=2 ttl=242 time=58.7 ms
64 bytes from 64.233.183.104: icmp_seq=3 ttl=242 time=57.7 ms
...
64 bytes from 64.233.183.104: icmp_seq=8 ttl=242 time=57.3 ms

--- 64.233.183.104 ping statistics ---
8 packets transmitted, 8 received, 0% packet loss, time 6998ms"

Pinging www.google.com works just fine, all the servers I have tried with domain suffixes of ".co.uk" behave like google.co.uk

Thanks for the speedy response, but before I log it as a bug, are we absolutely sure it couldn't be something to do with my local configuration?
 
Old 05-30-2008, 07:32 AM   #4
cmnorton
Member
 
Registered: Feb 2005
Distribution: Ubuntu, CentOS
Posts: 585

Rep: Reputation: 35
Domain?

Does your system participate in a domain, and, if so, is this domain reflected in your /etc/resolv.conf?

search your-domain-name
 
Old 05-30-2008, 10:27 AM   #5
adcockp
LQ Newbie
 
Registered: Mar 2008
Location: Hungerford, UK
Distribution: Ubuntu 8.04 LTS
Posts: 7

Original Poster
Rep: Reputation: 0
Thanks for staying with me on this.

OK, we're moving into uncharted territory, but here goes. Please bear with me if any of this is irrelevant, just plain dumb, or not the answer to the question you are asking.

The Linux box is not participating in a domain, all my current networking is simple peer-to-peer stuff via the router.

I do have a resolv.conf file, and this is what it contains...

search domain_not_set.invalid
nameserver 128.86.1.20
nameserver 212.77.0.2
nameserver 212.139.132.56
nameserver 212.139.132.57
nameserver 192.168.1.1

I do not know what the line "search domain_not_set.invalid" is all about, but the other entries are:

128.86.1.20 (ns0.ja.net), and,
212.77.0.2 (michael.vatican.va)
are "non censoring" DNS servers that I entered as "static DNS"
via my router's configuration utility. You can blame Wallace Wang
and his interesting book "Steal this computer book 4.0" for these.
Actually it was just a bit of fun months ago to see if I got
different search results if I used different DNS from my ISP's
default servers. I can remove them if you think they're causing
the issue, but surely if they were IE on the WinXP machines
would be SNAFU too?

212.139.132.56 (man-cache-0-a-1.ns.uk.tiscali.com), and,
212.139.132.56 (man-cache-1-a-1.ns.uk.tiscali.com)
are the ISPs default DNS

Finally, 192.168.1.1 is my router.

See anything odd here?

Although I am not in a domain, I notice from running
"System/Administration/Services" that the machine appears to
be running something called:
"Multicast DNS service discovery (avahi-daemon)"

Disabling this and re-starting the machine (not sure if this part's necessary) had no visible effect, in that networking still appears to be working fine and the ".co.uk" suffixed domains are still unreachable.

After the test I have re-enabled it just in case it was doing something important though.

Hope some of this helps.

Regards,
Pete
 
Old 05-31-2008, 07:46 AM   #6
adcockp
LQ Newbie
 
Registered: Mar 2008
Location: Hungerford, UK
Distribution: Ubuntu 8.04 LTS
Posts: 7

Original Poster
Rep: Reputation: 0
I think I've identified the issue... But not the fix

OK I've been doing some digging.

cmnorton, you are on the right track with the "resolv.conf" file.

The issue appears to be the SEQUENCING of the "nameserver" entries within the "resolv.conf" file.

My original file looked like this...

search domain_not_set.invalid
nameserver 128.86.1.20
nameserver 212.77.0.2
nameserver 212.139.132.56
nameserver 212.139.132.57
nameserver 192.168.1.1

Changing it so the router is the first nameserver in the list, like this, enables the Linux box to see ".co.uk" domains...

search domain_not_set.invalid
nameserver 192.168.1.1
nameserver 128.86.1.20
nameserver 212.77.0.2
nameserver 212.139.132.56
nameserver 212.139.132.57

This of course also solves the problem with Evolution too. The effect of changing the file is immediate (no re-boot/service re-start is required).

Now here's the problem... "resolv.conf" appears to be recreated automatically by the system during the boot process. Which means that the above is OK as a temporary workaround, but I'm really looking for a permanent fix.

IP addresses within my network are automatically allocated by my router (a Linksys WAG354g v2) which functions as the DHCP for the network.

Ubuntu's network configuration is set-up to reflect this "Automatic Configuration (DHCP)". So, I believe the software is doing what it is supposed to, it's just entering the nameservers in the wrong order while building the "resolv.conf" file.

Does anyone know if there is a way to control the ordering of the nameserver entries during this process?
 
Old 05-31-2008, 05:18 PM   #7
adcockp
LQ Newbie
 
Registered: Mar 2008
Location: Hungerford, UK
Distribution: Ubuntu 8.04 LTS
Posts: 7

Original Poster
Rep: Reputation: 0
SUCCESS! -- Well, after a fashion

I've been doing some more digging via Google and other forums and have come up with something that fixes my issue, but rather inelegantly.

The Linux box's DHCP client behaiour is apparently controlled by a file called "dhclient.conf". On this system, this is found in the directory "/etc/dhcp3". And it looks like this...

# Configuration file for /sbin/dhclient, which is included in Debian's
# dhcp3-client package.
#
# This is a sample configuration file for dhclient. See dhclient.conf's
# man page for more information about the syntax of this file
# and a more comprehensive list of the parameters understood by
dhclient.
#
# Normally, if the DHCP server provides reasonable information and does
# not leave anything out (like the domain name, for example), then
# few changes must be made to this file, if any.
#

send host-name "<hostname>";
#send dhcp-client-identifier 1:0:a0:24:ab:fb:9c;
#send dhcp-lease-time 3600;
#supersede domain-name "fugue.com home.vix.com";
#prepend domain-name-servers 127.0.0.1;
request subnet-mask, broadcast-address, time-offset, routers,
domain-name, domain-name-servers, host-name,
netbios-name-servers, netbios-scope;
#require subnet-mask, domain-name-servers;
timeout 30;
#retry 60;
#reboot 10;
#select-timeout 5;
#initial-interval 2;
#script "/etc/dhcp3/dhclient-script";
#media "-link0 -link1 -link2", "link0 link1";
#reject 192.33.137.209;

#alias {
# interface "eth0";
# fixed-address 192.5.5.213;
# option subnet-mask 255.255.255.255;
#}

#lease {
# interface "eth0";
# fixed-address 192.33.137.200;
# medium "link0 link1";
# option host-name "andare.swiftmedia.com";
# option subnet-mask 255.255.255.0;
# option broadcast-address 192.33.137.255;
# option routers 192.33.137.250;
# option domain-name-servers 127.0.0.1;
# renew 2 2000/1/12 00:00:01;
# rebind 2 2000/1/12 00:00:01;
# expire 2 2000/1/12 00:00:01;
#}

Although it looks busy, most of the lines in it are in fact commented out examples. Stripping all this out (because it does nothing) we are left with a much simpler view...

send host-name "<hostname>";
request subnet-mask, broadcast-address, time-offset, routers,
domain-name, domain-name-servers, host-name,
netbios-name-servers, netbios-scope;
timeout 30;

Inserting a "prepend" instruction into the file AFTER the "request" instruction I was able to force an entry for the router before the details entered automatically.

It now looks like this...

send host-name "<hostname>";
request subnet-mask, broadcast-address, time-offset, routers,
domain-name, domain-name-servers, host-name,
netbios-name-servers, netbios-scope;
prepend domain-name-servers 192.168.1.1;
timeout 30;

This has achieved (at least part of) the desired result, because the automatically generated "resolv.conf" file now looks like this...

search domain_not_set.invalid
nameserver 192.168.1.1
nameserver 128.86.1.20
nameserver 212.77.0.2
nameserver 212.139.132.56
nameserver 212.139.132.57
nameserver 192.168.1.1

And this gets around my ".co.uk" suffixed domain names issue!!

However, the duplicate entry for the router in the list doesn't really satisfy my desire for tidiness, and might be a cause other problems further down the line. But I don't know enough to know this.

So, where I am at is that I have groped around and stumbled upon something that "kinda" works. I am sure there is a better (correct) way of configuring the DNS search path, but I lack the skills to find it.

If there is anyone out there that does know a better way I'd be really glad to hear from you.

Regards,
Pete
 
Old 06-02-2008, 02:12 PM   #8
adcockp
LQ Newbie
 
Registered: Mar 2008
Location: Hungerford, UK
Distribution: Ubuntu 8.04 LTS
Posts: 7

Original Poster
Rep: Reputation: 0
Question Not success at all afterall :o(

It seems that the "solution" I came up with on Sunday did not work at all... Well it did, but only for the duration of the IP lease issued by the DHCP whereupon access to ".co.uk" domains stopped again.

This makes NO SENSE TO ME AT ALL, but if I edit the "resolv.conf" file again, and make it look EXACTLY the same as it did before the edit (change something and put it back) access to ".co.uk" suffixed domains starts working again!

I really need help from someone who knows what they're talking about to sort this out, if anyone can spare the time.
 
Old 06-06-2008, 01:37 AM   #9
adcockp
LQ Newbie
 
Registered: Mar 2008
Location: Hungerford, UK
Distribution: Ubuntu 8.04 LTS
Posts: 7

Original Poster
Rep: Reputation: 0
Hi,

It's been a while since the last post. I'm really at a loss as to where to go next. Does anyone have any ideas, or am I on my own?

Regards,
Pete
 
Old 06-07-2008, 09:43 PM   #10
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
Wink

Hi Pete,

Dunno if this will help, and believe me, I'm a trial and error man myself!!

This is your stripped out dhclient.conf file:

Quote:

send host-name "<hostname>";
request subnet-mask, broadcast-address, time-offset, routers,
domain-name, domain-name-servers, host-name,
netbios-name-servers, netbios-scope;
prepend domain-name-servers 192.168.1.1;
timeout 30;
And this is your list in resolv.conf:

Quote:

search domain_not_set.invalid
nameserver 192.168.1.1
nameserver 128.86.1.20
nameserver 212.77.0.2
nameserver 212.139.132.56
nameserver 212.139.132.57
nameserver 192.168.1.1
Seems to me that "netbios-name-servers" is your router: '192.168.1.1'
And because you use a peer to peer system, the rest are populated from your preceding resolv.conf? Or else from your router?

What you could try doing is moving "netbios-name-servers" to a position further to the top in your dhclient.conf file? You can also remove the "prepend" statement from the end.

Give it a go, let us know how you get on!

Anyway, that's my , and I have to tell you it may require a bit of original research! PhD stuff for sure, but that's Linux, even with Ubuntu!
 
Old 06-07-2008, 09:47 PM   #11
irishbitte
Senior Member
 
Registered: Oct 2007
Location: Brighton, UK
Distribution: Ubuntu Hardy, Ubuntu Jaunty, Eeebuntu, Debian, SME-Server
Posts: 1,213
Blog Entries: 1

Rep: Reputation: 82
Oh yeah, BTW, you can set up DNS on your router if it's sufficiently capable, and then remove all this stuff from happening at bootup, and set your clients to use your router as their "only" DNS lookup!

You said earlier that when you prepended domain-name-servers to be 192.168.1.1, your .co.uk problem went away. That's because your router is already set up to handle DNS, and your clients only have to look at your router for DNS?

Good luck anyway!!
 
  


Reply

Tags
networking, ubuntu, upgrade


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet connection just stops wchawaguta Linux - Hardware 2 11-16-2007 06:17 AM
My internet connection stops!! xowl Linux - Networking 1 06-30-2005 03:08 PM
Internet Connection Stops spaaarky21 Debian 5 01-31-2005 12:43 AM
I can't work Shorewall it stops my internet connection ralphus Linux - Newbie 5 11-13-2003 03:41 PM


All times are GMT -5. The time now is 07:18 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration