LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Distributions > Ubuntu
User Name
Password
Ubuntu This forum is for the discussion of Ubuntu Linux.

Notices

Reply
 
Search this Thread
Old 02-12-2009, 05:06 PM   #1
dcordina
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Rep: Reputation: 0
setting up dansguardian as a transparent proxy for hosts


I managed to install squid, transguardian and firestarter on ubuntu 8.10. Locally it works. I setup the proxy settings of firefox to 127.0.0.1:8080 and works perfectly. when I did the same on windows machine (meaning configured ie) it did not work. Now I need two things. One to configure the proxy to be transparent and to connect other hosts to this linux machine without the need to amend any setting in the connection of the internet browser.
 
Old 02-22-2009, 09:04 AM   #2
archtoad6
Senior Member
 
Registered: Oct 2004
Location: Houston, TX (usa)
Distribution: MEPIS, Debian, Knoppix,
Posts: 4,727
Blog Entries: 15

Rep: Reputation: 230Reputation: 230Reputation: 230
Smile Welcome

Welcome to LQ.

I'm not sure what you've got & what you are trying to do w/ it, starting w/ your title. Isn't squid the proxy, not Dansguardian? And what is this "transguardian" that you mention in your post?

Is the Ubuntu 8.10 box on which you "managed to install squid, transguardian and firestarter" a dedicated firewall/router/gateway, or a workstation that is doing double duty?

If you are asking Ubuntu 8.10 to do double duty, I would find an old "doorstop" & set it up as a dedicated firewall/router/gateway. I would not use any desktop or even server distro for this function, I would install a specialty distro on a dedicated box, like:(I have worked w/ the 1st 2, extensively w/ SmoothWall Express)
 
Old 02-28-2009, 09:32 AM   #3
jdavis2
Member
 
Registered: Feb 2007
Distribution: Fedora, Mandrake, Knoppix, Windows XP
Posts: 37

Rep: Reputation: 15
If you still want to go that route!

First it is possible that the reason it did not work from your external box is that your firewall might have been turned on and blocking external requests.

As far as setting up the transparent proxy, this worked for me.

http://www.faqs.org/docs/Linux-mini/...rentProxy.html

You may need to make adjustments to the port assignments depending on if you want the traffic to go through squid only or to hit transgaurdian first.

Last edited by jdavis2; 02-28-2009 at 09:35 AM.
 
Old 03-02-2009, 08:57 AM   #4
dcordina
LQ Newbie
 
Registered: Feb 2009
Posts: 9

Original Poster
Rep: Reputation: 0
solved

I managed to solve the issue. The problem was routing protocol towards the right protocol meaning port 80 to 8080. thanks
 
  


Reply

Tags
proxy


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
IPTABLES, SQUID, DANSGUARDIAN and Transparent Proxy metallica1973 Linux - Networking 18 09-03-2007 07:17 PM
setting up transparent proxy tsaravan Linux - Networking 4 03-30-2007 07:44 AM
FC4 - How to setup Transparent Proxy with Dansguardian RTX Networks Linux - Networking 1 09-12-2006 12:49 AM
proxy/dansguardian trouble metallica1973 Linux - Software 8 04-21-2006 12:23 AM
squid (Transparent proxy) & Dansguardian metallica1973 Linux - Security 8 12-15-2005 07:52 PM


All times are GMT -5. The time now is 03:33 PM.

Main Menu
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
identi.ca: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration